summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-09-17 06:23:41 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-09-17 06:23:41 +0000
commit8e5d7647cff953a3b03ef6e1b0515bec3c3d2ac6 (patch)
treec2d14ffecfe01f489a59ca3647d6409d9bf18f68 /app-editors
parentFixed typo in elog message: point to correct location at upstream's wiki (diff)
downloadgentoo-2-8e5d7647cff953a3b03ef6e1b0515bec3c3d2ac6.tar.gz
gentoo-2-8e5d7647cff953a3b03ef6e1b0515bec3c3d2ac6.tar.bz2
gentoo-2-8e5d7647cff953a3b03ef6e1b0515bec3c3d2ac6.zip
respect LDFLAGS, bug 337718; move to EAPI 3
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/teco/ChangeLog5
-rw-r--r--app-editors/teco/teco-1.00-r3.ebuild11
2 files changed, 10 insertions, 6 deletions
diff --git a/app-editors/teco/ChangeLog b/app-editors/teco/ChangeLog
index 5a6409c335c3..2afeeca0da03 100644
--- a/app-editors/teco/ChangeLog
+++ b/app-editors/teco/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/teco
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/teco/ChangeLog,v 1.21 2010/01/15 02:12:22 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/teco/ChangeLog,v 1.22 2010/09/17 06:23:41 fauli Exp $
+
+ 17 Sep 2010; Christian Faulhammer <fauli@gentoo.org> teco-1.00-r3.ebuild:
+ respect LDFLAGS, bug 337718; move to EAPI 3
15 Jan 2010; Jonathan Callen <abcd@gentoo.org> +files/teco-gcc4.patch,
teco-1.00-r3.ebuild:
diff --git a/app-editors/teco/teco-1.00-r3.ebuild b/app-editors/teco/teco-1.00-r3.ebuild
index 5bb70c7e8e46..cd7ae7929945 100644
--- a/app-editors/teco/teco-1.00-r3.ebuild
+++ b/app-editors/teco/teco-1.00-r3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/teco/teco-1.00-r3.ebuild,v 1.9 2010/01/15 02:12:22 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/teco/teco-1.00-r3.ebuild,v 1.10 2010/09/17 06:23:41 fauli Exp $
+
+EAPI=3
inherit toolchain-funcs flag-o-matic
@@ -22,9 +24,8 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}
-src_unpack() {
- unpack ${A}
- sed -i -e 's:-ltermcap:-lncurses:' Makefile
+src_prepare() {
+ sed -e 's:$(CC) -o te $(OBJS):$(CC) ${LDFLAGS} -o te $(OBJS):' -e 's:-ltermcap:-lncurses:' -i Makefile || die
# bug 103257
epatch "${FILESDIR}"/${PN}-double-free.diff
epatch "${FILESDIR}"/${PN}-gcc4.patch
@@ -32,7 +33,7 @@ src_unpack() {
src_compile() {
append-flags -ansi -D_POSIX_SOURCE
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "compilation failed"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die
}
src_install() {