summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-07-22 18:47:18 +0000
committerUlrich Müller <ulm@gentoo.org>2007-07-22 18:47:18 +0000
commit92d2d1165c4e5f65078fdaa568402d4f7e5fb4df (patch)
treea698d52fa4a5fec4b9aa1989e675a4ade6b4e8bf /app-editors
parentAdded 2.4.34.6. (diff)
downloadgentoo-2-92d2d1165c4e5f65078fdaa568402d4f7e5fb4df.tar.gz
gentoo-2-92d2d1165c4e5f65078fdaa568402d4f7e5fb4df.tar.bz2
gentoo-2-92d2d1165c4e5f65078fdaa568402d4f7e5fb4df.zip
Fix X dependencies.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/qemacs/ChangeLog6
-rw-r--r--app-editors/qemacs/qemacs-0.3.1-r3.ebuild15
-rw-r--r--app-editors/qemacs/qemacs-0.3.2_pre20070226.ebuild15
3 files changed, 19 insertions, 17 deletions
diff --git a/app-editors/qemacs/ChangeLog b/app-editors/qemacs/ChangeLog
index 8581d27977b1..29654fe38848 100644
--- a/app-editors/qemacs/ChangeLog
+++ b/app-editors/qemacs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/qemacs
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/ChangeLog,v 1.28 2007/07/22 08:58:00 omp Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/ChangeLog,v 1.29 2007/07/22 18:47:18 ulm Exp $
+
+ 22 Jul 2007; Ulrich Mueller <ulm@gentoo.org> qemacs-0.3.1-r3.ebuild,
+ qemacs-0.3.2_pre20070226.ebuild:
+ Fix X dependencies.
22 Jul 2007; David Shakaryan <omp@gentoo.org> qemacs-0.3.1-r3.ebuild:
Remove virtual/x11 from dependencies.
diff --git a/app-editors/qemacs/qemacs-0.3.1-r3.ebuild b/app-editors/qemacs/qemacs-0.3.1-r3.ebuild
index 1b5cec06438a..a85e4ba0dccc 100644
--- a/app-editors/qemacs/qemacs-0.3.1-r3.ebuild
+++ b/app-editors/qemacs/qemacs-0.3.1-r3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.3.1-r3.ebuild,v 1.8 2007/07/22 08:58:00 omp Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.3.1-r3.ebuild,v 1.9 2007/07/22 18:47:18 ulm Exp $
inherit eutils versionator flag-o-matic
-DESCRIPTION="QEmacs (for Quick Emacs) is a very small but powerful UNIX editor."
+DESCRIPTION="QEmacs (for Quick Emacs) is a very small but powerful UNIX editor"
HOMEPAGE="http://fabrice.bellard.free.fr/qemacs/"
SRC_URI="http://fabrice.bellard.free.fr/qemacs/${P}.tar.gz"
@@ -13,13 +13,12 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="X png unicode xv"
-# For those so inclined, the libXv dep can probably
-# be made conditional on the xv USE flag somehow.
-RDEPEND="X? ( x11-libs/libXv )
+DEPEND="X? ( x11-libs/libX11
+ x11-libs/libXext
+ xv? ( x11-libs/libXv ) )
png? ( =media-libs/libpng-1.2* )"
-DEPEND="${RDEPEND}
- X? ( x11-libs/libXft
- x11-proto/xextproto )"
+
+RDEPEND="${DEPEND}"
PROVIDE="virtual/editor"
src_unpack() {
diff --git a/app-editors/qemacs/qemacs-0.3.2_pre20070226.ebuild b/app-editors/qemacs/qemacs-0.3.2_pre20070226.ebuild
index 74801594fba2..5e0f0f740e13 100644
--- a/app-editors/qemacs/qemacs-0.3.2_pre20070226.ebuild
+++ b/app-editors/qemacs/qemacs-0.3.2_pre20070226.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.3.2_pre20070226.ebuild,v 1.3 2007/06/24 21:05:54 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.3.2_pre20070226.ebuild,v 1.4 2007/07/22 18:47:18 ulm Exp $
inherit eutils versionator flag-o-matic
-DESCRIPTION="Quick Emacs is a very small but powerful UNIX editor."
+DESCRIPTION="QEmacs (for Quick Emacs) is a very small but powerful UNIX editor"
HOMEPAGE="http://fabrice.bellard.free.fr/qemacs/"
SRC_URI="http://fabrice.bellard.free.fr/qemacs/${P}.tar.bz2"
@@ -14,13 +14,12 @@ KEYWORDS="~amd64 ~ppc ~x86"
IUSE="X png unicode xv"
RESTRICT="strip"
-# For those so inclined, the libXv dep can probably
-# be made conditional on the xv USE flag somehow.
-RDEPEND="X? ( x11-libs/libXv )
+DEPEND="X? ( x11-libs/libX11
+ x11-libs/libXext
+ xv? ( x11-libs/libXv ) )
png? ( =media-libs/libpng-1.2* )"
-DEPEND="${RDEPEND}
- X? ( x11-libs/libXft
- x11-proto/xextproto )"
+
+RDEPEND="${DEPEND}"
PROVIDE="virtual/editor"
src_unpack() {