summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-02-19 16:27:51 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-02-19 16:27:51 +0000
commit953dc286c1a66d6cdb983566676fdba3f34aa494 (patch)
tree7d733897517ceb314ee4c9fada2d45129d698a65 /app-editors
parentVersion bump. (diff)
downloadgentoo-2-953dc286c1a66d6cdb983566676fdba3f34aa494.tar.gz
gentoo-2-953dc286c1a66d6cdb983566676fdba3f34aa494.tar.bz2
gentoo-2-953dc286c1a66d6cdb983566676fdba3f34aa494.zip
Version bump, fix compilation with glibmm 2.31 or greater
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gobby/ChangeLog9
-rw-r--r--app-editors/gobby/gobby-0.4.13.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/app-editors/gobby/ChangeLog b/app-editors/gobby/ChangeLog
index b6d87255a78c..2adf45dc7390 100644
--- a/app-editors/gobby/ChangeLog
+++ b/app-editors/gobby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/gobby
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/ChangeLog,v 1.45 2011/04/30 09:50:35 xarthisius Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/ChangeLog,v 1.46 2012/02/19 16:27:51 xarthisius Exp $
+
+*gobby-0.4.13 (19 Feb 2012)
+
+ 19 Feb 2012; Kacper Kowalik <xarthisius@gentoo.org> +gobby-0.4.13.ebuild:
+ Version bump, fix compilation with glibmm 2.31 or greater
*gobby-0.4.94 (30 Apr 2011)
diff --git a/app-editors/gobby/gobby-0.4.13.ebuild b/app-editors/gobby/gobby-0.4.13.ebuild
new file mode 100644
index 000000000000..80e782846763
--- /dev/null
+++ b/app-editors/gobby/gobby-0.4.13.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/gobby-0.4.13.ebuild,v 1.1 2012/02/19 16:27:51 xarthisius Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="GTK-based collaborative editor"
+HOMEPAGE="http://gobby.0x539.de/"
+SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="avahi gnome"
+
+RDEPEND="dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ dev-libs/libsigc++:2
+ >=net-libs/obby-0.4.6[avahi?]
+ dev-cpp/libxmlpp:2.6
+ x11-libs/gtksourceview:2.0
+ gnome? ( gnome-base/gnome-vfs )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+# There's only one test and it needs X
+RESTRICT="test"
+
+src_configure() {
+ econf \
+ --with-gtksourceview2 \
+ $(use_with gnome)
+}
+
+src_install() {
+ default
+ domenu contrib/gobby.desktop
+}