summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé Luis Rivero <yoswink@gentoo.org>2009-04-29 18:58:32 +0000
committerJosé Luis Rivero <yoswink@gentoo.org>2009-04-29 18:58:32 +0000
commit964b44ddddbf1750d73f1dd95a840744371a9d63 (patch)
treea7bfab0cb015d3299cd039ecde5b7cad5d568132 /app-editors
parentVersion bump, bug #267814. Use QA_TEXTRELS to suppres warnings, bug #265171. (diff)
downloadgentoo-2-964b44ddddbf1750d73f1dd95a840744371a9d63.tar.gz
gentoo-2-964b44ddddbf1750d73f1dd95a840744371a9d63.tar.bz2
gentoo-2-964b44ddddbf1750d73f1dd95a840744371a9d63.zip
New revision. New dependency on libxml2-2.7.3-r1, see bug #264176 for details. Ebuild migrated to EAPI 2 format. Explicit RDEPEND = DEPEND.
(Portage version: 2.2_rc31/cvs/Linux i686)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/xmlcopyeditor/ChangeLog11
-rw-r--r--app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.2-r2.ebuild42
2 files changed, 51 insertions, 2 deletions
diff --git a/app-editors/xmlcopyeditor/ChangeLog b/app-editors/xmlcopyeditor/ChangeLog
index 80c54131fab6..2f07328dc27d 100644
--- a/app-editors/xmlcopyeditor/ChangeLog
+++ b/app-editors/xmlcopyeditor/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/xmlcopyeditor
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/ChangeLog,v 1.11 2008/10/24 21:13:39 pvdabeel Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/ChangeLog,v 1.12 2009/04/29 18:58:32 yoswink Exp $
+
+*xmlcopyeditor-1.2.0.2-r2 (29 Apr 2009)
+
+ 29 Apr 2009; Jose Luis Rivero <yoswink@gentoo.org>
+ +xmlcopyeditor-1.2.0.2-r2.ebuild:
+ New revision. New dependency on libxml2-2.7.3-r1, see bug #264176 for
+ details. Ebuild migrated to EAPI 2 format. Explicit RDEPEND = DEPEND.
*xmlcopyeditor-1.2.0.2-r1 (10 Oct 2008)
diff --git a/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.2-r2.ebuild b/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.2-r2.ebuild
new file mode 100644
index 000000000000..bdf3f0031d55
--- /dev/null
+++ b/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.2-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.2-r2.ebuild,v 1.1 2009/04/29 18:58:32 yoswink Exp $
+
+EAPI="2"
+
+WX_GTK_VER="2.8"
+
+inherit wxwidgets
+
+DESCRIPTION="XML Copy Editor is a fast, free, validating XML editor"
+HOMEPAGE="http://xml-copy-editor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xml-copy-editor/${P}.tar.gz
+ guidexml? ( mirror://gentoo/GuideXML-templates.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="guidexml"
+
+DEPEND=">=dev-libs/libxml2-2.7.3-r1 \
+ dev-libs/libxslt \
+ dev-libs/xerces-c \
+ dev-libs/boost \
+ dev-libs/libpcre \
+ app-text/aspell \
+ x11-libs/wxGTK:2.8[X]"
+
+RDEPEND=${DEPEND}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ if use guidexml; then
+ insinto /usr/share/xmlcopyeditor/templates/
+ for TEMPLATE in "${WORKDIR}"/GuideXML-templates/*.xml; do
+ newins "${TEMPLATE}" "${TEMPLATE##*/}" || die "GuideXML templates failed"
+ done
+ fi
+
+ dodoc AUTHORS ChangeLog README NEWS
+}