summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2011-02-21 06:17:02 +0000
committerJeremy Olexa <darkside@gentoo.org>2011-02-21 06:17:02 +0000
commitabe91a0d78d6c753435c42fef2abc14c5c174fa0 (patch)
tree3c2cf26298059794a7b1e371846d20a3b6f99ab0 /app-editors
parentUpdated with patch for bug 339751 (adds gdk-pixbuf2 detection). (diff)
downloadgentoo-2-abe91a0d78d6c753435c42fef2abc14c5c174fa0.tar.gz
gentoo-2-abe91a0d78d6c753435c42fef2abc14c5c174fa0.tar.bz2
gentoo-2-abe91a0d78d6c753435c42fef2abc14c5c174fa0.zip
Fixes for macos, bug 352991 by Johan Hattne
(Portage version: 2.1.9.40/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nedit/ChangeLog6
-rw-r--r--app-editors/nedit/nedit-5.5_p20110116.ebuild18
2 files changed, 20 insertions, 4 deletions
diff --git a/app-editors/nedit/ChangeLog b/app-editors/nedit/ChangeLog
index f359a720d9ce..8b43733c17a7 100644
--- a/app-editors/nedit/ChangeLog
+++ b/app-editors/nedit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/nedit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/ChangeLog,v 1.63 2011/01/16 20:20:46 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/ChangeLog,v 1.64 2011/02/21 06:17:02 darkside Exp $
+
+ 21 Feb 2011; Jeremy Olexa <darkside@gentoo.org>
+ nedit-5.5_p20110116.ebuild:
+ Fixes for macos, bug 352991 by Johan Hattne
*nedit-5.5_p20110116 (16 Jan 2011)
diff --git a/app-editors/nedit/nedit-5.5_p20110116.ebuild b/app-editors/nedit/nedit-5.5_p20110116.ebuild
index 4e939cecf412..5d2478dc93ae 100644
--- a/app-editors/nedit/nedit-5.5_p20110116.ebuild
+++ b/app-editors/nedit/nedit-5.5_p20110116.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/nedit-5.5_p20110116.ebuild,v 1.1 2011/01/16 20:20:47 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/nedit-5.5_p20110116.ebuild,v 1.2 2011/02/21 06:17:02 darkside Exp $
EAPI=2
@@ -12,7 +12,7 @@ SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="spell"
RDEPEND="spell? ( virtual/aspell-dict )
@@ -40,10 +40,22 @@ src_prepare() {
src_configure() {
sed -i -e "s:CFLAGS=-O:CFLAGS=${CFLAGS}:" -e "s:check_tif_rule::" \
makefiles/Makefile.linux || die
+ sed -i -e "s:CFLAGS=-O:CFLAGS=${CFLAGS}:" \
+ -e "s:MOTIFDIR=/usr/local:MOTIFDIR=${EPREFIX}/usr:" \
+ -e "s:-lX11:-lX11 -lXmu -liconv:" \
+ -e "s:check_tif_rule::" \
+ makefiles/Makefile.macosx || die
}
src_compile() {
- emake CC="$(tc-getCC)" linux || die
+ case ${CHOST} in
+ *-darwin*)
+ emake CC="$(tc-getCC)" macosx || die
+ ;;
+ *-linux*)
+ emake CC="$(tc-getCC)" linux || die
+ ;;
+ esac
emake VERSION="NEdit ${PV}" -j1 -C doc all || die
}