summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2010-01-22 23:57:51 +0000
committerDaniel Pielmeier <billie@gentoo.org>2010-01-22 23:57:51 +0000
commitbf8d7fda1fd0066071cc0cf1cb0c1b92db465207 (patch)
treed3def4c9ceb82255598d2a2ce6cfdf8546719095 /app-editors
parentNew revision does not install docs any more since they only consisted of the ... (diff)
downloadgentoo-2-bf8d7fda1fd0066071cc0cf1cb0c1b92db465207.tar.gz
gentoo-2-bf8d7fda1fd0066071cc0cf1cb0c1b92db465207.tar.bz2
gentoo-2-bf8d7fda1fd0066071cc0cf1cb0c1b92db465207.zip
Version bump. Fixes Bug #298146. Thanks to Jesús Guerrero for reporting. Remove old.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/bluefish/ChangeLog12
-rw-r--r--app-editors/bluefish/bluefish-2.0.0_rc1.ebuild (renamed from app-editors/bluefish/bluefish-1.3.7.ebuild)22
-rw-r--r--app-editors/bluefish/files/bluefish-2.0.0_rc1-gucharmap-automagic.patch60
3 files changed, 85 insertions, 9 deletions
diff --git a/app-editors/bluefish/ChangeLog b/app-editors/bluefish/ChangeLog
index d8dfc6fbe812..0e8373d5b4bf 100644
--- a/app-editors/bluefish/ChangeLog
+++ b/app-editors/bluefish/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-editors/bluefish
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/ChangeLog,v 1.66 2009/11/17 18:49:57 billie Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/ChangeLog,v 1.67 2010/01/22 23:57:50 billie Exp $
+
+*bluefish-2.0.0_rc1 (22 Jan 2010)
+
+ 22 Jan 2010; Daniel Pielmeier <billie@gentoo.org> -bluefish-1.3.7.ebuild,
+ +bluefish-2.0.0_rc1.ebuild,
+ +files/bluefish-2.0.0_rc1-gucharmap-automagic.patch:
+ Version bump. Fixes Bug #298146. Thanks to Jesús Guerrero for reporting.
+ Remove old.
*bluefish-1.3.8 (17 Nov 2009)
diff --git a/app-editors/bluefish/bluefish-1.3.7.ebuild b/app-editors/bluefish/bluefish-2.0.0_rc1.ebuild
index 2c8923595b34..d4af5679dd9e 100644
--- a/app-editors/bluefish/bluefish-1.3.7.ebuild
+++ b/app-editors/bluefish/bluefish-2.0.0_rc1.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-1.3.7.ebuild,v 1.1 2009/09/23 12:31:43 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-2.0.0_rc1.ebuild,v 1.1 2010/01/22 23:57:50 billie Exp $
-EAPI="2"
+EAPI=2
-inherit eutils fdo-mime
+inherit autotools eutils fdo-mime
IUSE="nls spell gnome python"
-MY_P="${PN}-unstable-${PV}"
+MY_P=${P/_/-}
DESCRIPTION="A GTK HTML editor for the experienced web designer or programmer."
-SRC_URI="http://www.bennewitz.com/bluefish/devel/source/${MY_P}.tar.bz2"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
HOMEPAGE="http://bluefish.openoffice.nl/"
LICENSE="GPL-2"
@@ -32,7 +32,14 @@ DEPEND="${RDEPEND}
nls? ( sys-devel/gettext dev-util/intltool )
python? ( dev-lang/python )"
-S="${WORKDIR}/${MY_P}"
+S=${WORKDIR}/${MY_P}
+
+src_prepare () {
+ # Fixes automagic installation of charmap plugin
+ # Upstream bug: https://bugzilla.gnome.org/show_bug.cgi?id=570990
+ epatch "${FILESDIR}"/${P}-gucharmap-automagic.patch
+ eautoreconf
+}
src_configure() {
econf \
@@ -41,6 +48,7 @@ src_configure() {
--disable-xml-catalog-update \
$(use_enable nls) \
$(use_enable spell spell-check) \
+ $(use_enable gnome charmap) \
$(use_enable python)
}
diff --git a/app-editors/bluefish/files/bluefish-2.0.0_rc1-gucharmap-automagic.patch b/app-editors/bluefish/files/bluefish-2.0.0_rc1-gucharmap-automagic.patch
new file mode 100644
index 000000000000..d6097c6d6e00
--- /dev/null
+++ b/app-editors/bluefish/files/bluefish-2.0.0_rc1-gucharmap-automagic.patch
@@ -0,0 +1,60 @@
+--- configure.ac.old 2009-12-17 03:11:30.000000000 +0100
++++ configure.ac 2010-01-23 00:16:11.000000000 +0100
+@@ -421,29 +421,38 @@
+
+ PKG_CHECK_MODULES([BLUEFISH_REQUIRED], [$BF_dependencies])
+
+-# optionally build the charmap plugin if gucharmap is available
+-PKG_CHECK_MODULES(
+- [CHARMAP_PLUGIN],
+- [gucharmap-2],
+- [
+- build_charmap_plugin=yes
+- AC_DEFINE([HAVE_LIBGUCHARMAP_2], [1], [Define to 1 if you have the `gucharmap-2' library (-lgucharmap).])
+- ],
+- [PKG_CHECK_MODULES(
++# build the charmap plugin
++
++AC_ARG_ENABLE(
++ [charmap],
++ AC_HELP_STRING(
++ [--enable-charmap],
++ [enable (or disable) the charmap plugin needs gucharmap @<:@default=no@:>@]
++ )
++)
++
++if test "x$enable_charmap" != "xno"; then
++ PKG_CHECK_MODULES(
+ [CHARMAP_PLUGIN],
+- [gucharmap >= 2.20],
++ [gucharmap-2],
+ [
+ build_charmap_plugin=yes
+- AC_DEFINE([HAVE_LIBGUCHARMAP], [1], [Define to 1 if you have the `gucharmap' library (-lgucharmap).])
++ AC_DEFINE([HAVE_LIBGUCHARMAP_2], [1], [Define to 1 if you have the `gucharmap-2' library (-lgucharmap).])
+ ],
+- [
+- build_charmap_plugin=no
+- AC_MSG_WARN([Disabling the building of the charmap plugin.])
+- AC_MSG_WARN([Install gucharmap/gucharmap2 (>= 2.20) library/headers to build the plugin.])
+- ]
+- )]
+-)
+-AM_CONDITIONAL([ENABLE_CHARMAP_PLUGIN], [test "x$build_charmap_plugin" = "xyes"])
++ [PKG_CHECK_MODULES(
++ [CHARMAP_PLUGIN],
++ [gucharmap >= 2.20],
++ [
++ build_charmap_plugin=yes
++ AC_DEFINE([HAVE_LIBGUCHARMAP], [1], [Define to 1 if you have the `gucharmap' library (-lgucharmap).])
++ ],
++ )]
++ )
++ AM_CONDITIONAL([ENABLE_CHARMAP_PLUGIN], [test "x$build_charmap_plugin" = "xyes"])
++else
++ AM_CONDITIONAL([ENABLE_CHARMAP_PLUGIN], [test "x$build_charmap_plugin" = "xno"])
++ AC_MSG_NOTICE([Disable building charmap plugin.])
++fi
+
+ AC_SEARCH_LIBS([nanosleep], [posix4 rt])
+