summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-02-13 11:25:21 +0000
committerUlrich Müller <ulm@gentoo.org>2014-02-13 11:25:21 +0000
commitfb5b2f526d426eef61b822703e55bd0bdd2ce141 (patch)
tree54f44da774250f267a1cdde92e80a92c25b4dd3a /app-editors
parentInitial import. New dependency of dev-util/cucumber, code is extracted out of... (diff)
downloadgentoo-2-fb5b2f526d426eef61b822703e55bd0bdd2ce141.tar.gz
gentoo-2-fb5b2f526d426eef61b822703e55bd0bdd2ce141.tar.bz2
gentoo-2-fb5b2f526d426eef61b822703e55bd0bdd2ce141.zip
Remove old.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/mg/ChangeLog8
-rw-r--r--app-editors/mg/files/mg-20130922-dirname.patch52
-rw-r--r--app-editors/mg/mg-20130922-r2.ebuild58
3 files changed, 6 insertions, 112 deletions
diff --git a/app-editors/mg/ChangeLog b/app-editors/mg/ChangeLog
index 1c6f90807f0a..a0c08cc62202 100644
--- a/app-editors/mg/ChangeLog
+++ b/app-editors/mg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/mg
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mg/ChangeLog,v 1.65 2013/11/18 01:06:38 ulm Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mg/ChangeLog,v 1.66 2014/02/13 11:25:21 ulm Exp $
+
+ 13 Feb 2014; Ulrich Müller <ulm@gentoo.org> -mg-20130922-r2.ebuild,
+ -files/mg-20130922-dirname.patch:
+ Remove old.
*mg-20131118 (18 Nov 2013)
diff --git a/app-editors/mg/files/mg-20130922-dirname.patch b/app-editors/mg/files/mg-20130922-dirname.patch
deleted file mode 100644
index c8b93a702fbd..000000000000
--- a/app-editors/mg/files/mg-20130922-dirname.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-Fix dirname(3) call in readin and writeout functions.
-https://bugs.gentoo.org/487758
-
-Patch from OpenBSD CVS:
-http://www.openbsd.org/cgi-bin/cvsweb/src/usr.bin/mg/file.c.diff?r1=1.87;r2=1.89
-
---- mg-20130922-orig/file.c
-+++ mg-20130922/file.c
-@@ -210,7 +210,7 @@ readin(char *fname)
- struct stat statbuf;
- int status, i, ro = FALSE;
- PF *ael;
-- char *dp;
-+ char dp[NFILEN];
-
- /* might be old */
- if (bclear(curbp) != TRUE)
-@@ -255,7 +255,8 @@ readin(char *fname)
- if (errno != ENOENT)
- ro = TRUE;
- else if (errno == ENOENT) {
-- dp = dirname(fname);
-+ (void)xdirname(dp, fname, sizeof(dp));
-+ (void)strlcat(dp, "/", sizeof(dp));
- if (stat(dp, &statbuf) == -1 && errno == ENOENT) {
- /* no read-only; like emacs */
- ewprintf("Use M-x make-directory RET RET to "
-@@ -669,19 +670,17 @@ writeout(FILE ** ffp, struct buffer *bp, char *fn)
- {
- struct stat statbuf;
- int s;
-- char *dp;
-+ char dp[NFILEN];
-
-- dp = dirname(fn);
--
- if (stat(fn, &statbuf) == -1 && errno == ENOENT) {
- errno = 0;
-+ (void)xdirname(dp, fn, sizeof(dp));
-+ (void)strlcat(dp, "/", sizeof(dp));
- if (access(dp, W_OK) && errno == EACCES) {
-- ewprintf("Directory %s%s write-protected", dp,
-- (dp[0] == '/' && dp[1] == '\0') ? "" : "/");
-+ ewprintf("Directory %s write-protected", dp);
- return (FIOERR);
- } else if (errno == ENOENT) {
-- ewprintf("%s%s: no such directory", dp,
-- (dp[0] == '/' && dp[1] == '\0') ? "" : "/");
-+ ewprintf("%s: no such directory", dp);
- return (FIOERR);
- }
- }
diff --git a/app-editors/mg/mg-20130922-r2.ebuild b/app-editors/mg/mg-20130922-r2.ebuild
deleted file mode 100644
index 179763bdec54..000000000000
--- a/app-editors/mg/mg-20130922-r2.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mg/mg-20130922-r2.ebuild,v 1.1 2013/10/22 10:34:28 ulm Exp $
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="MicroGnuEmacs, a port from the BSDs"
-HOMEPAGE="http://homepage.boetes.org/software/mg/"
-SRC_URI="http://homepage.boetes.org/software/mg/${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~x86"
-IUSE="livecd"
-
-RDEPEND="sys-libs/ncurses"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- dev-libs/clens"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-dirname.patch
- epatch_user
-
- # create our own Makefile to avoid BSD make
- echo -e 'SRCS =' *.c '\n\nmg: $(SRCS:.c=.o)' \
- '\n\t$(CC) $(LDFLAGS) -o $@ $^ $(LDLIBS)' >Makefile || die
-
- # remove OpenBSD specific easter egg
- sed -i -e 's/theo\.c//' Makefile || die
- sed -i -e '/theo_init/d' main.c || die
-
- # fix path to tutorial in man page
- sed -i -e "s:doc/mg/:doc/${PF}/:" mg.1 || die
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" \
- CPPFLAGS="${CPPFLAGS} -DFKEYS -DREGEX -DXKEYS \
- -I${EPREFIX}/usr/include/clens" \
- LDLIBS="-lclens $("$(tc-getPKG_CONFIG)" --libs ncurses)"
-}
-
-src_install() {
- dobin mg
- doman mg.1
- dodoc README README_PORTING tutorial
- # don't compress the tutorial, otherwise mg cannot open it
- docompress -x /usr/share/doc/${PF}/tutorial
-}
-
-pkg_postinst() {
- if use livecd; then
- [[ -e ${EROOT}/usr/bin/emacs ]] || ln -s mg "${EROOT}"/usr/bin/emacs
- fi
-}