summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-06-18 19:08:51 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-06-18 19:08:51 +0000
commit903e97908e9f284be6e7670cd5e39366429ccb88 (patch)
tree7cb23a340ebd1e99e40b1f2a3f3e2a28984ee52c /app-emacs/cc-mode/cc-mode-5.31.3.ebuild
parentStable on x86. Bug #137181. (diff)
downloadgentoo-2-903e97908e9f284be6e7670cd5e39366429ccb88.tar.gz
gentoo-2-903e97908e9f284be6e7670cd5e39366429ccb88.tar.bz2
gentoo-2-903e97908e9f284be6e7670cd5e39366429ccb88.zip
Initial port. Ebuild contributed by Adam Piatyszek <ediap@et.put.poznan.pl> and Christian Schlotter <again@gmx.de>. Resolves Bug #93923.
(Portage version: 2.1)
Diffstat (limited to 'app-emacs/cc-mode/cc-mode-5.31.3.ebuild')
-rw-r--r--app-emacs/cc-mode/cc-mode-5.31.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-emacs/cc-mode/cc-mode-5.31.3.ebuild b/app-emacs/cc-mode/cc-mode-5.31.3.ebuild
new file mode 100644
index 000000000000..2876d8237a96
--- /dev/null
+++ b/app-emacs/cc-mode/cc-mode-5.31.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/cc-mode/cc-mode-5.31.3.ebuild,v 1.1 2006/06/18 19:08:51 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="An Emacs mode for editing and C and other languages with similar syntax."
+HOMEPAGE="http://cc-mode.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
+
+DEPEND=""
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-comp *.el || die
+ makeinfo ${PN}.texi || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc || die
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ dodoc README NEWS
+ doinfo ${PN}.info
+}