summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-04-14 15:06:39 +0000
committerUlrich Müller <ulm@gentoo.org>2009-04-14 15:06:39 +0000
commit2b6b264e3e2a19e4ed947e4a8faf1c851accb60f (patch)
tree2250b06a462c1874ef87e8e1bd9f3ee1daef2280 /app-emacs/company-mode
parentStable for HPPA (bug #264166). (diff)
downloadgentoo-2-2b6b264e3e2a19e4ed947e4a8faf1c851accb60f.tar.gz
gentoo-2-2b6b264e3e2a19e4ed947e4a8faf1c851accb60f.tar.bz2
gentoo-2-2b6b264e3e2a19e4ed947e4a8faf1c851accb60f.zip
Version bump. Don't disable the oddmuse backend.
(Portage version: 2.2_rc30/cvs/Linux i686)
Diffstat (limited to 'app-emacs/company-mode')
-rw-r--r--app-emacs/company-mode/ChangeLog7
-rw-r--r--app-emacs/company-mode/company-mode-0.3.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/app-emacs/company-mode/ChangeLog b/app-emacs/company-mode/ChangeLog
index 4ad670aef768..ca196218f547 100644
--- a/app-emacs/company-mode/ChangeLog
+++ b/app-emacs/company-mode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/company-mode
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/company-mode/ChangeLog,v 1.1 2009/04/08 16:20:59 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/company-mode/ChangeLog,v 1.2 2009/04/14 15:06:39 ulm Exp $
+
+*company-mode-0.3 (14 Apr 2009)
+
+ 14 Apr 2009; Ulrich Mueller <ulm@gentoo.org> +company-mode-0.3.ebuild:
+ Version bump. Don't disable the oddmuse backend.
*company-mode-0.2.1 (08 Apr 2009)
diff --git a/app-emacs/company-mode/company-mode-0.3.ebuild b/app-emacs/company-mode/company-mode-0.3.ebuild
new file mode 100644
index 000000000000..8b400f4459a3
--- /dev/null
+++ b/app-emacs/company-mode/company-mode-0.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/company-mode/company-mode-0.3.ebuild,v 1.1 2009/04/14 15:06:39 ulm Exp $
+
+EAPI=2
+NEED_EMACS=22
+
+inherit elisp
+
+DESCRIPTION="In-buffer completion front-end"
+HOMEPAGE="http://nschum.de/src/emacs/company-mode/"
+SRC_URI="http://nschum.de/src/emacs/${PN}/company-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="semantic"
+
+# Note: company-mode supports many backends, and we refrain from including
+# them all in RDEPEND. Only depend on things that are needed at build time.
+DEPEND="semantic? ( app-emacs/cedet )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ # Disable semantic backend, unless selected by its USE flag
+ if ! use semantic; then
+ elog "Disabling semantic backend"
+ rm "company-semantic.el" || die
+ sed -i -e "s/company-semantic *//" company.el || die
+ fi
+}