summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-10-24 20:57:39 +0000
committerUlrich Müller <ulm@gentoo.org>2007-10-24 20:57:39 +0000
commit1494a3d4b767831e4737a3eb45a6dc4a588b2d8a (patch)
tree5743b9763338d5702ed426214ed6e46ae9c80af3 /app-emacs/csharp-mode/csharp-mode-0.7.0.ebuild
parentamd64 stable, bug 196767 (diff)
downloadgentoo-2-1494a3d4b767831e4737a3eb45a6dc4a588b2d8a.tar.gz
gentoo-2-1494a3d4b767831e4737a3eb45a6dc4a588b2d8a.tar.bz2
gentoo-2-1494a3d4b767831e4737a3eb45a6dc4a588b2d8a.zip
Version bump and remove old.
(Portage version: 2.1.3.16)
Diffstat (limited to 'app-emacs/csharp-mode/csharp-mode-0.7.0.ebuild')
-rw-r--r--app-emacs/csharp-mode/csharp-mode-0.7.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-emacs/csharp-mode/csharp-mode-0.7.0.ebuild b/app-emacs/csharp-mode/csharp-mode-0.7.0.ebuild
new file mode 100644
index 000000000000..87bd65d969a1
--- /dev/null
+++ b/app-emacs/csharp-mode/csharp-mode-0.7.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/csharp-mode/csharp-mode-0.7.0.ebuild,v 1.1 2007/10/24 20:57:38 ulm Exp $
+
+inherit elisp versionator
+
+DESCRIPTION="A derived Emacs mode implementing most of the C# rules"
+HOMEPAGE="http://mfgames.com/linux/csharp-mode"
+SRC_URI="http://mfgames.com/linux/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+NEED_CCMODE=5.30
+
+DEPEND="|| ( >=app-emacs/cc-mode-${NEED_CCMODE} >=virtual/emacs-22 )"
+RDEPEND="${DEPEND}"
+
+SIMPLE_ELISP=t
+SITEFILE=80${PN}-gentoo.el
+
+pkg_setup () {
+ local HAVE_CCMODE
+ HAVE_CCMODE=$(emacs -batch -q \
+ --eval "(and (require 'cc-mode nil t) (princ c-version))")
+ if [ -z "${HAVE_CCMODE}" ] \
+ || ! version_is_at_least "${NEED_CCMODE}" "${HAVE_CCMODE}"; then
+ eerror "This package needs at least cc-mode version ${NEED_CCMODE}."
+ eerror "You should either install package app-emacs/cc-mode,"
+ eerror "or use \"eselect emacs\" to select an Emacs version >= 22."
+ die "cc-mode version ${HAVE_CCMODE} is too low."
+ fi
+}