summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-01-09 15:26:45 +0000
committerUlrich Müller <ulm@gentoo.org>2008-01-09 15:26:45 +0000
commitf2c66ecae5d9e381b0409f597fbea6b36c401862 (patch)
treec3ff14912d2155af0cfe2eeca46debed67857e65 /app-emacs/ddskk/ddskk-13.1.ebuild
parentAdded missing pkgconfig and X library deps (diff)
downloadgentoo-2-f2c66ecae5d9e381b0409f597fbea6b36c401862.tar.gz
gentoo-2-f2c66ecae5d9e381b0409f597fbea6b36c401862.tar.bz2
gentoo-2-f2c66ecae5d9e381b0409f597fbea6b36c401862.zip
Fix compile failure, bug #205045.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'app-emacs/ddskk/ddskk-13.1.ebuild')
-rw-r--r--app-emacs/ddskk/ddskk-13.1.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/app-emacs/ddskk/ddskk-13.1.ebuild b/app-emacs/ddskk/ddskk-13.1.ebuild
index c6e7784dbbb9..5fbea38a52fa 100644
--- a/app-emacs/ddskk/ddskk-13.1.ebuild
+++ b/app-emacs/ddskk/ddskk-13.1.ebuild
@@ -1,18 +1,17 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/ddskk/ddskk-13.1.ebuild,v 1.2 2007/10/04 23:15:41 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ddskk/ddskk-13.1.ebuild,v 1.3 2008/01/09 15:26:44 ulm Exp $
inherit elisp
-IUSE=""
-
DESCRIPTION="One Japanese input methods on Emacs"
-SRC_URI="http://openlab.ring.gr.jp/skk/maintrunk/${P}.tar.gz"
HOMEPAGE="http://openlab.ring.gr.jp/skk/"
+SRC_URI="http://openlab.ring.gr.jp/skk/maintrunk/${P}.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
DEPEND=">=app-emacs/apel-10.7"
RDEPEND="${DEPEND}
@@ -21,23 +20,21 @@ RDEPEND="${DEPEND}
SITEFILE=50ddskk-gentoo.el
src_unpack() {
-
unpack ${A}
find . -type f | xargs sed -i -e 's%/usr/local%/usr%g' || die
}
src_compile() {
-
emake < /dev/null || die "emake failed"
emake info < /dev/null || die "emake info failed"
#cd nicola
#make < /dev/null || die
cd "${S}/tut-code"
+ EMACSFLAGS="${EMACSFLAGS} -L .. -L ."
elisp-compile *.el || die "elisp-compile failed"
}
src_install () {
-
elisp-install ${PN} *.el* nicola/*.el* tut-code/*.el* || die "elisp-install failed"
elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die "elisp-site-file-install failed"