summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-02-24 08:08:39 +0000
committerUlrich Müller <ulm@gentoo.org>2014-02-24 08:08:39 +0000
commitfd39c818dd2e43238fb6026eb82f6e4459ccd007 (patch)
tree2ca0f700384bed13188d9b22338e0514c4bad469 /app-emacs/edb
parentParallel install fails sometimes (#501990) (diff)
downloadgentoo-2-fd39c818dd2e43238fb6026eb82f6e4459ccd007.tar.gz
gentoo-2-fd39c818dd2e43238fb6026eb82f6e4459ccd007.tar.bz2
gentoo-2-fd39c818dd2e43238fb6026eb82f6e4459ccd007.zip
Update ebuild to EAPI 5. Specify LICENSE more precisely. Move site-init file to canonical name.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'app-emacs/edb')
-rw-r--r--app-emacs/edb/ChangeLog9
-rw-r--r--app-emacs/edb/edb-1.31.ebuild33
-rw-r--r--app-emacs/edb/files/50edb-gentoo.el (renamed from app-emacs/edb/files/52edb-gentoo.el)3
3 files changed, 25 insertions, 20 deletions
diff --git a/app-emacs/edb/ChangeLog b/app-emacs/edb/ChangeLog
index 6aeac86a1b51..512fe79f673a 100644
--- a/app-emacs/edb/ChangeLog
+++ b/app-emacs/edb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/edb
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/edb/ChangeLog,v 1.12 2010/09/09 11:44:30 ulm Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/edb/ChangeLog,v 1.13 2014/02/24 08:08:38 ulm Exp $
+
+ 24 Feb 2014; Ulrich Müller <ulm@gentoo.org> edb-1.31.ebuild,
+ +files/50edb-gentoo.el, -files/52edb-gentoo.el:
+ Update ebuild to EAPI 5. Specify LICENSE more precisely. Move site-init file
+ to canonical name.
09 Sep 2010; Ulrich Mueller <ulm@gentoo.org> edb-1.31.ebuild,
+files/edb-1.31-skram-path.patch:
diff --git a/app-emacs/edb/edb-1.31.ebuild b/app-emacs/edb/edb-1.31.ebuild
index 4852848e4674..5a0bc1e51dfb 100644
--- a/app-emacs/edb/edb-1.31.ebuild
+++ b/app-emacs/edb/edb-1.31.ebuild
@@ -1,31 +1,34 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/edb/edb-1.31.ebuild,v 1.2 2010/09/09 11:44:30 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/edb/edb-1.31.ebuild,v 1.3 2014/02/24 08:08:38 ulm Exp $
-inherit elisp eutils
+EAPI=5
+
+inherit elisp
DESCRIPTION="EDB, The Emacs Database"
-HOMEPAGE="http://www.gnuvola.org/software/edb/"
+HOMEPAGE="http://www.gnuvola.org/software/edb/
+ http://www.emacswiki.org/emacs/EmacsDataBase"
SRC_URI="http://www.gnuvola.org/software/edb/${P}.tar.gz"
-LICENSE="GPL-3"
+LICENSE="GPL-3+ Texinfo-manual"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
-IUSE=""
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
ELISP_PATCHES="${P}-skram-path.patch"
-SITEFILE="52${PN}-gentoo.el"
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ default
+}
src_compile() {
- econf
- emake -j1 || die
+ emake -j1
}
src_install() {
- einstall sitelisp="${D}${SITELISP}" || die "einstall failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
- || die "elisp-site-file-install failed"
- dodoc AUTHORS BUGS ChangeLog HACKING NEWS README THANKS TODO \
- doc/refcard.ps || die "dodoc failed"
+ einstall sitelisp="${D}${SITELISP}"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc AUTHORS BUGS ChangeLog HACKING NEWS README THANKS TODO doc/refcard.ps
insinto /usr/share/doc/${PF}; doins -r examples
}
diff --git a/app-emacs/edb/files/52edb-gentoo.el b/app-emacs/edb/files/50edb-gentoo.el
index 4bcf00f5d6f6..a2670b65ba31 100644
--- a/app-emacs/edb/files/52edb-gentoo.el
+++ b/app-emacs/edb/files/50edb-gentoo.el
@@ -1,6 +1,3 @@
-
-;;; edb site-lisp configuration
-
(add-to-list 'load-path "@SITELISP@")
(autoload 'db-find-file "database" "EDB database package" t)
(autoload 'edb-interact "database" "EDB database package" t)