summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-03-21 08:16:44 +0000
committerUlrich Müller <ulm@gentoo.org>2009-03-21 08:16:44 +0000
commitbcf3c08297f546390497470afc0092b75f802e57 (patch)
treea5933dd7f00dbde2e7288c446623a4abb30b05bc /app-emacs/jde
parentVersion bump (diff)
downloadgentoo-2-bcf3c08297f546390497470afc0092b75f802e57.tar.gz
gentoo-2-bcf3c08297f546390497470afc0092b75f802e57.tar.bz2
gentoo-2-bcf3c08297f546390497470afc0092b75f802e57.zip
Make jde-import.el work with Emacs 22.
(Portage version: 2.2_rc26/cvs/Linux i686)
Diffstat (limited to 'app-emacs/jde')
-rw-r--r--app-emacs/jde/ChangeLog9
-rw-r--r--app-emacs/jde/files/jde-2.3.5.1-import.patch27
-rw-r--r--app-emacs/jde/jde-2.3.5.1-r2.ebuild (renamed from app-emacs/jde/jde-2.3.5.1-r1.ebuild)2
3 files changed, 36 insertions, 2 deletions
diff --git a/app-emacs/jde/ChangeLog b/app-emacs/jde/ChangeLog
index 2678470a6c41..a09c77570e68 100644
--- a/app-emacs/jde/ChangeLog
+++ b/app-emacs/jde/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emacs/jde
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/jde/ChangeLog,v 1.31 2009/03/02 23:01:57 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/jde/ChangeLog,v 1.32 2009/03/21 08:16:44 ulm Exp $
+
+*jde-2.3.5.1-r2 (21 Mar 2009)
+
+ 21 Mar 2009; Ulrich Mueller <ulm@gentoo.org>
+ +files/jde-2.3.5.1-import.patch, -jde-2.3.5.1-r1.ebuild,
+ +jde-2.3.5.1-r2.ebuild:
+ Make jde-import.el work with Emacs 22. Patch from Debian.
*jde-2.3.5.1-r1 (02 Mar 2009)
diff --git a/app-emacs/jde/files/jde-2.3.5.1-import.patch b/app-emacs/jde/files/jde-2.3.5.1-import.patch
new file mode 100644
index 000000000000..b8c826e6ad9e
--- /dev/null
+++ b/app-emacs/jde/files/jde-2.3.5.1-import.patch
@@ -0,0 +1,27 @@
+Fix error with jde-import-kill-extra-imports in Emacs 22.
+http://patch-tracking.debian.net/patch/series/view/jde/2.3.5.1-5/0008-lisp-jde-import.el-Fix-error-with-jde-import-kill-e.patch
+
+--- jde-2.3.5.1-orig/lisp/jde-import.el 2006-02-19 15:22:36.000000000 +0100
++++ jde-2.3.5.1/lisp/jde-import.el 2009-03-21 08:49:49.000000000 +0100
+@@ -495,15 +495,17 @@
+ (classname (jde-import-get-classname name))
+ (case-fold-search nil)
+- (number-of-matches
+- (substring (count-matches
+- (concat "\\b" classname "\\b")) 0 2)))
++ (number-of-matches
++ (count-matches (concat "\\b" classname "\\b"))))
++ (when (stringp number-of-matches)
++ (setq number-of-matches
++ (string-to-number (substring number-of-matches 0 2))))
+ (if (or
+ ;; If name is already listed in the set
+ ;; of required imports...
+ (member name required-imports)
+ ;;or the class is not reference in the file
+ ;;and is not an import of the whole package i.e. .*
+- (and (< (string-to-number number-of-matches) 2)
++ (and (< number-of-matches 2)
+ (not (string= classname "*")))
+ ;; or imports a class in the current package...
+ (and
diff --git a/app-emacs/jde/jde-2.3.5.1-r1.ebuild b/app-emacs/jde/jde-2.3.5.1-r2.ebuild
index a52bd9002e19..9c8f10485f89 100644
--- a/app-emacs/jde/jde-2.3.5.1-r1.ebuild
+++ b/app-emacs/jde/jde-2.3.5.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/jde/jde-2.3.5.1-r1.ebuild,v 1.1 2009/03/02 23:01:57 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/jde/jde-2.3.5.1-r2.ebuild,v 1.1 2009/03/21 08:16:44 ulm Exp $
inherit elisp eutils