summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-04-20 16:12:23 +0000
committerUlrich Müller <ulm@gentoo.org>2010-04-20 16:12:23 +0000
commit84d270daea65bdfa3eb4e1de5cee6ab17ef704d6 (patch)
tree8c87f300a2d02c5763cc8060908d77085e7f6df0 /app-emacs/mmm-mode
parentgoosnes, xfce4-indicator-plugin, and jpgalleg are gone now. use snes9x with U... (diff)
downloadgentoo-2-84d270daea65bdfa3eb4e1de5cee6ab17ef704d6.tar.gz
gentoo-2-84d270daea65bdfa3eb4e1de5cee6ab17ef704d6.tar.bz2
gentoo-2-84d270daea65bdfa3eb4e1de5cee6ab17ef704d6.zip
Compatibility fix for mode line format of Emacs 23, bug 311259.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'app-emacs/mmm-mode')
-rw-r--r--app-emacs/mmm-mode/ChangeLog10
-rw-r--r--app-emacs/mmm-mode/files/mmm-mode-0.4.8-format-mode-line.patch15
-rw-r--r--app-emacs/mmm-mode/mmm-mode-0.4.8-r2.ebuild29
3 files changed, 52 insertions, 2 deletions
diff --git a/app-emacs/mmm-mode/ChangeLog b/app-emacs/mmm-mode/ChangeLog
index 3bd1c0b4a433..0777dd3529f3 100644
--- a/app-emacs/mmm-mode/ChangeLog
+++ b/app-emacs/mmm-mode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/mmm-mode
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/mmm-mode/ChangeLog,v 1.15 2009/12/07 22:36:00 ulm Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/mmm-mode/ChangeLog,v 1.16 2010/04/20 16:12:23 ulm Exp $
+
+*mmm-mode-0.4.8-r2 (20 Apr 2010)
+
+ 20 Apr 2010; Ulrich Mueller <ulm@gentoo.org> +mmm-mode-0.4.8-r2.ebuild,
+ +files/mmm-mode-0.4.8-format-mode-line.patch:
+ Compatibility fix for mode line format of Emacs 23, bug 311259.
07 Dec 2009; Ulrich Mueller <ulm@gentoo.org> mmm-mode-0.4.8-r1.ebuild:
Remove redundant and misspelt configure options. Add Prefix KEYWORDS.
diff --git a/app-emacs/mmm-mode/files/mmm-mode-0.4.8-format-mode-line.patch b/app-emacs/mmm-mode/files/mmm-mode-0.4.8-format-mode-line.patch
new file mode 100644
index 000000000000..b204f896f301
--- /dev/null
+++ b/app-emacs/mmm-mode/files/mmm-mode-0.4.8-format-mode-line.patch
@@ -0,0 +1,15 @@
+--- mmm-mode-0.4.8-orig/mmm-utils.el
++++ mmm-mode-0.4.8/mmm-utils.el
+@@ -78,7 +78,11 @@
+ (save-match-data
+ (dolist (pair arg-pairs)
+ (while (string-match (car pair) string)
+- (setq string (replace-match (cdr pair) t t string))))))
++ (setq string (replace-match
++ (if (fboundp 'format-mode-line)
++ (format-mode-line (cdr pair))
++ (cdr pair))
++ t t string))))))
+ string)
+
+ (defun mmm-format-matches (string &optional on-string)
diff --git a/app-emacs/mmm-mode/mmm-mode-0.4.8-r2.ebuild b/app-emacs/mmm-mode/mmm-mode-0.4.8-r2.ebuild
new file mode 100644
index 000000000000..b08749ee7227
--- /dev/null
+++ b/app-emacs/mmm-mode/mmm-mode-0.4.8-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/mmm-mode/mmm-mode-0.4.8-r2.ebuild,v 1.1 2010/04/20 16:12:23 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Enables the user to edit different parts of a file in different major modes"
+HOMEPAGE="http://mmm-mode.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+ELISP_PATCHES="${P}-format-mode-line.patch"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ econf --with-emacs
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ doinfo *.info* || die
+ dodoc AUTHORS ChangeLog FAQ NEWS README README.Mason TODO
+}