summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-12-01 21:09:24 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-12-01 21:09:24 +0000
commit1dd9b41ed55a131ec462700aa1aa2a57876c540c (patch)
treeac0b448770043b6a413701854f2cf4501a8e1fb9 /app-emacs/nxml-libvirt-schemas
parentversion bump (diff)
downloadgentoo-2-1dd9b41ed55a131ec462700aa1aa2a57876c540c.tar.gz
gentoo-2-1dd9b41ed55a131ec462700aa1aa2a57876c540c.tar.bz2
gentoo-2-1dd9b41ed55a131ec462700aa1aa2a57876c540c.zip
Version bump.
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs/nxml-libvirt-schemas')
-rw-r--r--app-emacs/nxml-libvirt-schemas/ChangeLog8
-rw-r--r--app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-0.8.6.ebuild67
2 files changed, 74 insertions, 1 deletions
diff --git a/app-emacs/nxml-libvirt-schemas/ChangeLog b/app-emacs/nxml-libvirt-schemas/ChangeLog
index 15d117450011..b698a301b87a 100644
--- a/app-emacs/nxml-libvirt-schemas/ChangeLog
+++ b/app-emacs/nxml-libvirt-schemas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/nxml-libvirt-schemas
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/nxml-libvirt-schemas/ChangeLog,v 1.3 2010/10/29 18:46:14 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/nxml-libvirt-schemas/ChangeLog,v 1.4 2010/12/01 21:09:24 flameeyes Exp $
+
+*nxml-libvirt-schemas-0.8.6 (01 Dec 2010)
+
+ 01 Dec 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +nxml-libvirt-schemas-0.8.6.ebuild:
+ Version bump.
*nxml-libvirt-schemas-0.8.5 (29 Oct 2010)
diff --git a/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-0.8.6.ebuild b/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-0.8.6.ebuild
new file mode 100644
index 000000000000..4297ac0650c1
--- /dev/null
+++ b/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-0.8.6.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-0.8.6.ebuild,v 1.1 2010/12/01 21:09:24 flameeyes Exp $
+
+BACKPORTS=
+
+EAPI=2
+
+inherit elisp eutils
+
+MY_P="libvirt-${PV}"
+
+DESCRIPTION="Extension for nxml-mode with libvirt schemas"
+HOMEPAGE="http://www.libvirt.org/"
+
+SRC_URI="http://libvirt.org/sources/${MY_P}.tar.gz
+ ${BACKPORTS:+mirror://gentoo/${MY_P}-backports-${BACKPORTS}.tar.bz2}"
+
+# This is the license of the package, but the schema files are
+# provided without license, maybe it's bad.
+LICENSE="LGPL-2.1"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( >=app-emacs/nxml-mode-20041004-r3 >=virtual/emacs-23 )"
+
+# Yes this requires Java, but I'd rather not repackage this, if you
+# know something better in C, I'll be glad to use that.
+DEPEND="app-text/trang"
+
+SITEFILE=60${PN}-gentoo.el
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ [[ -d "${WORKDIR}/patches" ]] && \
+ EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" EPATCH_SOURCE="${WORKDIR}/patches" epatch
+}
+
+src_compile() {
+ emake -C docs/schemas -f "${FILESDIR}/Makefile-trang" || die "trang failed"
+}
+
+src_test() {
+ # No we don't need tests here… trang will take care of checking
+ # the well-formedness of the schema files for us
+ :
+}
+
+src_install() {
+ insinto ${SITEETC}/${PN}
+ doins "${FILESDIR}/schemas.xml" docs/schemas/*.rnc || die "install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+}
+
+pkg_postinst () {
+ elisp-site-regen
+
+ if [ $(emacs -batch -q --eval "(princ (fboundp 'nxml-mode))") = nil ]; then
+ ewarn "This package needs nxml-mode. You should either install"
+ ewarn "app-emacs/nxml-mode, or use \"eselect emacs\" to select"
+ ewarn "an Emacs version >= 23."
+ fi
+}