summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-04-11 12:16:30 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-04-11 12:16:30 +0000
commit066b0857fd0aa7ac6689ea27e9a9a9c1a0bf9abd (patch)
tree9aeec869b2f1935b72789178b553340a04515aad /app-emacs/ocaml-mode
parentMark as stable on all archs and remove old versions (Manifest recommit) (diff)
downloadgentoo-2-066b0857fd0aa7ac6689ea27e9a9a9c1a0bf9abd.tar.gz
gentoo-2-066b0857fd0aa7ac6689ea27e9a9a9c1a0bf9abd.tar.bz2
gentoo-2-066b0857fd0aa7ac6689ea27e9a9a9c1a0bf9abd.zip
Initial import
Diffstat (limited to 'app-emacs/ocaml-mode')
-rw-r--r--app-emacs/ocaml-mode/ChangeLog11
-rw-r--r--app-emacs/ocaml-mode/Manifest3
-rw-r--r--app-emacs/ocaml-mode/files/50ocaml-mode-gentoo.el9
-rw-r--r--app-emacs/ocaml-mode/files/digest-ocaml-mode-3.071
-rw-r--r--app-emacs/ocaml-mode/metadata.xml6
-rw-r--r--app-emacs/ocaml-mode/ocaml-mode-3.07.ebuild47
6 files changed, 77 insertions, 0 deletions
diff --git a/app-emacs/ocaml-mode/ChangeLog b/app-emacs/ocaml-mode/ChangeLog
new file mode 100644
index 000000000000..0c7ce568b6a4
--- /dev/null
+++ b/app-emacs/ocaml-mode/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/ocaml-mode
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ocaml-mode/ChangeLog,v 1.1 2004/04/11 12:16:30 mattam Exp $
+
+*ocaml-mode-3.07 (11 Apr 2004)
+
+ 11 Apr 2004; Matthieu Sozeau <mattam@gentoo.org> ocaml-mode-3.07.ebuild,
+ files/50ocaml-mode-gentoo.el:
+ Initial import for the ocaml mode accompanying the standard distribution of
+ ocaml. Closes bug #43128. Thanks to liquidx@gentoo.org for initial ebuilds.
+
diff --git a/app-emacs/ocaml-mode/Manifest b/app-emacs/ocaml-mode/Manifest
new file mode 100644
index 000000000000..661a95946408
--- /dev/null
+++ b/app-emacs/ocaml-mode/Manifest
@@ -0,0 +1,3 @@
+MD5 7fd86f46d2c4a584e1c5e60bf3159bca ocaml-mode-3.07.ebuild 1120
+MD5 99e5c405e771ad88b4160b0b8c10fae9 files/50ocaml-mode-gentoo.el 366
+MD5 6e02dcc33419f9e035b77ff4a0104e8b files/digest-ocaml-mode-3.07 63
diff --git a/app-emacs/ocaml-mode/files/50ocaml-mode-gentoo.el b/app-emacs/ocaml-mode/files/50ocaml-mode-gentoo.el
new file mode 100644
index 000000000000..6c54f8faa8da
--- /dev/null
+++ b/app-emacs/ocaml-mode/files/50ocaml-mode-gentoo.el
@@ -0,0 +1,9 @@
+
+;;; ocaml-mode site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+(setq auto-mode-alist
+ (cons '("\\.ml[iylp]?$" . caml-mode) auto-mode-alist))
+(autoload 'caml-mode "caml" "Major mode for editing Caml code." t)
+(autoload 'run-caml "inf-caml" "Run an inferior Caml process." t)
+(require 'caml-font)
diff --git a/app-emacs/ocaml-mode/files/digest-ocaml-mode-3.07 b/app-emacs/ocaml-mode/files/digest-ocaml-mode-3.07
new file mode 100644
index 000000000000..33759519a3ff
--- /dev/null
+++ b/app-emacs/ocaml-mode/files/digest-ocaml-mode-3.07
@@ -0,0 +1 @@
+MD5 2dd038055f5e1350078ad81270411b78 ocaml-3.07.tar.gz 2537449
diff --git a/app-emacs/ocaml-mode/metadata.xml b/app-emacs/ocaml-mode/metadata.xml
new file mode 100644
index 000000000000..d3eb2339e1fa
--- /dev/null
+++ b/app-emacs/ocaml-mode/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <herd>emacs</herd>
+</pkgmetadata>
diff --git a/app-emacs/ocaml-mode/ocaml-mode-3.07.ebuild b/app-emacs/ocaml-mode/ocaml-mode-3.07.ebuild
new file mode 100644
index 000000000000..957bc20f2134
--- /dev/null
+++ b/app-emacs/ocaml-mode/ocaml-mode-3.07.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ocaml-mode/ocaml-mode-3.07.ebuild,v 1.1 2004/04/11 12:16:30 mattam Exp $
+
+inherit elisp
+
+IUSE=""
+MY_P=${P/-mode/}
+
+DESCRIPTION="Emacs mode for OCaml"
+HOMEPAGE="http://www.ocaml.org/"
+SRC_URI="http://caml.inria.fr/distrib/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc
+"
+IUSE=""
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${MY_P}/emacs"
+
+src_compile() {
+ COMPILECMD='(progn
+ (setq load-path (cons "." load-path))
+ (byte-compile-file "caml-xemacs.el")
+ (byte-compile-file "caml-emacs.el")
+ (byte-compile-file "caml.el")
+ (byte-compile-file "inf-caml.el")
+ (byte-compile-file "caml-help.el")
+ (byte-compile-file "camldebug.el"))'
+ emacs -batch -eval "${COMPILECMD}"
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/50ocaml-mode-gentoo.el
+}
+
+pkg_postinst() {
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}