summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-05-02 08:45:00 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-05-02 08:45:00 +0000
commit8f43a20425d87adbbf15ca1be2c5bc7d7bcf7a3c (patch)
tree41ef63df16f830b3381521595ab5af4a70bcc690 /app-emacs/ognus
parentfix for tk-8.4 issue (diff)
downloadgentoo-2-8f43a20425d87adbbf15ca1be2c5bc7d7bcf7a3c.tar.gz
gentoo-2-8f43a20425d87adbbf15ca1be2c5bc7d7bcf7a3c.tar.bz2
gentoo-2-8f43a20425d87adbbf15ca1be2c5bc7d7bcf7a3c.zip
new version
Diffstat (limited to 'app-emacs/ognus')
-rw-r--r--app-emacs/ognus/ChangeLog7
-rw-r--r--app-emacs/ognus/files/digest-ognus-0.241
-rw-r--r--app-emacs/ognus/ognus-0.24.ebuild57
3 files changed, 64 insertions, 1 deletions
diff --git a/app-emacs/ognus/ChangeLog b/app-emacs/ognus/ChangeLog
index 06f322951827..3689a51c44ed 100644
--- a/app-emacs/ognus/ChangeLog
+++ b/app-emacs/ognus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/ognus
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/ognus/ChangeLog,v 1.2 2003/04/13 10:42:35 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ognus/ChangeLog,v 1.3 2003/05/02 08:45:00 mkennedy Exp $
+
+*ognus-0.24 (02 May 2003)
+
+ 02 May 2003; Matthew Kennedy <mkennedy@gentoo.org> ognus-0.24.ebuild:
+ Version bump to latest.
*ognus-0.18 (13 Apr 2003)
diff --git a/app-emacs/ognus/files/digest-ognus-0.24 b/app-emacs/ognus/files/digest-ognus-0.24
new file mode 100644
index 000000000000..ff6b682b8562
--- /dev/null
+++ b/app-emacs/ognus/files/digest-ognus-0.24
@@ -0,0 +1 @@
+MD5 de556fa8b838b8e570299c3c4c0b4c0a ognus-0.24.tar.gz 2248517
diff --git a/app-emacs/ognus/ognus-0.24.ebuild b/app-emacs/ognus/ognus-0.24.ebuild
new file mode 100644
index 000000000000..9be898aaec19
--- /dev/null
+++ b/app-emacs/ognus/ognus-0.24.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ognus/ognus-0.24.ebuild,v 1.1 2003/05/02 08:45:00 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Current alpha branch of the Gnus news- and mail-reader"
+HOMEPAGE="http://www.gnus.org/"
+SRC_URI="http://quimby.gnus.org/gnus/dist/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --bindir=/usr/bin \
+ --datadir=/usr/share \
+ --infodir=/usr/share/info \
+ --with-emacs \
+ --with-lispdir=/usr/share/emacs/site-lisp/ognus \
+ --with-etcdir=/usr/share/emacs/etc \
+ --with-url=/usr/share/emacs/site-lisp/w3 \
+ --with-w3=/usr/share/emacs/site-lisp/w3
+ emake || die
+}
+
+src_install() {
+ make install \
+ prefix=${D}/usr \
+ datadir=${D}/usr/share \
+ infodir=${D}/usr/share/info \
+ lispdir=${D}/usr/share/emacs/site-lisp/ognus \
+ etcdir=${D}/usr/share/emacs/etc \
+ || die
+
+ elisp-site-file-install ${FILESDIR}/70ognus-gentoo.el
+
+ dodoc ChangeLog GNUS-NEWS README todo
+
+ # fix info documentation
+ find ${D}/usr/share/info -type f -exec mv {} {}.info \;
+}
+
+pkg_postinst() {
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}