summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-03-28 09:29:41 +0000
committerMamoru Komachi <usata@gentoo.org>2005-03-28 09:29:41 +0000
commit030b94212efbc14d748298f135d6414b0e8caa2f (patch)
treeafd16b250f5f32ebcedb67fb9b66edee97fa1f84 /app-emacs/riece/riece-1.0.8.ebuild
parentFixing small bug (#86650) with linux-mod/convert_to_m, thanks to Stefan Schwe... (diff)
downloadgentoo-2-030b94212efbc14d748298f135d6414b0e8caa2f.tar.gz
gentoo-2-030b94212efbc14d748298f135d6414b0e8caa2f.tar.bz2
gentoo-2-030b94212efbc14d748298f135d6414b0e8caa2f.zip
Version bumped.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-emacs/riece/riece-1.0.8.ebuild')
-rw-r--r--app-emacs/riece/riece-1.0.8.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/riece/riece-1.0.8.ebuild b/app-emacs/riece/riece-1.0.8.ebuild
new file mode 100644
index 000000000000..a66cb861a8f2
--- /dev/null
+++ b/app-emacs/riece/riece-1.0.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/riece/riece-1.0.8.ebuild,v 1.1 2005/03/28 09:29:41 usata Exp $
+
+inherit elisp
+
+IUSE=""
+S="${WORKDIR}/${P/b/}"
+
+DESCRIPTION="Riece is a redesign of Liece IRC client"
+HOMEPAGE="http://www.nongnu.org/riece/"
+SRC_URI="http://savannah.nongnu.org/download/riece/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~ppc ~ppc64 ~amd64 ~ppc-macos"
+
+SITEFILE=50riece-gentoo.el
+
+src_compile() {
+
+ econf --with-lispdir=${SITELISP} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+
+ einstall lispdir=${D}/${SITELISP} || die "einstall failed"
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+}