summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-02-14 16:43:48 +0000
committerUlrich Müller <ulm@gentoo.org>2014-02-14 16:43:48 +0000
commit82ff5450fed9770d14cbc96e077b3db10b27b9b0 (patch)
tree73aa800833f026dd7913ad5b54658e308563ccc5 /app-emacs/template
parentVersion bump. Remove old ebuild immediately, owing to wrong sorting order wit... (diff)
downloadgentoo-2-82ff5450fed9770d14cbc96e077b3db10b27b9b0.tar.gz
gentoo-2-82ff5450fed9770d14cbc96e077b3db10b27b9b0.tar.bz2
gentoo-2-82ff5450fed9770d14cbc96e077b3db10b27b9b0.zip
Install templates in SITEETC directory.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'app-emacs/template')
-rw-r--r--app-emacs/template/ChangeLog10
-rw-r--r--app-emacs/template/files/50template-gentoo.el5
-rw-r--r--app-emacs/template/template-3.1c-r1.ebuild31
-rw-r--r--app-emacs/template/template-3.1c.ebuild31
4 files changed, 40 insertions, 37 deletions
diff --git a/app-emacs/template/ChangeLog b/app-emacs/template/ChangeLog
index 640703a7bc61..b5da9b1d09dd 100644
--- a/app-emacs/template/ChangeLog
+++ b/app-emacs/template/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/template
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/template/ChangeLog,v 1.1 2008/01/23 13:57:14 opfer Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/template/ChangeLog,v 1.2 2014/02/14 16:43:47 ulm Exp $
+
+*template-3.1c-r1 (14 Feb 2014)
+
+ 14 Feb 2014; Ulrich Müller <ulm@gentoo.org> -template-3.1c.ebuild,
+ +template-3.1c-r1.ebuild, files/50template-gentoo.el:
+ Install templates in SITEETC directory.
*template-3.1c (23 Jan 2008)
diff --git a/app-emacs/template/files/50template-gentoo.el b/app-emacs/template/files/50template-gentoo.el
index 19bceb39174e..3da76196f42e 100644
--- a/app-emacs/template/files/50template-gentoo.el
+++ b/app-emacs/template/files/50template-gentoo.el
@@ -1,6 +1,3 @@
-
-;;; template site-lisp configuration
-
(add-to-list 'load-path "@SITELISP@")
(autoload 'template-single-comment "template"
"Decorate the comment in the current line with dashes and alike." t)
@@ -20,4 +17,4 @@
(file-directory-p "~/lib/templates"))
(expand-file-name "~/lib/templates/")
(expand-file-name "~/.templates/"))
- "@SITELISP@/templates"))
+ "@SITEETC@/templates"))
diff --git a/app-emacs/template/template-3.1c-r1.ebuild b/app-emacs/template/template-3.1c-r1.ebuild
new file mode 100644
index 000000000000..e1410ebc6912
--- /dev/null
+++ b/app-emacs/template/template-3.1c-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/template/template-3.1c-r1.ebuild,v 1.1 2014/02/14 16:43:47 ulm Exp $
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Use templates, decorate comments, auto-update buffers"
+HOMEPAGE="http://emacs-template.sourceforge.net/"
+SRC_URI="mirror://sourceforge/emacs-template/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile lisp/*.el
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ insinto "${SITEETC}/${PN}"
+ doins -r templates
+ dodoc README lisp/ChangeLog
+}
diff --git a/app-emacs/template/template-3.1c.ebuild b/app-emacs/template/template-3.1c.ebuild
deleted file mode 100644
index ec3c0439b3b5..000000000000
--- a/app-emacs/template/template-3.1c.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/template/template-3.1c.ebuild,v 1.1 2008/01/23 13:57:14 opfer Exp $
-
-inherit elisp
-
-DESCRIPTION="Use templates, decorate comments, auto-update buffers"
-HOMEPAGE="http://emacs-template.sourceforge.net/"
-SRC_URI="mirror://sourceforge/emacs-template/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-SITEFILE=50${PN}-gentoo.el
-S="${WORKDIR}/${PN}"
-
-src_compile() {
- elisp-compile lisp/*.el || die "elisp-compile failed"
-}
-
-src_install() {
- elisp-install ${PN} lisp/*.{el,elc} || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
- || die "elisp-site-file-install failed"
-
- insinto "${SITELISP}/${PN}/templates"
- doins templates/*.tpl || die "doins failed"
- dodoc README lisp/ChangeLog || die "dodoc failed"
-}