summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-10-15 18:00:20 +0000
committerUlrich Müller <ulm@gentoo.org>2009-10-15 18:00:20 +0000
commit0967f99b564da1d2643c6303c342da0422347db1 (patch)
treeb297418efe8f699692fd7ebf2400c7ece64a9374 /app-emacs
parentAdd myself as primary maintainer since genstef is clearly gone (diff)
downloadgentoo-2-0967f99b564da1d2643c6303c342da0422347db1.tar.gz
gentoo-2-0967f99b564da1d2643c6303c342da0422347db1.tar.bz2
gentoo-2-0967f99b564da1d2643c6303c342da0422347db1.zip
Version bump.
(Portage version: 2.2_rc46/cvs/Linux i686)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/yasnippet/ChangeLog7
-rw-r--r--app-emacs/yasnippet/yasnippet-0.6.1c.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/app-emacs/yasnippet/ChangeLog b/app-emacs/yasnippet/ChangeLog
index cfc64053d6db..c2e5263436c9 100644
--- a/app-emacs/yasnippet/ChangeLog
+++ b/app-emacs/yasnippet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/yasnippet
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/yasnippet/ChangeLog,v 1.8 2009/08/28 16:11:04 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/yasnippet/ChangeLog,v 1.9 2009/10/15 18:00:20 ulm Exp $
+
+*yasnippet-0.6.1c (15 Oct 2009)
+
+ 15 Oct 2009; Ulrich Mueller <ulm@gentoo.org> +yasnippet-0.6.1c.ebuild:
+ Version bump.
*yasnippet-0.6.0c (28 Aug 2009)
diff --git a/app-emacs/yasnippet/yasnippet-0.6.1c.ebuild b/app-emacs/yasnippet/yasnippet-0.6.1c.ebuild
new file mode 100644
index 000000000000..fffd9d4713e5
--- /dev/null
+++ b/app-emacs/yasnippet/yasnippet-0.6.1c.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/yasnippet/yasnippet-0.6.1c.ebuild,v 1.1 2009/10/15 18:00:20 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Yet another snippet extension for Emacs"
+HOMEPAGE="http://code.google.com/p/yasnippet/"
+SRC_URI="http://yasnippet.googlecode.com/files/${P}.tar.bz2
+ doc? ( http://yasnippet.googlecode.com/files/${PN}-doc-${PV}.tar.bz2 )"
+
+# Homepage says MIT licence, source contains GPL-2 copyright notice
+LICENSE="MIT GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=app-emacs/dropdown-list-20080316"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_unpack() {
+ elisp_src_unpack
+
+ # remove bundled copy of dropdown-list
+ rm "${S}/dropdown-list.el" || die
+}
+
+src_install() {
+ elisp_src_install
+
+ insinto "${SITEETC}/${PN}"
+ doins -r snippets || die "doins failed"
+
+ if use doc; then
+ dohtml -r "${WORKDIR}"/doc/* || die "dohtml failed"
+ fi
+}
+
+pkg_postinst() {
+ elisp-site-regen
+
+ elog "Please add the following code into your .emacs to use yasnippet:"
+ elog "(yas/initialize)"
+ elog "(yas/load-directory \"${SITEETC}/${PN}/snippets\")"
+}