summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-09-20 18:52:00 +0000
committerUlrich Müller <ulm@gentoo.org>2009-09-20 18:52:00 +0000
commit4351448dd038f26a31d0db5a18f699d717c19185 (patch)
tree9c822b3f050242a24eb7dc414377b2aa63b917ea /app-emacs
parentppc stable #281576 (diff)
downloadgentoo-2-4351448dd038f26a31d0db5a18f699d717c19185.tar.gz
gentoo-2-4351448dd038f26a31d0db5a18f699d717c19185.tar.bz2
gentoo-2-4351448dd038f26a31d0db5a18f699d717c19185.zip
Suppress package for Emacs 23, where rst-mode is already defined.
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/rst/ChangeLog8
-rw-r--r--app-emacs/rst/files/50rst-gentoo.el5
-rw-r--r--app-emacs/rst/rst-0.5-r1.ebuild34
3 files changed, 46 insertions, 1 deletions
diff --git a/app-emacs/rst/ChangeLog b/app-emacs/rst/ChangeLog
index 6bac1f924558..9c70ac538649 100644
--- a/app-emacs/rst/ChangeLog
+++ b/app-emacs/rst/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/rst
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/rst/ChangeLog,v 1.28 2009/09/07 10:03:52 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/rst/ChangeLog,v 1.29 2009/09/20 18:52:00 ulm Exp $
+
+*rst-0.5-r1 (20 Sep 2009)
+
+ 20 Sep 2009; Ulrich Mueller <ulm@gentoo.org> +files/50rst-gentoo.el,
+ +rst-0.5-r1.ebuild:
+ Suppress package for Emacs 23, where rst-mode is already defined.
07 Sep 2009; Christian Faulhammer <fauli@gentoo.org> -rst-0.4-r1.ebuild,
-files/rst-0.4-lazy-lock-mode-fix.patch:
diff --git a/app-emacs/rst/files/50rst-gentoo.el b/app-emacs/rst/files/50rst-gentoo.el
new file mode 100644
index 000000000000..593ab6d63457
--- /dev/null
+++ b/app-emacs/rst/files/50rst-gentoo.el
@@ -0,0 +1,5 @@
+;; Emacs 23 and later include rst.el
+(unless (fboundp 'rst-mode)
+ (add-to-list 'load-path "@SITELISP@")
+ (autoload 'rst-mode "rst" "mode for editing reStructuredText documents" t)
+ (add-to-list 'auto-mode-alist '("\\.re?st\\'" . rst-mode)))
diff --git a/app-emacs/rst/rst-0.5-r1.ebuild b/app-emacs/rst/rst-0.5-r1.ebuild
new file mode 100644
index 000000000000..f4caa3cd3243
--- /dev/null
+++ b/app-emacs/rst/rst-0.5-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/rst/rst-0.5-r1.ebuild,v 1.1 2009/09/20 18:52:00 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="ReStructuredText support for Emacs"
+HOMEPAGE="http://www.emacswiki.org/cgi-bin/wiki/reStructuredText"
+SRC_URI="mirror://sourceforge/docutils/docutils-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}/docutils-${PV}/tools/editors/emacs"
+DOCS="README.txt"
+SITEFILE="50${PN}-gentoo.el"
+
+pkg_setup() {
+ local have_emacs=$(elisp-emacs-version)
+ if [ "${have_emacs%%.*}" -ge 23 ]; then
+ echo
+ elog "Please note that \"${PN}\" is already included with Emacs 23 or"
+ elog "later, so ${CATEGORY}/${PN} is only needed for lower versions."
+ elog "You may select the active Emacs version with \"eselect emacs\"."
+ fi
+}
+
+src_install() {
+ elisp_src_install
+ # prevent inclusion of package dir by subdirs.el
+ touch "${D}${SITELISP}/${PN}/.nosearch"
+}