summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-03-13 21:45:55 +0000
committerMamoru Komachi <usata@gentoo.org>2004-03-13 21:45:55 +0000
commit98ea313eae5d14a8b32d2c7c9bee88113d2a6243 (patch)
treee02145a73937806ee40dddc3824a919d4ee61215 /app-emacs
parentAdded to ~ppc (Manifest recommit) (diff)
downloadgentoo-2-98ea313eae5d14a8b32d2c7c9bee88113d2a6243.tar.gz
gentoo-2-98ea313eae5d14a8b32d2c7c9bee88113d2a6243.tar.bz2
gentoo-2-98ea313eae5d14a8b32d2c7c9bee88113d2a6243.zip
Initial import. Thanks to Michal Maruska <mmc@maruska.dyndns.org> for contributing the ebuild. Closing bug #40007
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/gnuplot-mode/ChangeLog11
-rw-r--r--app-emacs/gnuplot-mode/Manifest3
-rw-r--r--app-emacs/gnuplot-mode/files/50gnuplot-gentoo.el5
-rw-r--r--app-emacs/gnuplot-mode/files/digest-gnuplot-mode-0.6.01
-rw-r--r--app-emacs/gnuplot-mode/gnuplot-mode-0.6.0.ebuild46
-rw-r--r--app-emacs/gnuplot-mode/metadata.xml5
6 files changed, 71 insertions, 0 deletions
diff --git a/app-emacs/gnuplot-mode/ChangeLog b/app-emacs/gnuplot-mode/ChangeLog
new file mode 100644
index 000000000000..2845d6698296
--- /dev/null
+++ b/app-emacs/gnuplot-mode/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/gnuplot-mode
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gnuplot-mode/ChangeLog,v 1.1 2004/03/13 21:45:55 usata Exp $
+
+*gnuplot-mode-0.6.0 (14 Mar 2004)
+
+ 14 Mar 2004; Mamoru KOMACHI <usata@gentoo.org> gnuplot-mode-0.6.0.ebuild,
+ metadata.xml, files/50gnuplot-gentoo.el:
+ Initial import. Thanks to Michal Maruska <mmc@maruska.dyndns.org>
+ for contributing the ebuild. Closing bug #40007
+
diff --git a/app-emacs/gnuplot-mode/Manifest b/app-emacs/gnuplot-mode/Manifest
new file mode 100644
index 000000000000..dc175ddf4928
--- /dev/null
+++ b/app-emacs/gnuplot-mode/Manifest
@@ -0,0 +1,3 @@
+MD5 bfbbbaec1fe38dcc2f3f1900caef8f9a gnuplot-mode-0.6.0.ebuild 967
+MD5 3318096b418ec06f7b66e7db4dfc2cb9 files/50gnuplot-gentoo.el 147
+MD5 8a8cfa291853d00fac0d679ca2bcd20e files/digest-gnuplot-mode-0.6.0 70
diff --git a/app-emacs/gnuplot-mode/files/50gnuplot-gentoo.el b/app-emacs/gnuplot-mode/files/50gnuplot-gentoo.el
new file mode 100644
index 000000000000..08f655cc4fbc
--- /dev/null
+++ b/app-emacs/gnuplot-mode/files/50gnuplot-gentoo.el
@@ -0,0 +1,5 @@
+
+;;; gnuplot-mode site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'gnuplot-mode "gnuplot" "Start gnuplot-mode" t)
diff --git a/app-emacs/gnuplot-mode/files/digest-gnuplot-mode-0.6.0 b/app-emacs/gnuplot-mode/files/digest-gnuplot-mode-0.6.0
new file mode 100644
index 000000000000..70ac6cc99666
--- /dev/null
+++ b/app-emacs/gnuplot-mode/files/digest-gnuplot-mode-0.6.0
@@ -0,0 +1 @@
+MD5 0a3fee5a4ed3224770b8880bc714f054 gnuplot-mode.0.6.0.tar.gz 306727
diff --git a/app-emacs/gnuplot-mode/gnuplot-mode-0.6.0.ebuild b/app-emacs/gnuplot-mode/gnuplot-mode-0.6.0.ebuild
new file mode 100644
index 000000000000..c759a1786e7c
--- /dev/null
+++ b/app-emacs/gnuplot-mode/gnuplot-mode-0.6.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gnuplot-mode/gnuplot-mode-0.6.0.ebuild,v 1.1 2004/03/13 21:45:55 usata Exp $
+
+inherit elisp
+
+IUSE=""
+
+MY_P=${PN}.${PV}
+DESCRIPTION="Gnuplot mode for Emacs"
+HOMEPAGE="http://feff.phys.washington.edu/~ravel/gnuplot/"
+SRC_URI="http://feff.phys.washington.edu/~ravel/gnuplot/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/emacs
+ media-gfx/gnuplot"
+
+S="${WORKDIR}/${MY_P}"
+
+SITEFILE=50gnuplot-gentoo.el
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+
+ PATH=./:$PATH make install lispdir=$D/usr/share/emacs/site-lisp/${PN} || die
+ elisp-site-file-install ${FILESDIR}/${SITEFILE} || die
+
+ mv gnuplot.info gnuplot-mode.info
+ doinfo gnuplot-mode.info
+ dodoc ChangeLog README
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/${PN}.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}
diff --git a/app-emacs/gnuplot-mode/metadata.xml b/app-emacs/gnuplot-mode/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/gnuplot-mode/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>