summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2008-06-14 22:30:05 +0000
committerLuca Barbato <lu_zero@gentoo.org>2008-06-14 22:30:05 +0000
commitc3406a0528fb8f9c31441eb0810fe0d5d7ea1f47 (patch)
tree4611ba06dcc31514aa13f2e1d4998974f3693d1c /app-emulation/bochs
parentLatest x86_64 beta client (diff)
downloadgentoo-2-c3406a0528fb8f9c31441eb0810fe0d5d7ea1f47.tar.gz
gentoo-2-c3406a0528fb8f9c31441eb0810fe0d5d7ea1f47.tar.bz2
gentoo-2-c3406a0528fb8f9c31441eb0810fe0d5d7ea1f47.zip
Address bug #226533
(Portage version: 2.1.5.4)
Diffstat (limited to 'app-emulation/bochs')
-rw-r--r--app-emulation/bochs/ChangeLog6
-rw-r--r--app-emulation/bochs/bochs-2.2.6.ebuild106
-rw-r--r--app-emulation/bochs/bochs-2.3.5.ebuild111
-rw-r--r--app-emulation/bochs/bochs-2.3.ebuild9
4 files changed, 9 insertions, 223 deletions
diff --git a/app-emulation/bochs/ChangeLog b/app-emulation/bochs/ChangeLog
index ddd0a729e58d..8392c4c4747e 100644
--- a/app-emulation/bochs/ChangeLog
+++ b/app-emulation/bochs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/bochs
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.76 2008/06/05 02:22:51 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.77 2008/06/14 22:30:05 lu_zero Exp $
+
+ 14 Jun 2008; Luca Barbato <lu_zero@gentoo.org> -bochs-2.2.6.ebuild,
+ bochs-2.3.ebuild, -bochs-2.3.5.ebuild:
+ Address bug #226533
*bochs-2.3.7 (05 Jun 2008)
diff --git a/app-emulation/bochs/bochs-2.2.6.ebuild b/app-emulation/bochs/bochs-2.2.6.ebuild
deleted file mode 100644
index d6ef4ae3a0e0..000000000000
--- a/app-emulation/bochs/bochs-2.2.6.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.2.6.ebuild,v 1.10 2007/09/28 23:38:51 dirtyepic Exp $
-
-inherit eutils wxwidgets
-
-DESCRIPTION="a LGPL-ed pc emulator"
-HOMEPAGE="http://bochs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
- http://bochs.sourceforge.net/guestos/dlxlinux4.tar.gz
- mirror://gentoo/${P}-unicode.patch.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 ppc ~sparc x86"
-IUSE="debugger readline sdl wxwindows X ncurses vnc"
-
-RDEPEND="virtual/libc
- X? ( x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXpm )
- sdl? ( media-libs/libsdl )
- wxwindows? ( =x11-libs/wxGTK-2.6* )
- readline? ( sys-libs/readline )
- ncurses? ( sys-libs/ncurses )"
-
-DEPEND="${RDEPEND}
- X? ( x11-proto/xproto )
- >=sys-apps/sed-4
- >=app-text/opensp-1.5"
-
-src_unpack() {
- unpack ${P}.tar.gz
- cd ${S}
- sed -i \
- -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux4.tar.gz .:" \
- -e "s:BOCHSDIR=:BOCHSDIR=/usr/$(get_libdir)/bochs#:" \
- -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' Makefile.in || \
- die "sed Makefile.in failed"
-
-# Make it use the correct path to gtk-2
- sed -i -e "s:/opt/gnome:/usr:" configure
-# Fix some bad coding for gcc-4.1 compliance
- sed -i -e "s:\#ifndef PARANOID:\#if 0:" iodev/hdimage.h
-# Make sure wxwindows 2.6 is used in case both 2.6 and 2.4 are installed
- sed -i -e "s:wx-config:wx-config-2.6:" configure
-# wx unicode patches from fedora and bits the fedora missed
- epatch ${DISTDIR}/${P}-unicode.patch.gz
-}
-
-src_compile() {
- export WX_GTK_VER=2.6
-
- use wxwindows && \
- need-wxwidgets gtk2
-
- [[ "$ARCH" == "x86" ]] \
- && myconf="--enable-idle-hack --enable-fast-function-calls"
- myconf="${myconf} `use_with sdl`"
- myconf="${myconf} `use_enable readline`"
- use wxwindows && \
- myconf="${myconf} --with-wx"
- use wxwindows || \
- myconf="${myconf} --without-wx"
- use debugger && \
- myconf="$myconf --enable-debugger --enable-disasm \
- --enable-x86-debugger --enable-iodebug"
- use debugger || \
- myconf="$myconf --enable-gdb-stub"
- use vnc && \
- myconf="$myconf --with-rfb"
-
- use X && \
- myconf="$myconf --with-x11"
-
- use ncurses && \
- myconf="$myconf --with-term"
-
- if ! use X && ! use ncurses && ! use vnc && ! use sdl
- then
- myconf="$myconf --with-nogui"
- fi
-
-# needed to use gtk2 includes and libs
- autoconf
- ./configure \
- --enable-usb --enable-pci --enable-vbe \
- --enable-sse=2 --enable-3dnow --enable-plugins \
- --enable-cpu-level=6 --enable-all-optimizations \
- --enable-ne2000 --enable-sb16=linux --enable-clgd54xx \
- --enable-apic --enable-compressed-hd \
- --enable-pni --enable-sep --host=${CHOST} \
- --libdir=/usr/$(get_libdir) --prefix=/usr \
- ${myconf} || die "configure failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR=${D} install unpack_dlx || die "make install failed"
- #workaround
- make prefix=${D}/usr install_dlx
-
- dodoc CHANGES README TESTFORM.txt || die "dodoc failed"
-}
diff --git a/app-emulation/bochs/bochs-2.3.5.ebuild b/app-emulation/bochs/bochs-2.3.5.ebuild
deleted file mode 100644
index 00fb4c0c1da3..000000000000
--- a/app-emulation/bochs/bochs-2.3.5.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.3.5.ebuild,v 1.2 2007/09/28 23:38:51 dirtyepic Exp $
-
-inherit eutils wxwidgets
-
-DESCRIPTION="a LGPL-ed pc emulator"
-HOMEPAGE="http://bochs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
- http://bochs.sourceforge.net/guestos/dlxlinux4.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-IUSE="debugger readline sdl svga wxwindows X ncurses vnc"
-
-RDEPEND="virtual/libc
- X? ( x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXpm )
- sdl? ( media-libs/libsdl )
- svga? ( media-libs/svgalib )
- wxwindows? ( =x11-libs/wxGTK-2.6* )
- readline? ( sys-libs/readline )
- ncurses? ( sys-libs/ncurses )"
-
-DEPEND="${RDEPEND}
- X? ( x11-proto/xproto )
- >=sys-apps/sed-4
- >=app-text/opensp-1.5"
-
-src_unpack() {
- unpack ${P}.tar.gz
- cd ${S}
- sed -i \
- -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux4.tar.gz .:" \
- -e "s:BOCHSDIR=:BOCHSDIR=/usr/$(get_libdir)/bochs#:" \
- -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' Makefile.in || \
- die "sed Makefile.in failed"
-
-# Make it use the correct path to gtk-2
- sed -i -e "s:/opt/gnome:/usr:" configure
-# Fix some bad coding for gcc-4.1 compliance
- sed -i -e "s:\#ifndef PARANOID:\#if 0:" iodev/hdimage.h
-# Make sure wxwindows 2.6 is used in case both 2.6 and 2.4 are installed
- sed -i -e "s:wx-config:wx-config-2.6:" configure
-}
-
-src_compile() {
- export WX_GTK_VER=2.6
-
- use wxwindows && \
- need-wxwidgets gtk2
-
- [[ "$ARCH" == "x86" ]] \
- && myconf="--enable-idle-hack --enable-fast-function-calls"
- [[ "$ARCH" == "amd64" ]] \
- && myconf="--enable-x86-64"
- myconf="${myconf} `use_with sdl`"
- myconf="${myconf} `use_with svga`"
- myconf="${myconf} `use_enable readline`"
- use wxwindows && \
- myconf="${myconf} --with-wx"
- use wxwindows || \
- myconf="${myconf} --without-wx"
-
- if use debugger
- then
- myconf="$myconf --enable-debugger --enable-disasm \
- --enable-x86-debugger --enable-iodebug"
- else
- myconf="$myconf --enable-gdb-stub --disable-smp"
- fi
-
- use vnc && \
- myconf="$myconf --with-rfb"
-
- use X && \
- myconf="$myconf --with-x11"
-
- use ncurses && \
- myconf="$myconf --with-term"
-
- if ! use X && ! use ncurses && ! use vnc && ! use sdl
- then
- myconf="$myconf --with-nogui"
- fi
-
-# needed to use gtk2 includes and libs
- autoconf
- ./configure \
- --enable-usb --enable-pci --enable-vbe \
- --enable-sse=4 --enable-3dnow --enable-plugins \
- --enable-cpu-level=6 --enable-all-optimizations \
- --enable-ne2000 --enable-sb16=linux --enable-clgd54xx \
- --enable-apic --enable-compressed-hd \
- --enable-sep --host=${CHOST} \
- --libdir=/usr/$(get_libdir) --prefix=/usr \
- ${myconf} || die "configure failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR=${D} install unpack_dlx || die "make install failed"
- #workaround
- make prefix=${D}/usr install_dlx
-
- dodoc CHANGES README TESTFORM.txt || die "dodoc failed"
-}
diff --git a/app-emulation/bochs/bochs-2.3.ebuild b/app-emulation/bochs/bochs-2.3.ebuild
index f8f5a37997ec..f3b6f3c63089 100644
--- a/app-emulation/bochs/bochs-2.3.ebuild
+++ b/app-emulation/bochs/bochs-2.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.3.ebuild,v 1.6 2007/09/28 23:38:51 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.3.ebuild,v 1.7 2008/06/14 22:30:05 lu_zero Exp $
-inherit eutils wxwidgets
+inherit eutils wxwidgets autotools
DESCRIPTION="a LGPL-ed pc emulator"
HOMEPAGE="http://bochs.sourceforge.net/"
@@ -49,6 +49,7 @@ src_unpack() {
epatch ${FILESDIR}/${P}-redog.patch
epatch ${FILESDIR}/${P}-floppy.patch
epatch ${FILESDIR}/${P}-ne2k.patch
+ eautoconf
}
src_compile() {
@@ -84,8 +85,6 @@ src_compile() {
myconf="$myconf --with-nogui"
fi
-# needed to use gtk2 includes and libs
- autoconf
./configure \
--enable-usb --enable-pci --enable-vbe \
--enable-sse=2 --enable-3dnow --enable-plugins \