summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-20 05:05:34 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-20 05:05:34 +0000
commitf84ee436d01e48a44c8d6c5da9e3b01d740b0cc3 (patch)
tree2c3e086e0ac7c1f4d40189e330d4fc8f70023bd6 /app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-5.0.3.ebuild
parentremoved broken older version and updated stable with gcc4 and bash3 patches (diff)
downloadgentoo-2-f84ee436d01e48a44c8d6c5da9e3b01d740b0cc3.tar.gz
gentoo-2-f84ee436d01e48a44c8d6c5da9e3b01d740b0cc3.tar.bz2
gentoo-2-f84ee436d01e48a44c8d6c5da9e3b01d740b0cc3.zip
Version bump #140950 by riskable.
(Portage version: 2.1.1_pre3-r1)
Diffstat (limited to 'app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-5.0.3.ebuild')
-rw-r--r--app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-5.0.3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-5.0.3.ebuild b/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-5.0.3.ebuild
new file mode 100644
index 000000000000..9a31d6976cd4
--- /dev/null
+++ b/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-5.0.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-5.0.3.ebuild,v 1.1 2006/07/20 05:05:34 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="specialized version of wine for MS Office"
+HOMEPAGE="http://www.codeweavers.com/site/products/cxoffice/"
+SRC_URI="install-crossover-pro-${PV}.sh"
+
+LICENSE="CROSSOVER"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="nas"
+RESTRICT="fetch nostrip"
+
+RDEPEND="nas? ( media-libs/nas )
+ || (
+ ( x11-libs/libXrandr x11-libs/libXi x11-libs/libXmu x11-libs/libXxf86dga x11-libs/libXxf86vm )
+ virtual/x11
+ )
+ sys-libs/glibc
+ amd64? ( app-emulation/emul-linux-x86-xlibs )"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE}"
+ einfo "and place ${A} in ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ dodir /opt/cxoffice
+ cp -r * "${D}"/opt/cxoffice || die "cp failed"
+ rm -r "${D}"/opt/cxoffice/setup.{sh,data}
+ insinto /opt/cxoffice/etc
+ doins support/templates/cxoffice.conf
+}
+
+pkg_postinst() {
+ einfo "Run /opt/cxoffice/bin/cxsetup as normal user to create"
+ einfo "bottles and install Windows applications."
+}