summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-08-13 12:21:33 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-08-13 12:21:33 +0000
commit81f5ee58caeb709c6b00e3f819b69cd8d6808976 (patch)
treeddd2b6b90001b3d950e2f373aea4baba8ce0a7db /app-emulation/dinero/dinero-4.7.ebuild
parentMarked ppc stable for bug #318881. (diff)
downloadgentoo-2-81f5ee58caeb709c6b00e3f819b69cd8d6808976.tar.gz
gentoo-2-81f5ee58caeb709c6b00e3f819b69cd8d6808976.tar.bz2
gentoo-2-81f5ee58caeb709c6b00e3f819b69cd8d6808976.zip
Respect LDFLAGS wrt bug 331837. Thanks to Diego for report.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/dinero/dinero-4.7.ebuild')
-rw-r--r--app-emulation/dinero/dinero-4.7.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/app-emulation/dinero/dinero-4.7.ebuild b/app-emulation/dinero/dinero-4.7.ebuild
index 792cfdf40a8c..e5e194cdc4c1 100644
--- a/app-emulation/dinero/dinero-4.7.ebuild
+++ b/app-emulation/dinero/dinero-4.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dinero/dinero-4.7.ebuild,v 1.9 2008/12/30 18:53:51 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dinero/dinero-4.7.ebuild,v 1.10 2010/08/13 12:21:33 xarthisius Exp $
inherit toolchain-funcs
@@ -15,6 +15,13 @@ KEYWORDS="x86 ppc"
LICENSE="as-is"
IUSE=""
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e "s/\$(CC)/& \$(LDFLAGS)/" \
+ -i Makefile.in || die #331837
+}
+
src_compile() {
tc-export AR CC RANLIB
econf