summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2008-07-09 20:08:28 +0000
committerSerkan Kaba <serkan@gentoo.org>2008-07-09 20:08:28 +0000
commit11be8f3449b09095d2dba9c96a25e14d54b8af4a (patch)
tree7f7932354670288f83cd146b114210c6da611eb2 /app-emulation/emul-linux-x86-java
parentVersion bump. (diff)
downloadgentoo-2-11be8f3449b09095d2dba9c96a25e14d54b8af4a.tar.gz
gentoo-2-11be8f3449b09095d2dba9c96a25e14d54b8af4a.tar.bz2
gentoo-2-11be8f3449b09095d2dba9c96a25e14d54b8af4a.zip
Version bump. Fix quoting.
(Portage version: 2.2_rc1/cvs/Linux 2.6.24-gentoo-r8 x86_64)
Diffstat (limited to 'app-emulation/emul-linux-x86-java')
-rw-r--r--app-emulation/emul-linux-x86-java/ChangeLog10
-rw-r--r--app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.15.ebuild4
-rw-r--r--app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.16.ebuild99
-rw-r--r--app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.05.ebuild4
-rw-r--r--app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.07.ebuild101
5 files changed, 213 insertions, 5 deletions
diff --git a/app-emulation/emul-linux-x86-java/ChangeLog b/app-emulation/emul-linux-x86-java/ChangeLog
index a97392a0c98b..c10d6704eb04 100644
--- a/app-emulation/emul-linux-x86-java/ChangeLog
+++ b/app-emulation/emul-linux-x86-java/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/emul-linux-x86-java
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/ChangeLog,v 1.55 2008/05/22 20:37:29 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/ChangeLog,v 1.56 2008/07/09 20:08:28 serkan Exp $
+
+*emul-linux-x86-java-1.6.0.07 (09 Jul 2008)
+*emul-linux-x86-java-1.5.0.16 (09 Jul 2008)
+
+ 09 Jul 2008; Serkan Kaba <serkan@gentoo.org>
+ emul-linux-x86-java-1.5.0.15.ebuild, +emul-linux-x86-java-1.5.0.16.ebuild,
+ emul-linux-x86-java-1.6.0.05.ebuild, +emul-linux-x86-java-1.6.0.07.ebuild:
+ Version bump. Fix quoting.
22 May 2008; Markus Meier <maekke@gentoo.org>
emul-linux-x86-java-1.6.0.06.ebuild:
diff --git a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.15.ebuild b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.15.ebuild
index 43e810bd7175..fc253335a534 100644
--- a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.15.ebuild
+++ b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.15.ebuild,v 1.6 2008/04/19 15:03:51 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.15.ebuild,v 1.7 2008/07/09 20:08:28 serkan Exp $
inherit versionator pax-utils eutils java-vm-2
@@ -32,7 +32,7 @@ QA_TEXTRELS_amd64="opt/${P}/lib/i386/motif21/libmawt.so
src_unpack() {
mkdir bundled-jdk
cd bundled-jdk
- sh ${DISTDIR}/${At} --accept-license --unpack || die "Failed to unpack"
+ sh "${DISTDIR}"/${At} --accept-license --unpack || die "Failed to unpack"
cd ..
bash "${FILESDIR}"/construct.sh bundled-jdk sun-jdk-${PV} ${P} || die "construct.sh failed"
diff --git a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.16.ebuild b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.16.ebuild
new file mode 100644
index 000000000000..cf5f6bd20a46
--- /dev/null
+++ b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.16.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.16.ebuild,v 1.1 2008/07/09 20:08:28 serkan Exp $
+
+inherit versionator pax-utils eutils java-vm-2
+
+UPDATE="$(get_version_component_range 4)"
+UPDATE="${UPDATE#0}"
+MY_PV="$(get_version_component_range 2-3)u${UPDATE}"
+
+At="jdk-${MY_PV}-dlj-linux-i586.bin"
+DESCRIPTION="32bit version Sun's J2SE Development Kit"
+HOMEPAGE="http://java.sun.com/j2se/1.5.0/"
+SRC_URI="http://download.java.net/dlj/binaries/${At}"
+
+SLOT="1.5"
+LICENSE="dlj-1.1"
+KEYWORDS="-* ~amd64"
+RESTRICT="strip"
+IUSE="X alsa nsplugin"
+
+JAVA_VM_NO_GENERATION1=true
+
+RDEPEND="alsa? ( app-emulation/emul-linux-x86-soundlibs )
+ X? ( app-emulation/emul-linux-x86-xlibs )"
+
+JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
+
+QA_TEXTRELS_amd64="opt/${P}/lib/i386/motif21/libmawt.so
+ opt/${P}/lib/i386/libdeploy.so"
+
+src_unpack() {
+ mkdir bundled-jdk
+ cd bundled-jdk
+ sh "${DISTDIR}"/${At} --accept-license --unpack || die "Failed to unpack"
+
+ cd ..
+ bash "${FILESDIR}"/construct.sh bundled-jdk sun-jdk-${PV} ${P} || die "construct.sh failed"
+}
+
+src_compile() {
+ # Set PaX markings on all JDK/JRE executables to allow code-generation on
+ # the heap by the JIT compiler. This has to be done before CDS - #215225
+ pax-mark m $(list-paxables "${S}"/bin/*)
+
+ # see bug #207282
+ einfo "Creating the Class Data Sharing archives"
+ "${S}"/bin/java -client -Xshare:dump || die
+}
+
+src_install() {
+ dodir /opt/${P}
+ cp -pPR bin lib man javaws plugin "${D}/opt/${P}/" || die "failed to copy"
+
+ dodoc CHANGES README THIRDPARTYLICENSEREADME.txt || die
+ dohtml Welcome.html || die
+
+ if use nsplugin; then
+ local plugin_dir="ns7-gcc29"
+ if has_version '>=sys-devel/gcc-3' ; then
+ plugin_dir="ns7"
+ fi
+
+ install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so
+ fi
+
+ # FIXME figure out how to handle the control pannel conflict with
+ # sun-jdk-bin
+
+ # install control panel for Gnome/KDE
+# sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
+# -e "s/\(Name=Java\)/\1 Control Panel ${SLOT}/" \
+# ${D}/opt/${P}/plugin/desktop/sun_java.desktop > \
+# ${T}/sun_java-${SLOT}.desktop
+
+# domenu ${T}/sun_java-${SLOT}.desktop
+
+ set_java_env
+ java-vm_revdep-mask
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ if ! use X; then
+ local xwarn="X11 libraries and/or"
+ fi
+
+ echo
+ ewarn "Some parts of Sun's JDK require ${xwarn} virtual/lpr to be installed."
+ ewarn "Be careful which Java libraries you attempt to use."
+
+ echo
+ elog "Beginning with 1.5.0.10 the hotspot vm can use epoll"
+ elog "The epoll-based implementation of SelectorProvider is not selected by"
+ elog "default."
+ elog "Use java -Djava.nio.channels.spi.SelectorProvider=sun.nio.ch.EPollSelectorProvider"
+}
diff --git a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.05.ebuild b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.05.ebuild
index fc13277a91a8..18a8513b6e1a 100644
--- a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.05.ebuild
+++ b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.05.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.05.ebuild,v 1.2 2008/03/27 19:34:33 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.05.ebuild,v 1.3 2008/07/09 20:08:28 serkan Exp $
inherit versionator pax-utils java-vm-2 eutils
@@ -35,7 +35,7 @@ QA_TEXTRELS_amd64="opt/${P}/lib/i386/motif21/libmawt.so
src_unpack() {
if [[ ! -r "${DISTDIR}"/${A} ]]; then
- die "cannot read ${DISTDIR}/${A}. Please check the permission and try again."
+ die "cannot read "${DISTDIR}"/${A}. Please check the permission and try again."
fi
mkdir bundled-jdk
diff --git a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.07.ebuild b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.07.ebuild
new file mode 100644
index 000000000000..b495423013c2
--- /dev/null
+++ b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.07.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.07.ebuild,v 1.1 2008/07/09 20:08:28 serkan Exp $
+
+inherit versionator pax-utils java-vm-2 eutils
+
+UPDATE="$(get_version_component_range 4)"
+UPDATE="${UPDATE#0}"
+MY_PV="$(get_version_component_range 2)u${UPDATE}"
+
+At="jdk-${MY_PV}-dlj-linux-i586.bin"
+DESCRIPTION="32bit version Sun's J2SE Development Kit"
+HOMEPAGE="http://java.sun.com/javase/6/"
+#SRC_URI="http://download.java.net/dlj/binaries/${At}"
+SRC_URI="http://dlc.sun.com/dlj/binaries/${At}"
+
+SLOT="1.6"
+LICENSE="dlj-1.1"
+KEYWORDS="-* ~amd64"
+RESTRICT="strip"
+IUSE="X alsa nsplugin"
+
+JAVA_VM_NO_GENERATION1=true
+
+RDEPEND="alsa? ( app-emulation/emul-linux-x86-soundlibs )
+ X? ( app-emulation/emul-linux-x86-xlibs )
+ app-emulation/emul-linux-x86-compat"
+
+JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
+
+QA_TEXTRELS_amd64="opt/${P}/lib/i386/motif21/libmawt.so
+ opt/${P}/lib/i386/libdeploy.so
+ opt/${P}/lib/i386/client/libjvm.so
+ opt/${P}/lib/i386/server/libjvm.so"
+
+src_unpack() {
+ mkdir bundled-jdk
+ cd bundled-jdk
+ sh "${DISTDIR}"/${At} --accept-license --unpack || die "Failed to unpack"
+
+ cd ..
+ bash "${FILESDIR}"/construct-${SLOT}.sh bundled-jdk sun-jdk-${PV} ${P} || die "construct-${SLOT}.sh failed"
+}
+
+src_compile() {
+ # Set PaX markings on all JDK/JRE executables to allow code-generation on
+ # the heap by the JIT compiler. This has to be done before CDS - #215225
+ pax-mark m $(list-paxables "${S}"/bin/*)
+
+ # see bug #207282
+ einfo "Creating the Class Data Sharing archives"
+ "${S}"/bin/java -client -Xshare:dump || die
+ "${S}"/bin/java -server -Xshare:dump || die
+}
+
+src_install() {
+ local dirs="bin lib man javaws plugin"
+ dodir /opt/${P}
+
+ cp -pPR ${dirs} "${D}/opt/${P}/" || die "failed to copy"
+
+ dodoc README THIRDPARTYLICENSEREADME.txt || die
+ dohtml Welcome.html || die
+ dodir /opt/${P}/share/
+
+ if use nsplugin; then
+ local plugin_dir="ns7-gcc29"
+ if has_version '>=sys-devel/gcc-3' ; then
+ plugin_dir="ns7"
+ fi
+
+ install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so
+ fi
+
+ # FIXME figure out how to handle the control pannel conflict with
+ # sun-jdk-bin
+
+ # install control panel for Gnome/KDE
+# sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
+# -e "s/\(Name=Java\)/\1 Control Panel ${SLOT}/" \
+# ${D}/opt/${P}/plugin/desktop/sun_java.desktop > \
+# ${T}/sun_java-${SLOT}.desktop
+
+# domenu ${T}/sun_java-${SLOT}.desktop
+
+ set_java_env
+ java-vm_revdep-mask
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ if ! use X; then
+ local xwarn="X11 libraries and/or"
+ fi
+
+ echo
+ ewarn "Some parts of Sun's JDK require ${xwarn} virtual/lpr to be installed."
+ ewarn "Be careful which Java libraries you attempt to use."
+}