summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-12-10 21:56:21 +0000
committerVlastimil Babka <caster@gentoo.org>2010-12-10 21:56:21 +0000
commit738d69bcdbdc8c5f6382e753c693cfae2cfc0639 (patch)
tree31df0159624c9116b3fedebf2dbb45bca32fbcf6 /app-emulation/emul-linux-x86-java
parentVersion bump. (diff)
downloadgentoo-2-738d69bcdbdc8c5f6382e753c693cfae2cfc0639.tar.gz
gentoo-2-738d69bcdbdc8c5f6382e753c693cfae2cfc0639.tar.bz2
gentoo-2-738d69bcdbdc8c5f6382e753c693cfae2cfc0639.zip
Version bump.
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/emul-linux-x86-java')
-rw-r--r--app-emulation/emul-linux-x86-java/ChangeLog8
-rw-r--r--app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.23.ebuild112
2 files changed, 119 insertions, 1 deletions
diff --git a/app-emulation/emul-linux-x86-java/ChangeLog b/app-emulation/emul-linux-x86-java/ChangeLog
index 9ef3e84707b3..c1299b7da453 100644
--- a/app-emulation/emul-linux-x86-java/ChangeLog
+++ b/app-emulation/emul-linux-x86-java/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/emul-linux-x86-java
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/ChangeLog,v 1.93 2010/10/13 12:56:47 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/ChangeLog,v 1.94 2010/12/10 21:56:21 caster Exp $
+
+*emul-linux-x86-java-1.6.0.23 (10 Dec 2010)
+
+ 10 Dec 2010; Vlastimil Babka <caster@gentoo.org>
+ +emul-linux-x86-java-1.6.0.23.ebuild:
+ Version bump.
13 Oct 2010; Vlastimil Babka <caster@gentoo.org>
-emul-linux-x86-java-1.6.0.20.ebuild,
diff --git a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.23.ebuild b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.23.ebuild
new file mode 100644
index 000000000000..93ccc17f0833
--- /dev/null
+++ b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.23.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.23.ebuild,v 1.1 2010/12/10 21:56:21 caster Exp $
+
+inherit versionator pax-utils java-vm-2 eutils
+
+UPDATE="$(get_version_component_range 4)"
+UPDATE="${UPDATE#0}"
+MY_PV="$(get_version_component_range 2)u${UPDATE}"
+
+At="jdk-${MY_PV}-dlj-linux-i586.bin"
+DESCRIPTION="Sun's Java SE Runtime Environment (32bit)"
+HOMEPAGE="http://java.sun.com/javase/6/"
+#SRC_URI="http://download.java.net/dlj/binaries/${At}"
+SRC_URI="http://dlc.sun.com/dlj/binaries/${At}"
+
+SLOT="1.6"
+LICENSE="dlj-1.1"
+KEYWORDS="-* ~amd64"
+RESTRICT="strip"
+IUSE="X alsa nsplugin"
+
+JAVA_VM_NO_GENERATION1=true
+
+RDEPEND="alsa? ( app-emulation/emul-linux-x86-soundlibs )
+ X? ( app-emulation/emul-linux-x86-xlibs )"
+
+JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
+
+QA_TEXTRELS_amd64="opt/${P}/lib/i386/motif21/libmawt.so
+ opt/${P}/lib/i386/libdeploy.so
+ opt/${P}/lib/i386/client/libjvm.so
+ opt/${P}/lib/i386/server/libjvm.so"
+QA_DT_HASH="opt/${P}/.*"
+
+src_unpack() {
+ mkdir bundled-jdk
+ cd bundled-jdk
+ sh "${DISTDIR}"/${At} --accept-license --unpack || die "Failed to unpack"
+
+ cd ..
+ bash "${FILESDIR}"/construct-${SLOT}.sh bundled-jdk sun-jdk-${PV} ${P} || die "construct-${SLOT}.sh failed"
+}
+
+src_compile() {
+ # Set PaX markings on all JDK/JRE executables to allow code-generation on
+ # the heap by the JIT compiler. This has to be done before CDS - #215225
+ pax-mark m $(list-paxables "${S}"/bin/*)
+
+ # see bug #207282
+ einfo "Creating the Class Data Sharing archives"
+ "${S}"/bin/java -client -Xshare:dump || die
+ "${S}"/bin/java -server -Xshare:dump || die
+}
+
+src_install() {
+ local dirs="bin lib man javaws plugin"
+ dodir /opt/${P}
+
+ cp -pPR ${dirs} "${D}/opt/${P}/" || die "failed to copy"
+
+ dodoc README THIRDPARTYLICENSEREADME.txt || die
+ dohtml Welcome.html || die
+ dodir /opt/${P}/share/
+
+ if use nsplugin; then
+ local plugin_dir="ns7-gcc29"
+ if has_version '>=sys-devel/gcc-3' ; then
+ plugin_dir="ns7"
+ fi
+
+ install_mozilla_plugin /opt/${P}/lib/i386/libnpjp2.so
+ install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so old_oji
+ fi
+
+ # FIXME figure out how to handle the control pannel conflict with
+ # sun-jdk-bin
+
+ # install control panel for Gnome/KDE
+# sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
+# -e "s/\(Name=Java\)/\1 Control Panel ${SLOT}/" \
+# ${D}/opt/${P}/plugin/desktop/sun_java.desktop > \
+# ${T}/sun_java-${SLOT}.desktop
+
+# domenu ${T}/sun_java-${SLOT}.desktop
+
+ set_java_env
+ java-vm_revdep-mask
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ elog
+ elog "Two variants of the nsplugin are available via eselect java-nsplugin."
+ elog "Note that starting with ${PN}-1.6.0.19 their naming and the default changed,"
+ elog "users with the old plugin set are switched to the new default automatically."
+ elog "The default ${VMHANDLE} is the new 'plugin2' which works in Firefox 3 (xulrunner-1.9)"
+ elog "and newer, the ${VMHANDLE}-old_oji is the old plugin using the OJI API"
+ elog "that was removed in Firefox 3.6 (xulrunner-1.9.2)."
+ elog "For more info see https://jdk6.dev.java.net/plugin2/"
+ elog
+
+ if ! use X; then
+ local xwarn="X11 libraries and/or"
+ fi
+
+ echo
+ ewarn "Some parts of Sun's JDK require ${xwarn} virtual/lpr to be installed."
+ ewarn "Be careful which Java libraries you attempt to use."
+}