summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé María Alonso <nimiux@gentoo.org>2014-06-24 08:47:11 +0000
committerJosé María Alonso <nimiux@gentoo.org>2014-06-24 08:47:11 +0000
commitc06214d23d224eb24cc93cbd52689797f7d44b54 (patch)
tree283b264fabc27a42505ff37590bf3d987ade7a5d /app-emulation/free42
parentDrop EAPI=1. #513918 (diff)
downloadgentoo-2-c06214d23d224eb24cc93cbd52689797f7d44b54.tar.gz
gentoo-2-c06214d23d224eb24cc93cbd52689797f7d44b54.tar.bz2
gentoo-2-c06214d23d224eb24cc93cbd52689797f7d44b54.zip
Version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key D628E536)
Diffstat (limited to 'app-emulation/free42')
-rw-r--r--app-emulation/free42/ChangeLog8
-rw-r--r--app-emulation/free42/files/free42-1.5.3a-fix-makefile.patch30
-rw-r--r--app-emulation/free42/free42-1.5.3a.ebuild46
3 files changed, 83 insertions, 1 deletions
diff --git a/app-emulation/free42/ChangeLog b/app-emulation/free42/ChangeLog
index d52ee81b037a..0c73ed9e7bac 100644
--- a/app-emulation/free42/ChangeLog
+++ b/app-emulation/free42/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/free42
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/free42/ChangeLog,v 1.19 2014/06/23 21:49:31 nimiux Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/free42/ChangeLog,v 1.20 2014/06/24 08:47:11 nimiux Exp $
+
+*free42-1.5.3a (24 Jun 2014)
+
+ 24 Jun 2014; Chema Alonso <nimiux@gentoo.org> +free42-1.5.3a.ebuild,
+ +files/free42-1.5.3a-fix-makefile.patch:
+ Version bump
23 Jun 2014; Chema Alonso <nimiux@gentoo.org> -free42-1.4.75.ebuild,
-files/free42-1.4.75-fix-alsa.patch:
diff --git a/app-emulation/free42/files/free42-1.5.3a-fix-makefile.patch b/app-emulation/free42/files/free42-1.5.3a-fix-makefile.patch
new file mode 100644
index 000000000000..8f73b4405e7f
--- /dev/null
+++ b/app-emulation/free42/files/free42-1.5.3a-fix-makefile.patch
@@ -0,0 +1,30 @@
+diff -Nuar a/gtk/Makefile b/gtk/Makefile
+--- a/gtk/Makefile 2014-06-21 19:46:55.000000000 +0200
++++ b/gtk/Makefile 2014-06-24 00:03:38.719906032 +0200
+@@ -19,7 +19,6 @@
+ -Wall \
+ -Wno-parentheses \
+ -Wno-write-strings \
+- -g \
+ -I/usr/X11R6/include \
+ -fno-exceptions \
+ -fno-rtti \
+@@ -30,14 +29,11 @@
+ -DDECIMAL_GLOBAL_ROUNDING_ACCESS_FUNCTIONS=1 \
+ -DDECIMAL_GLOBAL_EXCEPTION_FLAGS=1 \
+ -DDECIMAL_GLOBAL_EXCEPTION_FLAGS_ACCESS_FUNCTIONS=1 \
+- -D_WCHAR_T_DEFINED
++ -D_WCHAR_T_DEFINED \
++ ${CXXFLAGS}
+
+-LDFLAGS = -L/usr/X11R6/lib
+-LIBS := gcc111libbid-$(shell uname -m).a -lXmu $(shell pkg-config --libs gtk+-2.0)
+-
+-ifeq "$(shell uname -s)" "Linux"
+-LDFLAGS += -Wl,--hash-style=both
+-endif
++LDFLAGS := -L/usr/X11R6/lib ${LDFLAGS}
++LIBS := gcc111libbid-$(shell uname -m).a -lXmu -lX11 -ldl -lpthread $(shell pkg-config --libs gtk+-2.0)
+
+ SRCS = shell_main.cc shell_skin.cc skins.cc keymap.cc shell_loadimage.cc \
+ shell_spool.cc core_main.cc core_commands1.cc core_commands2.cc \
diff --git a/app-emulation/free42/free42-1.5.3a.ebuild b/app-emulation/free42/free42-1.5.3a.ebuild
new file mode 100644
index 000000000000..2e4b44051140
--- /dev/null
+++ b/app-emulation/free42/free42-1.5.3a.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/free42/free42-1.5.3a.ebuild,v 1.1 2014/06/24 08:47:11 nimiux Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An HP-42S Calculator Simulator"
+HOMEPAGE="http://thomasokken.com/free42/"
+SRC_URI="mirror://gentoo/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa"
+
+DEPEND="dev-libs/atk
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/pango
+ alsa? ( media-libs/alsa-lib )"
+
+RDEPEND="${DEPEND}
+ x11-libs/libX11
+ x11-libs/libXmu"
+
+S="${WORKDIR}/${PN}-nologo-${PV}"
+
+src_prepare() {
+ sed -i -e 's/print_gif_name\[FILENAMELEN\]/print_gif_name\[1000\]/' \
+ "${S}/gtk/shell_main.cc" || die
+ epatch "${FILESDIR}"/${P}-fix-makefile.patch
+}
+
+src_compile() {
+ local myconf
+ use alsa && myconf="AUDIO_ALSA=yes"
+ emake CXX="$(tc-getCXX)" BCD_MATH=1 ${myconf} -C "${S}/gtk"
+}
+
+src_install() {
+ dodoc CREDITS HISTORY README TODO
+ dobin gtk/free42dec
+}