summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-09-17 13:28:31 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-09-17 13:28:31 +0000
commit3ec3a450ea853a61b83e6225ec50c98ff2681224 (patch)
treee0c1838fa660c48f17b553ee5f237f1a91549353 /app-emulation/fuse
parentFix building with libpng15 wrt #383201 by Diego Elio Pettenò. USE="static-li... (diff)
downloadgentoo-2-3ec3a450ea853a61b83e6225ec50c98ff2681224.tar.gz
gentoo-2-3ec3a450ea853a61b83e6225ec50c98ff2681224.tar.bz2
gentoo-2-3ec3a450ea853a61b83e6225ec50c98ff2681224.zip
Fix building with libpng15 (missing zlib.h include) wrt #383223 by Diego Elio Pettenò
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/fuse')
-rw-r--r--app-emulation/fuse/ChangeLog7
-rw-r--r--app-emulation/fuse/files/fuse-1.0.0-libpng15.patch10
-rw-r--r--app-emulation/fuse/fuse-1.0.0.ebuild28
3 files changed, 32 insertions, 13 deletions
diff --git a/app-emulation/fuse/ChangeLog b/app-emulation/fuse/ChangeLog
index e803f9ad8e31..13a1bee237af 100644
--- a/app-emulation/fuse/ChangeLog
+++ b/app-emulation/fuse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/fuse
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/fuse/ChangeLog,v 1.33 2011/05/02 20:01:15 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/fuse/ChangeLog,v 1.34 2011/09/17 13:28:31 ssuominen Exp $
+
+ 17 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> fuse-1.0.0.ebuild,
+ +files/fuse-1.0.0-libpng15.patch:
+ Fix building with libpng15 (missing zlib.h include) wrt #383223 by Diego Elio
+ Pettenò
*fuse-1.0.0 (02 May 2011)
diff --git a/app-emulation/fuse/files/fuse-1.0.0-libpng15.patch b/app-emulation/fuse/files/fuse-1.0.0-libpng15.patch
new file mode 100644
index 000000000000..3da2d672c47b
--- /dev/null
+++ b/app-emulation/fuse/files/fuse-1.0.0-libpng15.patch
@@ -0,0 +1,10 @@
+--- screenshot.c
++++ screenshot.c
+@@ -48,6 +48,7 @@
+
+ #ifdef USE_LIBPNG
+
++#include <zlib.h>
+ #include <png.h>
+
+ static int get_rgb32_data( libspectrum_byte *rgb32_data, size_t stride,
diff --git a/app-emulation/fuse/fuse-1.0.0.ebuild b/app-emulation/fuse/fuse-1.0.0.ebuild
index e2dcecbaa94e..114c05728f07 100644
--- a/app-emulation/fuse/fuse-1.0.0.ebuild
+++ b/app-emulation/fuse/fuse-1.0.0.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/fuse/fuse-1.0.0.ebuild,v 1.1 2011/05/02 20:01:15 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/fuse/fuse-1.0.0.ebuild,v 1.2 2011/09/17 13:28:31 ssuominen Exp $
-EAPI="3"
+EAPI=4
+inherit eutils
DESCRIPTION="Free Unix Spectrum Emulator by Philip Kendall"
HOMEPAGE="http://fuse-emulator.sourceforge.net"
@@ -45,14 +46,21 @@ RDEPEND="~app-emulation/libspectrum-1.0.0
!alsa? ( ao? ( media-libs/libao ) )
joystick? ( media-libs/libjsw ) ) ) ) ) )
dev-libs/glib:2
- png? ( media-libs/libpng )
+ png? ( media-libs/libpng sys-libs/zlib )
xml? ( dev-libs/libxml2 )"
DEPEND="${RDEPEND}
dev-lang/perl
dev-util/pkgconfig"
+DOCS=( AUTHORS ChangeLog README THANKS )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng15.patch
+}
+
src_configure() {
local guiflag
+
if use gtk; then
guiflag=""
elif use sdl; then
@@ -66,7 +74,9 @@ src_configure() {
else # We default to X user interface
guiflag="--without-gtk"
fi
- econf --without-win32 \
+
+ econf \
+ --without-win32 \
${guiflag} \
$(use_with gpm) \
$(use_with alsa) \
@@ -75,16 +85,10 @@ src_configure() {
$(use_enable joystick ui-joystick) \
$(use_with xml libxml2) \
$(use_with png ) \
- $(use_enable memlimit smallmem) \
- || die "econf failed!"
-}
-
-src_compile() {
- emake || die "emake failed!"
+ $(use_enable memlimit smallmem)
}
src_install() {
- emake install DESTDIR="${D}" || die
- dodoc AUTHORS ChangeLog README THANKS
+ default
doman man/fuse.1
}