summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-04-07 14:50:37 +0000
committerMike Frysinger <vapier@gentoo.org>2007-04-07 14:50:37 +0000
commit9af2d4177cc0fc52dd448fe969c7b9d4ec6ce06d (patch)
treea161710b4cb7c6cda7eecd6b72f50d46e6d95ef4 /app-emulation/hercules
parentupdate (diff)
downloadgentoo-2-9af2d4177cc0fc52dd448fe969c7b9d4ec6ce06d.tar.gz
gentoo-2-9af2d4177cc0fc52dd448fe969c7b9d4ec6ce06d.tar.bz2
gentoo-2-9af2d4177cc0fc52dd448fe969c7b9d4ec6ce06d.zip
Version bump #116190 by Jay Maynard.
(Portage version: 2.1.2.3)
Diffstat (limited to 'app-emulation/hercules')
-rw-r--r--app-emulation/hercules/ChangeLog9
-rw-r--r--app-emulation/hercules/files/digest-hercules-3.043
-rw-r--r--app-emulation/hercules/hercules-3.04.ebuild33
3 files changed, 43 insertions, 2 deletions
diff --git a/app-emulation/hercules/ChangeLog b/app-emulation/hercules/ChangeLog
index c6cb5727a4cd..878ae8753f9f 100644
--- a/app-emulation/hercules/ChangeLog
+++ b/app-emulation/hercules/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/hercules
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/ChangeLog,v 1.16 2007/01/25 22:11:56 genone Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/ChangeLog,v 1.17 2007/04/07 14:50:37 vapier Exp $
+
+*hercules-3.04 (07 Apr 2007)
+
+ 07 Apr 2007; Mike Frysinger <vapier@gentoo.org> +hercules-3.04.ebuild:
+ Version bump #116190 by Jay Maynard.
25 Jan 2007; Marius Mauch <genone@gentoo.org> hercules-2.17.1-r1.ebuild,
hercules-3.00.ebuild, hercules-3.01.ebuild, hercules-3.02.ebuild:
diff --git a/app-emulation/hercules/files/digest-hercules-3.04 b/app-emulation/hercules/files/digest-hercules-3.04
new file mode 100644
index 000000000000..da6fe5c6936b
--- /dev/null
+++ b/app-emulation/hercules/files/digest-hercules-3.04
@@ -0,0 +1,3 @@
+MD5 7c7df7d52bf0365d5cbe051dc9e2e481 hercules-3.04.tar.gz 2079774
+RMD160 ef13c0625eba2623648bbfeba73144e1cd87d6f4 hercules-3.04.tar.gz 2079774
+SHA256 4512a7c2b86b4a92c337c99761295aa4eaa54e90da3d0881c283b69c03b1eed5 hercules-3.04.tar.gz 2079774
diff --git a/app-emulation/hercules/hercules-3.04.ebuild b/app-emulation/hercules/hercules-3.04.ebuild
new file mode 100644
index 000000000000..0a8a8fd52a71
--- /dev/null
+++ b/app-emulation/hercules/hercules-3.04.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/hercules-3.04.ebuild,v 1.1 2007/04/07 14:50:37 vapier Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Hercules System/370, ESA/390 and zArchitecture Mainframe Emulator"
+HOMEPAGE="http://www.hercules-390.org/"
+SRC_URI="http://www.hercules-390.org/${P}.tar.gz"
+
+LICENSE="QPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="custom-cflags"
+
+src_compile() {
+ use custom-cflags || strip-flags
+ econf \
+ --enable-cckd-bzip2 \
+ --enable-het-bzip2 \
+ --enable-setuid-hercifc \
+ --enable-custom="Gentoo Linux ${PF}.ebuild" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die
+ dohtml -r html/
+ insinto /usr/share/hercules
+ doins hercules.cnf
+ dodoc README.* RELEASE.NOTES CHANGES
+}