summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2011-06-03 18:33:21 +0000
committerDoug Goldstein <cardoe@gentoo.org>2011-06-03 18:33:21 +0000
commitdf172bc7730c04d32e580ed187e70b954f09ce24 (patch)
treec47d55a693d1d30a771fb358f0e3d12a2fc565af /app-emulation/libvirt
parentalpha/arm/ia64/s390/sh/sparc stable wrt #368459 (diff)
downloadgentoo-2-df172bc7730c04d32e580ed187e70b954f09ce24.tar.gz
gentoo-2-df172bc7730c04d32e580ed187e70b954f09ce24.tar.bz2
gentoo-2-df172bc7730c04d32e580ed187e70b954f09ce24.zip
Version bump. Contains updates to the init script service ordering. bug #344211
(Portage version: 2.1.9.50/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/libvirt')
-rw-r--r--app-emulation/libvirt/ChangeLog9
-rwxr-xr-xapp-emulation/libvirt/files/libvirtd.init-r4119
-rw-r--r--app-emulation/libvirt/libvirt-0.9.2_rc2.ebuild253
3 files changed, 380 insertions, 1 deletions
diff --git a/app-emulation/libvirt/ChangeLog b/app-emulation/libvirt/ChangeLog
index d4d41b6b3aa7..4900980aa0f8 100644
--- a/app-emulation/libvirt/ChangeLog
+++ b/app-emulation/libvirt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/libvirt
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.107 2011/06/03 18:13:03 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.108 2011/06/03 18:33:21 cardoe Exp $
+
+*libvirt-0.9.2_rc2 (03 Jun 2011)
+
+ 03 Jun 2011; Doug Goldstein <cardoe@gentoo.org> +libvirt-0.9.2_rc2.ebuild,
+ +files/libvirtd.init-r4:
+ Version bump. Contains updates to the init script service ordering. bug
+ #344211
03 Jun 2011; Doug Goldstein <cardoe@gentoo.org> libvirt-9999.ebuild:
Fix issue where the git eclass isn't pulled in for the 9999 build. bug
diff --git a/app-emulation/libvirt/files/libvirtd.init-r4 b/app-emulation/libvirt/files/libvirtd.init-r4
new file mode 100755
index 000000000000..41c801c97137
--- /dev/null
+++ b/app-emulation/libvirt/files/libvirtd.init-r4
@@ -0,0 +1,119 @@
+#!/sbin/runscript
+
+opts="start stop status reload restart"
+
+depend() {
+ need net
+ after ntp-client ntpd nfs iscsid nfsmount portmap rpc.statd iptables ip6tables ebtables ceph corosync
+}
+
+libvirtd_virsh() {
+ # Silence errors because virsh always throws an error about
+ # not finding the hypervisor version when connecting to libvirtd
+ LC_ALL=C virsh -c qemu:///system "$@" 2>/dev/null
+}
+
+libvirtd_dom_list() {
+ # Make sure that it wouldn't be confused if the domain name
+ # contains the word running.
+ libvirtd_virsh list | awk '$3 == "running" { print $1 }'
+}
+
+libvirtd_dom_count() {
+ # Make sure that it wouldn't be confused if the domain name
+ # contains the word running.
+ libvirtd_virsh list | awk 'BEGIN { count = 0 } \
+ $3 == "running" { count++ } \
+ END { print count }'
+}
+
+libvirtd_net_list() {
+ # The purpose of the awk is to avoid networks with 'active' in the name
+ libvirtd_virsh net-list | awk '$2 == "active" { print $1 }'
+}
+
+libvirtd_net_count() {
+ # The purpose of the awk is to avoid networks with 'active' in the name
+ libvirtd_virsh net-list | awk 'BEGIN { count = 0 } \
+ $2 == "active" { count++ } \
+ END { print count }'
+}
+
+
+start() {
+ ebegin "Starting libvirtd"
+ start-stop-daemon --start \
+ --env KRB5_KTNAME=/etc/libvirt/krb5.tab \
+ --exec /usr/sbin/libvirtd -- -d ${LIBVIRTD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping libvirtd"
+ # try to shutdown all (KVM/Qemu) domains
+ DOM_COUNT="$(libvirtd_dom_count)"
+ if [ "${LIBVIRTD_KVM_SHUTDOWN}" != "none" ] \
+ && [ "${DOM_COUNT}" != "0" ] ; then
+
+ einfo " Shutting down domain(s):"
+ for DOM_ID in $(libvirtd_dom_list) ; do
+ NAME="$(libvirtd_virsh domname ${DOM_ID} | head -n 1)"
+ einfo " ${NAME}"
+ libvirtd_virsh ${LIBVIRTD_KVM_SHUTDOWN} ${DOM_ID} > /dev/null
+ done
+
+ if [ -n "${LIBVIRTD_KVM_SHUTDOWN_MAXWAIT}" ] ; then
+ COUNTER="${LIBVIRTD_KVM_SHUTDOWN_MAXWAIT}"
+ else
+ COUNTER=500
+ fi
+
+ if [ "${LIBVIRTD_KVM_SHUTDOWN}" = "shutdown" ]; then
+ einfo " Waiting ${COUNTER} seconds while domains shutdown ..."
+ DOM_COUNT="$(libvirtd_dom_count)"
+ while [ ${DOM_COUNT} -gt 0 ] && [ ${COUNTER} -gt 0 ] ; do
+ DOM_COUNT="$(libvirtd_dom_count)"
+ sleep 1
+ COUNTER=$((${COUNTER} - 1))
+ echo -n "."
+ done
+ fi
+
+ DOM_COUNT="$(libvirtd_dom_count)"
+ if [ "${DOM_COUNT}" != "0" ] ; then
+ eerror " !!! Some guests are still running, stopping anyway"
+ fi
+
+ fi
+
+ NET_COUNT="$(libvirtd_net_count)"
+ if [ "${LIBVIRTD_NET_SHUTDOWN}" != "no" ] \
+ && [ "${NET_COUNT}" != "0" ]; then
+
+ einfo " Shutting down network(s):"
+ for NET_NAME in $(libvirtd_net_list); do
+ einfo " ${NET_NAME}"
+ libvirtd_virsh net-destroy ${NET_NAME} > /dev/null
+ done
+
+ NET_COUNT="$(libvirtd_net_count)"
+ if [ "${NET_COUNT}" != "0" ]; then
+ eerror " !!! Some networks are still active, stopping anyway"
+ fi
+ fi
+
+ # Now actually stop the daemon
+ start-stop-daemon --stop --quiet --exec \
+ /usr/sbin/libvirtd --pidfile=/var/run/libvirtd.pid
+ eend $?
+}
+
+reload() {
+ ebegin "Stopping libvirtd without shutting down your VMs"
+ start-stop-daemon --stop --quiet --exec \
+ /usr/sbin/libvirtd --pidfile=/var/run/libvirtd.pid
+ eend $?
+
+ # Call the original start function
+ start
+}
diff --git a/app-emulation/libvirt/libvirt-0.9.2_rc2.ebuild b/app-emulation/libvirt/libvirt-0.9.2_rc2.ebuild
new file mode 100644
index 000000000000..9265026f08b9
--- /dev/null
+++ b/app-emulation/libvirt/libvirt-0.9.2_rc2.ebuild
@@ -0,0 +1,253 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-0.9.2_rc2.ebuild,v 1.1 2011/06/03 18:33:21 cardoe Exp $
+
+#BACKPORTS=1
+#AUTOTOOLIZE=yes
+
+EAPI="2"
+
+MY_P="${P/_rc/-rc}"
+
+PYTHON_DEPEND="python? 2:2.4"
+#RESTRICT_PYTHON_ABIS="3.*"
+#SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils python ${AUTOTOOLIZE+autotools}
+
+DESCRIPTION="C toolkit to manipulate virtual machines"
+HOMEPAGE="http://www.libvirt.org/"
+SRC_URI="http://libvirt.org/sources/${MY_P}.tar.gz
+ ftp://libvirt.org/libvirt/${MY_P}.tar.gz
+ ${BACKPORTS:+
+ http://dev.gentoo.org/~flameeyes/${PN}/${MY_P}-backports-${BACKPORTS}.tar.bz2
+ http://dev.gentoo.org/~cardoe/${PN}/${MY_P}-backports-${BACKPORTS}.tar.bz2}"
+S="${WORKDIR}/${P%_rc*}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="avahi caps debug iscsi +json +libvirtd lvm +lxc macvtap +network nfs \
+ nls numa openvz parted pcap phyp policykit python qemu sasl selinux udev \
+ uml virtualbox virt-network xen"
+# IUSE=one : bug #293416 & bug #299011
+
+# gettext.sh command is used by the libvirt command wrappers, and it's
+# non-optional, so put it into RDEPEND.
+RDEPEND="sys-libs/readline
+ sys-libs/ncurses
+ >=net-misc/curl-7.18.0
+ >=dev-libs/libxml2-2.7.6
+ >=dev-libs/libnl-1.1
+ >=net-libs/gnutls-1.0.25
+ sys-fs/sysfsutils
+ sys-apps/util-linux
+ sys-devel/gettext
+ >=net-analyzer/netcat6-1.0-r2
+ avahi? ( >=net-dns/avahi-0.6[dbus] )
+ caps? ( sys-libs/libcap-ng )
+ iscsi? ( sys-block/open-iscsi )
+ json? ( =dev-libs/yajl-1* )
+ libvirtd? ( net-misc/bridge-utils )
+ lvm? ( >=sys-fs/lvm2-2.02.48-r2 )
+ macvtap? ( >=dev-libs/libnl-1.1 )
+ nfs? ( net-fs/nfs-utils )
+ numa? ( sys-process/numactl )
+ openvz? ( sys-kernel/openvz-sources )
+ parted? (
+ >=sys-block/parted-1.8[device-mapper]
+ sys-fs/lvm2
+ )
+ pcap? ( >=net-libs/libpcap-1.0.0 )
+ phyp? ( net-libs/libssh2 )
+ policykit? ( >=sys-auth/polkit-0.9 )
+ qemu? ( || ( app-emulation/qemu-kvm >=app-emulation/qemu-0.10.0 app-emulation/qemu-kvm-spice ) )
+ sasl? ( dev-libs/cyrus-sasl )
+ selinux? ( >=sys-libs/libselinux-2.0.85 )
+ virtualbox? ( || ( app-emulation/virtualbox >=app-emulation/virtualbox-bin-2.2.0 ) )
+ xen? ( app-emulation/xen-tools app-emulation/xen )
+ udev? ( >=sys-fs/udev-145 >=x11-libs/libpciaccess-0.10.9 )
+ virt-network? ( net-dns/dnsmasq
+ >=net-firewall/iptables-1.4.10
+ net-firewall/ebtables
+ sys-apps/iproute2 )"
+# one? ( dev-libs/xmlrpc-c )
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ [[ -n ${BACKPORTS} ]] && \
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
+ epatch
+
+ [[ -n ${AUTOTOOLIZE} ]] && eautoreconf
+}
+
+src_configure() {
+ local myconf=""
+
+ myconf="${myconf} $(use_enable debug)"
+
+ ## enable/disable daemon, otherwise client only utils
+ myconf="${myconf} $(use_with libvirtd)"
+
+ ## enable/disable the daemon using avahi to find VMs
+ myconf="${myconf} $(use_with avahi)"
+
+ ## hypervisors on the local host
+ myconf="${myconf} $(use_with xen) $(use_with xen xen-inotify)"
+ # leave it automagic as it depends on the version of xen used.
+ use xen || myconf+=" --without-libxl"
+
+ myconf="${myconf} $(use_with openvz)"
+ myconf="${myconf} $(use_with lxc)"
+ if use virtualbox && has_version app-emulation/virtualbox-ose; then
+ myconf="${myconf} --with-vbox=/usr/lib/virtualbox-ose/"
+ else
+ myconf="${myconf} $(use_with virtualbox vbox)"
+ fi
+ myconf="${myconf} $(use_with uml)"
+ myconf="${myconf} $(use_with qemu)"
+ # doesn't belong with hypervisors but links to libvirtd for some reason
+ #myconf="${myconf} $(use_with one)"
+
+ ## hypervisor protocols
+ myconf="${myconf} $(use_with phyp)"
+ myconf="${myconf} --with-esx"
+
+ ## additional host drivers
+ myconf="${myconf} $(use_with network)"
+ myconf="${myconf} --with-storage-fs"
+ myconf="${myconf} $(use_with lvm storage-lvm)"
+ myconf="${myconf} $(use_with iscsi storage-iscsi)"
+ myconf="${myconf} $(use_with parted storage-disk)"
+ myconf="${myconf} $(use_with lvm storage-mpath)"
+ myconf="${myconf} $(use_with numa numactl)"
+ myconf="${myconf} $(use_with selinux)"
+
+ # udev for device support details
+ myconf="${myconf} $(use_with udev)"
+
+ # linux capability support so we don't need privileged accounts
+ myconf="${myconf} $(use_with caps capng)"
+
+ ## auth stuff
+ myconf="${myconf} $(use_with policykit polkit)"
+ myconf="${myconf} $(use_with sasl)"
+
+ # network biits
+ myconf="${myconf} $(use_with macvtap)"
+ myconf="${myconf} $(use_with pcap libpcap)"
+
+ ## other
+ myconf="${myconf} $(use_enable nls)"
+ myconf="${myconf} $(use_with python)"
+ myconf="${myconf} $(use_with json yajl)"
+
+ ## stuff we don't yet support
+ myconf="${myconf} --without-netcf --without-audit"
+
+ # we use udev over hal
+ myconf="${myconf} --without-hal"
+
+ # this is a nasty trick to work around the problem in bug
+ # #275073. The reason why we don't solve this properly is that
+ # it'll require us to rebuild autotools (and we don't really want
+ # to do that right now). The proper solution has been sent
+ # upstream and should hopefully land in 0.7.7, in the mean time,
+ # mime the same functionality with this.
+ case ${CHOST} in
+ *cygwin* | *mingw* )
+ ;;
+ *)
+ ac_cv_prog_WINDRES=no
+ ;;
+ esac
+
+ econf \
+ ${myconf} \
+ --disable-static \
+ --docdir=/usr/share/doc/${PF} \
+ --with-remote \
+ --localstatedir=/var \
+ --with-remote-pid-file=/var/run/libvirtd.pid
+}
+
+src_test() {
+ # Explicitly allow parallel build of tests
+ emake check || die "tests failed"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ HTML_DIR=/usr/share/doc/${PF}/html \
+ DOCS_DIR=/usr/share/doc/${PF}/python \
+ EXAMPLE_DIR=/usr/share/doc/${PF}/python/examples \
+ || die "emake install failed"
+
+ find "${D}" -name '*.la' -delete || die
+
+ use libvirtd || return 0
+ # From here, only libvirtd-related instructions, be warned!
+
+ newinitd "${FILESDIR}/libvirtd.init-r4" libvirtd || die
+ newconfd "${FILESDIR}/libvirtd.confd-r2" libvirtd || die
+
+ keepdir /var/lib/libvirt/images
+}
+
+pkg_preinst() {
+ # we only ever want to generate this once
+ if [[ -e "${ROOT}"/etc/libvirt/qemu/networks/default.xml ]]; then
+ rm -rf "${D}"/etc/libvirt/qemu/networks/default.xml
+ fi
+
+ # We really don't want to use or support old PolicyKit cause it
+ # screws with the new polkit integration
+ if has_version sys-auth/policykit; then
+ rm -rf "${D}"/usr/share/PolicyKit/policy/org.libvirt.unix.policy
+ fi
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize $(python_get_sitedir)/libvirt.py
+
+ elog
+ if use policykit && has_version sys-auth/policykit; then
+ elog "You must have run the following at least once:"
+ elog
+ elog "$ polkit-auth --grant org.libvirt.unix.manage --user \"USERNAME\""
+ elog
+ elog "to grant USERNAME access to libvirt when using USE=policykit"
+ else
+ elog "To allow normal users to connect to libvirtd you must change the"
+ elog " unix sock group and/or perms in /etc/libvirt/libvirtd.conf"
+ fi
+
+ use libvirtd || return 0
+ # From here, only libvirtd-related instructions, be warned!
+
+ elog
+ elog "For the basic networking support (bridged and routed networks)"
+ elog "you don't need any extra software. For more complex network modes"
+ elog "including but not limited to NATed network, you can enable the"
+ elog "'virt-network' USE flag."
+ elog
+ if has_version net-dns/dnsmasq; then
+ ewarn "If you have a DNS server setup on your machine, you will have"
+ ewarn "to configure /etc/dnsmasq.conf to enable the following settings: "
+ ewarn " bind-interfaces"
+ ewarn " interface or except-interface"
+ ewarn
+ ewarn "Otherwise you might have issues with your existing DNS server."
+ fi
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup $(python_get_sitedir)/libvirt.py
+}