summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-04-29 23:32:31 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-04-29 23:32:31 +0000
commit3dbd58b2fc1ab9283936cb04d00feb88ca442114 (patch)
treee8ff649a7c09a9432ba63c10a9af8fe00d48f66d /app-emulation/lxc
parentFix infinite look if the catalog is corrupted. (diff)
downloadgentoo-2-3dbd58b2fc1ab9283936cb04d00feb88ca442114.tar.gz
gentoo-2-3dbd58b2fc1ab9283936cb04d00feb88ca442114.tar.bz2
gentoo-2-3dbd58b2fc1ab9283936cb04d00feb88ca442114.zip
Fix my own patch for mounting devices and files.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/lxc')
-rw-r--r--app-emulation/lxc/ChangeLog8
-rw-r--r--app-emulation/lxc/files/lxc-0.8.0_rc1-blockmount.patch31
-rw-r--r--app-emulation/lxc/lxc-0.8.0_rc1-r3.ebuild (renamed from app-emulation/lxc/lxc-0.8.0_rc1-r2.ebuild)2
3 files changed, 32 insertions, 9 deletions
diff --git a/app-emulation/lxc/ChangeLog b/app-emulation/lxc/ChangeLog
index c1eda5d20dcc..5966e9f2c258 100644
--- a/app-emulation/lxc/ChangeLog
+++ b/app-emulation/lxc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/lxc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/ChangeLog,v 1.33 2012/04/28 00:17:01 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/ChangeLog,v 1.34 2012/04/29 23:32:31 flameeyes Exp $
+
+*lxc-0.8.0_rc1-r3 (29 Apr 2012)
+
+ 29 Apr 2012; Diego E. Pettenò <flameeyes@gentoo.org> +lxc-0.8.0_rc1-r3.ebuild,
+ -lxc-0.8.0_rc1-r2.ebuild, files/lxc-0.8.0_rc1-blockmount.patch:
+ Fix my own patch for mounting devices and files.
*lxc-0.8.0_rc1-r2 (28 Apr 2012)
diff --git a/app-emulation/lxc/files/lxc-0.8.0_rc1-blockmount.patch b/app-emulation/lxc/files/lxc-0.8.0_rc1-blockmount.patch
index f7e6d250ef3d..34e20f508c64 100644
--- a/app-emulation/lxc/files/lxc-0.8.0_rc1-blockmount.patch
+++ b/app-emulation/lxc/files/lxc-0.8.0_rc1-blockmount.patch
@@ -1,4 +1,4 @@
-From f895fe1ad3aca8fed492df12adcd8710bca8ca32 Mon Sep 17 00:00:00 2001
+From dd411d7ae02f75aa2ffe8cd5e6271b36c113d03f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Diego=20Elio=20Petten=C3=B2?= <flameeyes@flameeyes.eu>
Date: Fri, 27 Apr 2012 17:01:33 -0700
Subject: [PATCH] Workaround requirement to use the realname of the block
@@ -13,12 +13,12 @@ file.
Signed-off-by: Diego Elio Pettenò <flameeyes@flameeyes.eu>
---
- src/lxc/conf.c | 34 +++++++++++++++++++---------------
+ src/lxc/conf.c | 38 +++++++++++++++++++++-----------------
src/lxc/conf.h | 1 +
- 2 files changed, 20 insertions(+), 15 deletions(-)
+ 2 files changed, 22 insertions(+), 17 deletions(-)
diff --git a/src/lxc/conf.c b/src/lxc/conf.c
-index e8088bb..593871a 100644
+index e8088bb..3ba6db6 100644
--- a/src/lxc/conf.c
+++ b/src/lxc/conf.c
@@ -350,9 +350,9 @@ static int mount_unknow_fs(const char *rootfs, const char *target, int mntopt)
@@ -120,17 +120,34 @@ index e8088bb..593871a 100644
ERROR("failed to mount rootfs");
return -1;
}
-@@ -1110,7 +1112,9 @@ static int mount_entry_on_absolute_rootfs(struct mntent *mntent,
+@@ -1099,7 +1101,7 @@ static inline int mount_entry_on_systemfs(struct mntent *mntent)
+ static int mount_entry_on_absolute_rootfs(struct mntent *mntent,
+ const struct lxc_rootfs *rootfs)
+ {
+- char *aux;
++ char *aux, *rootfs_path;
+ char path[MAXPATHLEN];
+ unsigned long mntflags;
+ char *mntdata;
+@@ -1110,14 +1112,16 @@ static int mount_entry_on_absolute_rootfs(struct mntent *mntent,
return -1;
}
- aux = strstr(mntent->mnt_dir, rootfs->path);
-+ aux = rootfs->isblock ? rootfs->mount : rootfs->path;
++ rootfs_path = rootfs->isblock ? rootfs->mount : rootfs->path;
+
-+ aux = strstr(mntent->mnt_dir, aux);
++ aux = strstr(mntent->mnt_dir, rootfs_path);
if (!aux) {
WARN("ignoring mount point '%s'", mntent->mnt_dir);
goto out;
+ }
+
+ snprintf(path, MAXPATHLEN, "%s/%s", rootfs->mount,
+- aux + strlen(rootfs->path));
++ aux + strlen(rootfs_path));
+
+ ret = mount_entry(mntent->mnt_fsname, path, mntent->mnt_type,
+ mntflags, mntdata);
diff --git a/src/lxc/conf.h b/src/lxc/conf.h
index 09f55cb..b70e637 100644
--- a/src/lxc/conf.h
diff --git a/app-emulation/lxc/lxc-0.8.0_rc1-r2.ebuild b/app-emulation/lxc/lxc-0.8.0_rc1-r3.ebuild
index 36705aeddce3..063563a3468a 100644
--- a/app-emulation/lxc/lxc-0.8.0_rc1-r2.ebuild
+++ b/app-emulation/lxc/lxc-0.8.0_rc1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/lxc-0.8.0_rc1-r2.ebuild,v 1.1 2012/04/28 00:17:01 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/lxc-0.8.0_rc1-r3.ebuild,v 1.1 2012/04/29 23:32:31 flameeyes Exp $
EAPI="4"