summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2008-08-30 20:04:43 +0000
committerMike Auty <ikelos@gentoo.org>2008-08-30 20:04:43 +0000
commitc4761da88cd2af218987d0f715e3cba82c6a9354 (patch)
tree4c144b1447e0d1343763081dac209edc675a2802 /app-emulation/open-vm-tools
parentx86 stable, bug #236057 (diff)
downloadgentoo-2-c4761da88cd2af218987d0f715e3cba82c6a9354.tar.gz
gentoo-2-c4761da88cd2af218987d0f715e3cba82c6a9354.tar.bz2
gentoo-2-c4761da88cd2af218987d0f715e3cba82c6a9354.zip
Version bump, now with unity and 2.6.26 support.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'app-emulation/open-vm-tools')
-rw-r--r--app-emulation/open-vm-tools/ChangeLog8
-rw-r--r--app-emulation/open-vm-tools/metadata.xml1
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-0.0.20080808.109361.ebuild126
3 files changed, 134 insertions, 1 deletions
diff --git a/app-emulation/open-vm-tools/ChangeLog b/app-emulation/open-vm-tools/ChangeLog
index 024fab0705f9..8113f19014dd 100644
--- a/app-emulation/open-vm-tools/ChangeLog
+++ b/app-emulation/open-vm-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/open-vm-tools
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/ChangeLog,v 1.7 2008/07/28 18:57:03 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/ChangeLog,v 1.8 2008/08/30 20:04:43 ikelos Exp $
+
+*open-vm-tools-0.0.20080808.109361 (30 Aug 2008)
+
+ 30 Aug 2008; Mike Auty <ikelos@gentoo.org> metadata.xml,
+ +open-vm-tools-0.0.20080808.109361.ebuild:
+ Version bump, now with unity and 2.6.26 support.
28 Jul 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/app-emulation/open-vm-tools/metadata.xml b/app-emulation/open-vm-tools/metadata.xml
index 5df2a8b0c02c..4186fedf6928 100644
--- a/app-emulation/open-vm-tools/metadata.xml
+++ b/app-emulation/open-vm-tools/metadata.xml
@@ -4,5 +4,6 @@
<herd>vmware</herd>
<use>
<flag name='icu'>Enable unicode support using <pkg>dev-libs/icu</pkg></flag>
+ <flag name='unity'>Enable host unity support</flag>
</use>
</pkgmetadata>
diff --git a/app-emulation/open-vm-tools/open-vm-tools-0.0.20080808.109361.ebuild b/app-emulation/open-vm-tools/open-vm-tools-0.0.20080808.109361.ebuild
new file mode 100644
index 000000000000..07654fa609bc
--- /dev/null
+++ b/app-emulation/open-vm-tools/open-vm-tools-0.0.20080808.109361.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-0.0.20080808.109361.ebuild,v 1.1 2008/08/30 20:04:43 ikelos Exp $
+
+inherit pam eutils linux-mod versionator
+
+MY_DATE="$(get_version_component_range 3)"
+MY_BUILD="$(get_version_component_range 4)"
+MY_PV="${MY_DATE:0:4}.${MY_DATE:4:2}.${MY_DATE:6:2}-${MY_BUILD}"
+MY_P="${PN}-${MY_PV}"
+
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Opensourced tools for VMware guests"
+HOMEPAGE="http://open-vm-tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="X xinerama icu unity"
+DEPEND="
+ virtual/linux-sources
+ sys-apps/ethtool
+ X? (
+ x11-libs/libX11
+ x11-libs/gtk+
+ )
+ unity? (
+ x11-libs/libXScrnSaver
+ dev-libs/uriparser
+ )
+ xinerama? (
+ x11-libs/libXinerama
+ )
+ !app-emulation/vmware-workstation-tools
+ !app-emulation/vmware-server-tools
+ !app-emulation/vmware-esx-tools
+ sys-process/procps
+ dev-libs/libdnet
+ icu? ( dev-libs/icu )
+ "
+
+RDEPEND="${DEPEND/virtual\/linux\-sources/}
+ virtual/pam
+ X? (
+ x11-base/xorg-server
+ x11-drivers/xf86-video-vmware
+ x11-drivers/xf86-input-vmmouse
+ )
+ unity? (
+ x11-libs/libXScrnSaver
+ dev-libs/uriparser
+ )
+"
+
+VMWARE_MOD_DIR="modules/linux"
+VMWARE_MODULE_LIST="vmblock vmhgfs vmsync vmmemctl vmxnet"
+
+pkg_setup() {
+
+ linux-mod_pkg_setup
+ MODULE_NAMES=""
+ BUILD_TARGETS="auto-build HEADER_DIR=${KERNEL_DIR}/include BUILD_DIR=${KV_OUT_DIR}"
+
+ for mod in ${VMWARE_MODULE_LIST};
+ do
+ if [[ "${mod}" == "vmxnet" ]];
+ then
+ MODTARGET="net"
+ else
+ MODTARGET="openvmtools"
+ fi
+ MODULE_NAMES="${MODULE_NAMES} ${mod}(${MODTARGET}:${S}/${VMWARE_MOD_DIR}/${mod})"
+ done
+
+ ewarn "If you're compiling for a hardened target, please use the hardened"
+ ewarn "toolchain (see bug #200376, comment 18)."
+
+ enewgroup vmware
+
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/default-scripts.patch"
+}
+
+src_compile() {
+ econf \
+ --without-kernel-modules \
+ $(use_with icu) \
+ $(use_with X x) \
+ $(use_enable unity) \
+ $(use_enable xinerama multimon) \
+ || die "Error: econf failed!"
+
+ linux-mod_src_compile
+
+ emake || die
+}
+
+src_install() {
+
+ linux-mod_src_install
+
+ pamd_mimic_system vmware-guestd auth account
+
+ emake install DESTDIR="${D}" || die "Failed to install"
+
+ newinitd "${FILESDIR}/open-vm.initd" vmware-tools
+ newconfd "${FILESDIR}/open-vm.confd" vmware-tools
+
+ if use X;
+ then
+ insinto /etc/X11/xinit/xinitrc.d
+ doins "${FILESDIR}/10-vmware-tools"
+
+ elog "To be able to use the drag'n'drop feature of VMware for file"
+ elog "exchange, you need to do this:"
+ elog " Add 'vmware-tools' to your default runlevel"
+ elog " Add the users which should have access to this function"
+ elog " to the group 'vmware'"
+ fi
+}