summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2013-11-05 20:37:41 +0000
committerChristian Ruppert <idl0r@gentoo.org>2013-11-05 20:37:41 +0000
commit52bf2156493098493ab8e664aaa75211d2d836a1 (patch)
tree693a31fabda4f7d2c97f549dfbd3e62107bf8719 /app-emulation/spice
parentAdd ruby20. Drop ree18. (diff)
downloadgentoo-2-52bf2156493098493ab8e664aaa75211d2d836a1.tar.gz
gentoo-2-52bf2156493098493ab8e664aaa75211d2d836a1.tar.bz2
gentoo-2-52bf2156493098493ab8e664aaa75211d2d836a1.zip
ALSA is only required with USE=client, 490416
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B427ABC8)
Diffstat (limited to 'app-emulation/spice')
-rw-r--r--app-emulation/spice/ChangeLog8
-rw-r--r--app-emulation/spice/files/spice-0.12.4-alsa-conditional.patch51
-rw-r--r--app-emulation/spice/spice-0.12.4-r1.ebuild (renamed from app-emulation/spice/spice-0.12.4.ebuild)10
3 files changed, 64 insertions, 5 deletions
diff --git a/app-emulation/spice/ChangeLog b/app-emulation/spice/ChangeLog
index 7007b3976039..6f3d219b89c5 100644
--- a/app-emulation/spice/ChangeLog
+++ b/app-emulation/spice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/spice
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.56 2013/10/09 05:24:36 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.57 2013/11/05 20:37:41 idl0r Exp $
+
+*spice-0.12.4-r1 (05 Nov 2013)
+
+ 05 Nov 2013; Christian Ruppert <idl0r@gentoo.org> -spice-0.12.4.ebuild,
+ +spice-0.12.4-r1.ebuild, +files/spice-0.12.4-alsa-conditional.patch:
+ ALSA is only required with USE=client, 490416
09 Oct 2013; Michał Górny <mgorny@gentoo.org> spice-0.12.3-r1.ebuild,
spice-0.12.4.ebuild:
diff --git a/app-emulation/spice/files/spice-0.12.4-alsa-conditional.patch b/app-emulation/spice/files/spice-0.12.4-alsa-conditional.patch
new file mode 100644
index 000000000000..82abb37c61d1
--- /dev/null
+++ b/app-emulation/spice/files/spice-0.12.4-alsa-conditional.patch
@@ -0,0 +1,51 @@
+From 58195c195110f0dbb24d831b5eefb2f094848b26 Mon Sep 17 00:00:00 2001
+From: Christian Ruppert <idl0r@qasl.de>
+Date: Sun, 03 Nov 2013 17:38:55 +0000
+Subject: Require alsa only with --enable-client
+
+Hey guys,
+
+the alsa libraries/header seem to be required only when configured with
+--enable-client so I wrote a patch to make configure respect it.
+
+--
+Regards,
+Christian Ruppert
+
+From 53683cc75ba092799f856f710cb45b2aacfb6123 Mon Sep 17 00:00:00 2001
+From: Christian Ruppert <idl0r@gentoo.org>
+Date: Sun, 3 Nov 2013 18:36:26 +0100
+Subject: [PATCH] Require alsa only with --enable-client
+---
+diff --git a/configure.ac b/configure.ac
+index 7e81329..882bf1b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -246,12 +246,6 @@ fi
+ AC_MSG_RESULT([found])
+ fi
+
+-if test "$os_linux" = yes; then
+- PKG_CHECK_MODULES(ALSA, alsa)
+- AC_SUBST(ALSA_CFLAGS)
+- AC_SUBST(ALSA_LIBS)
+-fi
+-
+ PKG_CHECK_MODULES(SSL, openssl)
+ AC_SUBST(SSL_CFLAGS)
+ AC_SUBST(SSL_LIBS)
+@@ -280,6 +274,12 @@ AC_SUBST(GL_LIBS)
+ SPICE_NONPKGCONFIG_LIBS+=" $GL_LIBS"
+
+ if test "x$red_target" = "xx11" && test "x$enable_client" = "xyes" ; then
++ if test "$os_linux" = yes; then
++ PKG_CHECK_MODULES(ALSA, alsa)
++ AC_SUBST(ALSA_CFLAGS)
++ AC_SUBST(ALSA_LIBS)
++ fi
++
+ PKG_CHECK_MODULES(XRANDR, xrandr)
+ PKG_CHECK_MODULES(XFIXES, xfixes)
+ PKG_CHECK_MODULES(MISC_X, x11 xext xrender)
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/app-emulation/spice/spice-0.12.4.ebuild b/app-emulation/spice/spice-0.12.4-r1.ebuild
index b1fee35a0d77..b3ec45a0d8dd 100644
--- a/app-emulation/spice/spice-0.12.4.ebuild
+++ b/app-emulation/spice/spice-0.12.4-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.12.4.ebuild,v 1.5 2013/10/09 05:24:36 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.12.4-r1.ebuild,v 1.1 2013/11/05 20:37:41 idl0r Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} pypy2_0 )
-inherit eutils python-any-r1
+inherit autotools eutils python-any-r1
DESCRIPTION="SPICE server and client."
HOMEPAGE="http://spice-space.org/"
@@ -19,7 +19,6 @@ IUSE="client sasl smartcard static-libs" # static
RDEPEND=">=x11-libs/pixman-0.17.7
>=dev-libs/glib-2.22:2
- media-libs/alsa-lib
>=media-libs/celt-0.5.1.1:0.5.1
dev-libs/openssl
virtual/jpeg
@@ -27,6 +26,7 @@ RDEPEND=">=x11-libs/pixman-0.17.7
sasl? ( dev-libs/cyrus-sasl )
smartcard? ( >=app-emulation/libcacard-0.1.2 )
client? (
+ media-libs/alsa-lib
>=x11-libs/libXrandr-1.2
x11-libs/libX11
x11-libs/libXext
@@ -69,9 +69,11 @@ pkg_setup() {
src_prepare() {
epatch \
- "${FILESDIR}/0.11.0-gold.patch"
+ "${FILESDIR}/0.11.0-gold.patch" \
+ "${FILESDIR}/${P}-alsa-conditional.patch"
epatch_user
+ eautoreconf
}
src_configure() {