summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2006-03-17 15:07:12 +0000
committerMichael Januszewski <spock@gentoo.org>2006-03-17 15:07:12 +0000
commit677c4a1f9a64af3ede00c977d944cfc3614d410b (patch)
tree1c5d283f5fee98cb5e5397052c26fa670c2b245a /app-emulation/uade/uade-2.02.ebuild
parentnew version. add gstreamer useflag, general cleanup (diff)
downloadgentoo-2-677c4a1f9a64af3ede00c977d944cfc3614d410b.tar.gz
gentoo-2-677c4a1f9a64af3ede00c977d944cfc3614d410b.tar.bz2
gentoo-2-677c4a1f9a64af3ede00c977d944cfc3614d410b.zip
Version bump (bug #126204). UADE now has support for media-sound/audacious.
(Portage version: 2.1_pre6-r3)
Diffstat (limited to 'app-emulation/uade/uade-2.02.ebuild')
-rw-r--r--app-emulation/uade/uade-2.02.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-emulation/uade/uade-2.02.ebuild b/app-emulation/uade/uade-2.02.ebuild
new file mode 100644
index 000000000000..8243ebe88ab3
--- /dev/null
+++ b/app-emulation/uade/uade-2.02.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-2.02.ebuild,v 1.1 2006/03/17 15:07:12 spock Exp $
+
+inherit eutils
+
+DESCRIPTION="Unix Amiga Delitracker Emulator - plays old Amiga tunes through UAE emulation and cloned m68k-assembler Eagleplayer API"
+HOMEPAGE="http://zakalwe.fi/uade"
+SRC_URI="http://zakalwe.fi/uade/uade2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="xmms audacious"
+
+RDEPEND="media-libs/libao
+ xmms? ( >=media-sound/xmms-1.2.2 )
+ audacious? ( >=media-sound/audacious-0.2 )"
+
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --package-prefix="${D}" \
+ $(use_with xmms) \
+ $(use_with audacious) \
+ || die "configure failed"
+ emake || die 'emake failed'
+}
+
+src_install() {
+ make install || die 'make install failed'
+ dodoc AUTHORS ChangeLog doc/BUGS doc/PLANS
+ doman doc/uade123.1
+}