summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-23 23:58:01 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-23 23:58:01 +0000
commitb6dd7ab6beffc6707e60b03cca29db17b0584960 (patch)
tree49cf7ee478f7f0cf93f3f9a9485b0c175a3cf1a6 /app-emulation/vice/files
parentwww-plugins/gnash: update USE flag checks (diff)
downloadgentoo-2-b6dd7ab6beffc6707e60b03cca29db17b0584960.tar.gz
gentoo-2-b6dd7ab6beffc6707e60b03cca29db17b0584960.tar.bz2
gentoo-2-b6dd7ab6beffc6707e60b03cca29db17b0584960.zip
Fix bug 292508 in a different way since upstream mentioned wanting configure.in check.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/vice/files')
-rw-r--r--app-emulation/vice/files/vice-2.2-xshm.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/vice/files/vice-2.2-xshm.patch b/app-emulation/vice/files/vice-2.2-xshm.patch
new file mode 100644
index 000000000000..0839f15e9005
--- /dev/null
+++ b/app-emulation/vice/files/vice-2.2-xshm.patch
@@ -0,0 +1,40 @@
+Check for xextproto 7.1.1 and include headers for X_ShmAttach.
+
+https://sourceforge.net/tracker/?func=detail&aid=2935150&group_id=223021&atid=1057617
+http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=0a4c4c5fe8ebad2dd13f5770bd90a194eebb2890
+
+--- configure.in
++++ configure.in
+@@ -2192,6 +2192,11 @@
+ [ X_LIBS="-lXext $X_LIBS";
+ LINK_X_LIBS="-lXext $LINK_X_LIBS"],,$X_LIBS)
+
++ PKG_CHECK_MODULES(XEXT, [xextproto >= 7.0.99.1],
++ HAVE_XEXTPROTO_71="yes"; AC_DEFINE(HAVE_XEXTPROTO_71, 1, [xextproto 7.1 available]),
++ HAVE_XEXTPROTO_71="no")
++ AM_CONDITIONAL(HAVE_XEXTPROTO_71, [ test "$HAVE_XEXTPROTO_71" = "yes" ])
++
+ AC_MSG_CHECKING(for X11/extensions/Xvlib.h)
+ AC_TRY_LINK([#include <X11/Xlib.h>
+ #include <X11/extensions/Xvlib.h>],
+--- src/arch/unix/x11/xaw/x11video.c
++++ src/arch/unix/x11/xaw/x11video.c
+@@ -56,6 +56,7 @@
+ #include "vice.h"
+
+ #include <X11/Xlib.h>
++#include <X11/Xlibint.h>
+ #include <X11/Xutil.h>
+ #include <X11/Intrinsic.h>
+ #include <X11/cursorfont.h>
+@@ -95,6 +96,10 @@
+ #endif
+
+ #ifdef USE_MITSHM
++#ifdef HAVE_XEXTPROTO_71
++#include <X11/extensions/shmproto.h>
++#include <X11/extensions/XShm.h>
++#endif
+ extern int shmhandler(Display* display, XErrorEvent* err);
+ extern int mitshm_failed; /* will be set to true if XShmAttach() failed */
+ extern int shmmajor; /* major number of MITSHM error codes */