summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-15 00:44:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-15 00:44:50 +0000
commit7a6522b68abbdecbd764545e9e0c91adb2754ed2 (patch)
tree30d468f867f9559e3bef3a4385e12d568e8ff025 /app-emulation/vice
parentversion bump, remove buggy version (Manifest recommit) (diff)
downloadgentoo-2-7a6522b68abbdecbd764545e9e0c91adb2754ed2.tar.gz
gentoo-2-7a6522b68abbdecbd764545e9e0c91adb2754ed2.tar.bz2
gentoo-2-7a6522b68abbdecbd764545e9e0c91adb2754ed2.zip
add patch to fix bug #53903 "monitor memory dump format string vulnerability"
Diffstat (limited to 'app-emulation/vice')
-rw-r--r--app-emulation/vice/ChangeLog9
-rw-r--r--app-emulation/vice/Manifest7
-rw-r--r--app-emulation/vice/files/1.14-console-security.patch104
-rw-r--r--app-emulation/vice/files/digest-vice-1.14-r11
-rw-r--r--app-emulation/vice/vice-1.14-r1.ebuild55
5 files changed, 173 insertions, 3 deletions
diff --git a/app-emulation/vice/ChangeLog b/app-emulation/vice/ChangeLog
index b65d1634141c..5284ad03123b 100644
--- a/app-emulation/vice/ChangeLog
+++ b/app-emulation/vice/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/vice
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.14 2004/04/14 20:02:28 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.15 2004/06/15 00:44:50 mr_bones_ Exp $
+
+*vice-1.14-r1 (14 Jun 2004)
+
+ 14 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> vice-1.14-r1.ebuild,
+ files/1.14-console-security.patch:
+ add patch to fix bug #53903 "monitor memory dump format string vulnerability"
+ Patch from upstream.
14 Apr 2004; Chris Gianelloni <wolf31o2@gentoo.org> vice-1.14.ebuild:
Adding inherit eutils per discussion amongst games developers.
diff --git a/app-emulation/vice/Manifest b/app-emulation/vice/Manifest
index de44bf9cf9bd..a734b8775ac0 100644
--- a/app-emulation/vice/Manifest
+++ b/app-emulation/vice/Manifest
@@ -1,5 +1,8 @@
-MD5 549d0cb79054195fef8e4de52feab13c vice-1.14.ebuild 1301
MD5 9415945c4ef1c57fcee6c4f63ca160df ChangeLog 1929
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 eca7586b8ef1c0d8665368c0328f9250 files/digest-vice-1.14 62
+MD5 56c2f5137beba54affe21a517563a798 vice-1.14-r1.ebuild 1431
+MD5 f9a2acd62f0867011d2978c7f8e10dfc vice-1.14.ebuild 1300
+MD5 5467080b8555dc1bad201449fbdaf87e files/1.14-console-security.patch 3709
+MD5 eca7586b8ef1c0d8665368c0328f9250 files/digest-vice-1.14-r1 62
MD5 962c8cfd8a9a308b180e1a26c4973625 files/1.14-po-Makefile.patch 560
+MD5 eca7586b8ef1c0d8665368c0328f9250 files/digest-vice-1.14 62
diff --git a/app-emulation/vice/files/1.14-console-security.patch b/app-emulation/vice/files/1.14-console-security.patch
new file mode 100644
index 000000000000..9a2e42bcd70e
--- /dev/null
+++ b/app-emulation/vice/files/1.14-console-security.patch
@@ -0,0 +1,104 @@
+Index: vice/src/arch/beos/uimon.c
+===================================================================
+RCS file: /var/lib/cvs/cbm/vice/src/arch/beos/uimon.c,v
+retrieving revision 1.9
+retrieving revision 1.9.10.1
+diff -u -r1.9 -r1.9.10.1
+--- vice/src/arch/beos/uimon.c 18 Mar 2004 19:12:57 -0000 1.9
++++ vice/src/arch/beos/uimon.c 8 Jun 2004 19:40:56 -0000 1.9.10.1
+@@ -72,7 +72,7 @@
+ {
+ va_start(ap, format);
+ buffer = lib_mvsprintf(format, ap);
+- rc = console_out(console_log, buffer);
++ rc = console_out(console_log, "%s", buffer);
+ lib_free(buffer);
+ }
+ return rc;
+Index: vice/src/arch/msdos/uimon.c
+===================================================================
+RCS file: /var/lib/cvs/cbm/vice/src/arch/msdos/uimon.c,v
+retrieving revision 1.10
+retrieving revision 1.10.10.1
+diff -u -r1.10 -r1.10.10.1
+--- vice/src/arch/msdos/uimon.c 18 Mar 2004 19:12:57 -0000 1.10
++++ vice/src/arch/msdos/uimon.c 8 Jun 2004 19:41:01 -0000 1.10.10.1
+@@ -70,7 +70,7 @@
+ if (console_log) {
+ va_start(ap, format);
+ buffer = lib_mvsprintf(format, ap);
+- rc = console_out(console_log, buffer);
++ rc = console_out(console_log, "%s", buffer);
+ lib_free(buffer);
+ }
+ return rc;
+Index: vice/src/arch/riscos/uimon.c
+===================================================================
+RCS file: /var/lib/cvs/cbm/vice/src/arch/riscos/uimon.c,v
+retrieving revision 1.10
+retrieving revision 1.10.10.1
+diff -u -r1.10 -r1.10.10.1
+--- vice/src/arch/riscos/uimon.c 18 Mar 2004 19:12:58 -0000 1.10
++++ vice/src/arch/riscos/uimon.c 8 Jun 2004 19:41:04 -0000 1.10.10.1
+@@ -72,7 +72,7 @@
+ {
+ va_start(ap, format);
+ buffer = lib_mvsprintf(format, ap);
+- rc = console_out(console_log, buffer);
++ rc = console_out(console_log, "%s", buffer);
+ lib_free(buffer);
+ }
+ return rc;
+Index: vice/src/arch/unix/uimon.c
+===================================================================
+RCS file: /var/lib/cvs/cbm/vice/src/arch/unix/uimon.c,v
+retrieving revision 1.12
+retrieving revision 1.12.4.1
+diff -u -r1.12 -r1.12.4.1
+--- vice/src/arch/unix/uimon.c 3 May 2004 06:09:12 -0000 1.12
++++ vice/src/arch/unix/uimon.c 8 Jun 2004 19:41:09 -0000 1.12.4.1
+@@ -76,7 +76,7 @@
+ {
+ va_start(ap, format);
+ buffer = lib_mvsprintf(format, ap);
+- rc = console_out(console_log, buffer);
++ rc = console_out(console_log, "%s", buffer);
+ lib_free(buffer);
+ }
+ return rc;
+Index: vice/src/arch/win32/uimon.c
+===================================================================
+RCS file: /var/lib/cvs/cbm/vice/src/arch/win32/uimon.c,v
+retrieving revision 1.36
+retrieving revision 1.36.2.1
+diff -u -r1.36 -r1.36.2.1
+--- vice/src/arch/win32/uimon.c 24 May 2004 10:30:02 -0000 1.36
++++ vice/src/arch/win32/uimon.c 8 Jun 2004 19:21:23 -0000 1.36.2.1
+@@ -2160,7 +2160,7 @@
+ {
+ va_start(ap, format);
+ buffer = lib_mvsprintf(format, ap);
+- rc = console_out(console_log, buffer);
++ rc = console_out(console_log, "%s", buffer);
+ lib_free(buffer);
+ }
+ return rc;
+
+Index: vice/src/monitor/mon_util.c
+===================================================================
+RCS file: /var/lib/cvs/cbm/vice/src/monitor/mon_util.c,v
+retrieving revision 1.13
+retrieving revision 1.13.10.1
+diff -u -r1.13 -r1.13.10.1
+--- vice/src/monitor/mon_util.c 19 Mar 2004 09:55:01 -0000 1.13
++++ vice/src/monitor/mon_util.c 8 Jun 2004 19:21:49 -0000 1.13.10.1
+@@ -48,7 +48,7 @@
+ va_start(ap, format);
+ buffer = lib_mvsprintf(format, ap);
+
+- rc = uimon_out(buffer);
++ rc = uimon_out("%s", buffer);
+ lib_free(buffer);
+
+ if (rc < 0)
+
diff --git a/app-emulation/vice/files/digest-vice-1.14-r1 b/app-emulation/vice/files/digest-vice-1.14-r1
new file mode 100644
index 000000000000..8b3d7db6170d
--- /dev/null
+++ b/app-emulation/vice/files/digest-vice-1.14-r1
@@ -0,0 +1 @@
+MD5 f25df1b8de2bbb536facbc05fcfa1db2 vice-1.14.tar.gz 3794698
diff --git a/app-emulation/vice/vice-1.14-r1.ebuild b/app-emulation/vice/vice-1.14-r1.ebuild
new file mode 100644
index 000000000000..21cbff71a65f
--- /dev/null
+++ b/app-emulation/vice/vice-1.14-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-1.14-r1.ebuild,v 1.1 2004/06/15 00:44:50 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="The Versatile Commodore 8-bit Emulator"
+HOMEPAGE="http://www.viceteam.org/"
+SRC_URI="ftp://ftp.funet.fi/pub/cbm/crossplatform/emulators/VICE/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="sdl nls gnome arts"
+
+RDEPEND="virtual/x11
+ sdl? ( media-libs/libsdl )
+ gnome? ( gnome-base/libgnomeui )
+ arts? ( kde-base/arts )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use nls && epatch "${FILESDIR}/${PV}-po-Makefile.patch"
+ # bug #53903
+ # http://www.trikaliotis.net/vicekb/vsa-2004-1
+ epatch "${FILESDIR}/${PV}-console-security.patch"
+}
+
+src_compile() {
+ egamesconf \
+ --enable-fullscreen \
+ --disable-dependency-tracking \
+ $(use_with sdl) \
+ $(use_with gnome gnomeui) \
+ $(use_with arts) \
+ $(use_enable nls) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ local docdir="${D}${GAMES_LIBDIR}/${PN}/doc"
+
+ make DESTDIR="${D}" install || die "make install failed"
+ dohtml "${docdir}/"* || die "dohtml failed"
+ dodoc \
+ AUTHORS ChangeLog FEEDBACK README \
+ "${docdir}/"{BUGS,NEWS,PETdoc.txt,TODO} \
+ "${docdir}/"{cbm_basic_tokens.txt,drive_info.txt,mon.txt,serial.txt}
+ rm -rf "${docdir}"
+ prepgamesdirs
+}