summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-02-11 03:05:43 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-02-11 03:05:43 +0000
commita6ea32339fb22d1452be3d5309ddeaff16f4456f (patch)
tree68ec44257e6d3421352f56fc2257980925cadf40 /app-emulation/vice
parentAdd EAPI check to silence repoman warnings (diff)
downloadgentoo-2-a6ea32339fb22d1452be3d5309ddeaff16f4456f.tar.gz
gentoo-2-a6ea32339fb22d1452be3d5309ddeaff16f4456f.tar.bz2
gentoo-2-a6ea32339fb22d1452be3d5309ddeaff16f4456f.zip
rework gui selection and deps; add more use flags
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-emulation/vice')
-rw-r--r--app-emulation/vice/ChangeLog8
-rw-r--r--app-emulation/vice/metadata.xml3
-rw-r--r--app-emulation/vice/vice-2.4.16-r1.ebuild (renamed from app-emulation/vice/vice-2.4.16.ebuild)130
3 files changed, 92 insertions, 49 deletions
diff --git a/app-emulation/vice/ChangeLog b/app-emulation/vice/ChangeLog
index ae36d98d87bc..76397c9bed89 100644
--- a/app-emulation/vice/ChangeLog
+++ b/app-emulation/vice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/vice
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.97 2015/02/05 03:17:04 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.98 2015/02/11 03:05:43 mr_bones_ Exp $
+
+*vice-2.4.16-r1 (11 Feb 2015)
+
+ 11 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org> +vice-2.4.16-r1.ebuild,
+ -vice-2.4.16.ebuild, metadata.xml:
+ rework gui selection and deps; add more use flags
*vice-2.4.16 (05 Feb 2015)
diff --git a/app-emulation/vice/metadata.xml b/app-emulation/vice/metadata.xml
index 84683fd48630..89baadf5a73b 100644
--- a/app-emulation/vice/metadata.xml
+++ b/app-emulation/vice/metadata.xml
@@ -3,8 +3,11 @@
<pkgmetadata>
<herd>games</herd>
<use>
+ <flag name="fullscreen">Enable the ability to run fullscreen</flag>
+ <flag name="gtk3">Use GTK+3 instead of GTK+2</flag>
<flag name='ethernet'>Enable ethernet emulation</flag>
<flag name='memmap'>Enable extra monitor features</flag>
+ <flag name='vte'>Enable support for <pkg>x11-libs/vte</pkg> in the GTK+ interface</flag>
<flag name='xrandr'>Enable support for the X xrandr extension</flag>
</use>
</pkgmetadata>
diff --git a/app-emulation/vice/vice-2.4.16.ebuild b/app-emulation/vice/vice-2.4.16-r1.ebuild
index 4e983b9263ea..a1822c0979bb 100644
--- a/app-emulation/vice/vice-2.4.16.ebuild
+++ b/app-emulation/vice/vice-2.4.16-r1.ebuild
@@ -1,67 +1,87 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-2.4.16.ebuild,v 1.1 2015/02/05 03:17:04 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-2.4.16-r1.ebuild,v 1.1 2015/02/11 03:05:43 mr_bones_ Exp $
EAPI=5
-inherit autotools eutils toolchain-funcs games
+inherit autotools eutils toolchain-funcs flag-o-matic games
DESCRIPTION="The Versatile Commodore 8-bit Emulator"
HOMEPAGE="http://vice-emu.sourceforge.net/"
SRC_URI="mirror://sourceforge/vice-emu/releases/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="Xaw3d alsa gnome nls png readline sdl ipv6 memmap ethernet oss zlib X gif jpeg xv dga xrandr ffmpeg lame pulseaudio"
+IUSE="Xaw3d alsa ethernet ffmpeg fullscreen gtk gtk3 ipv6 lame nls oss png pulseaudio readline sdl threads vte zlib"
RDEPEND="
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXpm
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libXt
- x11-libs/libXxf86vm
- x11-apps/xset
- Xaw3d? ( x11-libs/libXaw3d )
- !Xaw3d? ( !gnome? ( x11-libs/libXaw ) )
+ virtual/jpeg
+ virtual/opengl
+ media-libs/giflib
alsa? ( media-libs/alsa-lib )
- gnome? (
- x11-libs/gtk+:2
- x11-libs/vte:0
- dev-libs/atk
- x11-libs/pango
- )
- lame? ( media-sound/lame )
- ffmpeg? ( virtual/ffmpeg )
ethernet? (
>=net-libs/libpcap-0.9.8
>=net-libs/libnet-1.1.2.1
)
+ ffmpeg? ( virtual/ffmpeg )
+ lame? ( media-sound/lame )
nls? ( virtual/libintl )
png? ( media-libs/libpng:0 )
- readline? ( sys-libs/readline )
- sdl? ( media-libs/libsdl[sound] )
- gif? ( media-libs/giflib )
- jpeg? ( virtual/jpeg )
- xv? ( x11-libs/libXv )
- dga? ( x11-libs/libXxf86dga )
- xrandr? ( x11-libs/libXrandr )"
+ zlib? ( sys-libs/zlib )
+ sdl? (
+ media-libs/libsdl[joystick,sound,video]
+ )
+ !sdl? (
+ x11-libs/libX11
+ x11-libs/libXext
+ fullscreen? (
+ x11-libs/libXrandr
+ x11-libs/libXxf86vm )
+ readline? ( sys-libs/readline )
+ gtk? (
+ !gtk3? (
+ x11-libs/gtk+:2
+ vte? ( x11-libs/vte:0 )
+ )
+ gtk3? (
+ x11-libs/gtk+:3
+ vte? ( x11-libs/vte:2.90 )
+ )
+ x11-libs/pango
+ x11-libs/cairo
+ x11-libs/gtkglext
+ )
+ !gtk? (
+ x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt
+ x11-libs/libXv
+ sys-libs/readline
+ Xaw3d? ( x11-libs/libXaw3d )
+ !Xaw3d? ( x11-libs/libXaw )
+ )
+ )"
DEPEND="${RDEPEND}
virtual/pkgconfig
- x11-apps/bdftopcf
- x11-apps/mkfontdir
- x11-proto/xproto
- x11-proto/xf86vidmodeproto
- x11-proto/xextproto
- media-libs/fontconfig
- dga? ( x11-proto/xf86dgaproto )
- xv? ( x11-proto/videoproto )
+ !sdl? (
+ !gtk? (
+ x11-libs/libICE
+ x11-libs/libSM
+ )
+ x11-apps/bdftopcf
+ x11-apps/mkfontdir
+ x11-proto/xproto
+ fullscreen? ( x11-proto/xf86vidmodeproto )
+ x11-proto/xextproto
+ media-libs/fontconfig
+ x11-proto/videoproto
+ )
nls? ( sys-devel/gettext )"
pkg_pretend() {
- if use gnome && use sdl ; then
- eerror "gnome and sdl USE flags can't both be set. Pick one and mask the other one in /etc/portage/package.use"
+ if use gtk || use gtk3 && use sdl ; then
+ eerror "gtk (2 or 3) and sdl USE flags can't both be set. Pick one and mask the other one in /etc/portage/package.use"
die "Please pick one gui option."
fi
}
@@ -86,32 +106,46 @@ src_prepare() {
}
src_configure() {
+ local gui_arg
+
+ if use sdl ; then
+ gui_arg="--enable-sdlui"
+ elif use gtk || use gtk3 ; then
+ # The gtk UI code has raw calls to XOpenDisplay and
+ # is missing -lX11 if vte doesn't pull it in.
+ if ! use vte ; then
+ append-libs -lX11
+ fi
+ gui_arg="--enable-gnomeui"
+ if use gtk3 ; then
+ gui_arg="--enable-gnomeui3"
+ fi
+ fi
# don't try to actually run fc-cache (bug #280976)
FCCACHE=/bin/true \
PKG_CONFIG=$(tc-getPKG_CONFIG) \
egamesconf \
- --enable-fullscreen \
--enable-parsid \
--with-resid \
--without-arts \
--without-midas \
+ $(use_enable ethernet) \
$(use_enable ffmpeg) \
+ $(use_enable fullscreen) \
+ $(use_enable ipv6) \
$(use_enable lame) \
- $(use_enable gnome gnomeui) \
$(use_enable nls) \
+ $(use_enable vte) \
$(use_with Xaw3d xaw3d) \
$(use_with alsa) \
- $(use_with pulseaudio pulse) \
+ $(use_with oss) \
$(use_with png) \
+ $(use_with pulseaudio pulse) \
$(use_with readline) \
$(use_with sdl sdlsound) \
- $(use_enable sdl sdlui) \
- $(use_enable ipv6) \
- $(use oss || echo --without-oss) \
- $(use_enable memmap) \
- $(use_enable ethernet) \
+ $(use_with threads uithreads) \
$(use_with zlib) \
- $(use_with X x) \
+ ${gui_arg} \
--disable-option-checking
# --disable-option-checking has to be last
}