summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-01-06 07:27:57 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-01-06 07:27:57 +0000
commitf29d17343214cb53c8a06816d4b24357a3408105 (patch)
treec6f052bc02a1d8908e51b544426fb3b4e88b066f /app-emulation/vice
parentVersion bump. (diff)
downloadgentoo-2-f29d17343214cb53c8a06816d4b24357a3408105.tar.gz
gentoo-2-f29d17343214cb53c8a06816d4b24357a3408105.tar.bz2
gentoo-2-f29d17343214cb53c8a06816d4b24357a3408105.zip
EAPI=5; add arm support patch from Torsten Kurbad (bug #448134)
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-emulation/vice')
-rw-r--r--app-emulation/vice/ChangeLog8
-rw-r--r--app-emulation/vice/files/vice-2.4-arm.patch42
-rw-r--r--app-emulation/vice/vice-2.4.ebuild11
3 files changed, 54 insertions, 7 deletions
diff --git a/app-emulation/vice/ChangeLog b/app-emulation/vice/ChangeLog
index 0a8049280bb8..76983daa4d3d 100644
--- a/app-emulation/vice/ChangeLog
+++ b/app-emulation/vice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/vice
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.85 2012/11/06 21:55:05 mr_bones_ Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.86 2013/01/06 07:27:57 mr_bones_ Exp $
+
+ 06 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/vice-2.4-arm.patch, vice-2.4.ebuild:
+ EAPI=5; add arm support patch from Torsten Kurbad (bug #448134)
06 Nov 2012; Michael Sterrett <mr_bones_@gentoo.org> vice-2.4.ebuild:
add x11-libs/vte:0 dep (bug #442082)
diff --git a/app-emulation/vice/files/vice-2.4-arm.patch b/app-emulation/vice/files/vice-2.4-arm.patch
new file mode 100644
index 000000000000..d96a75d2296d
--- /dev/null
+++ b/app-emulation/vice/files/vice-2.4-arm.patch
@@ -0,0 +1,42 @@
+Index: vice/configure.in
+===================================================================
+--- vice/configure.in (Revision 26764)
++++ vice/configure.in (Revision 26765)
+@@ -2299,6 +2299,7 @@
+
+ if test x"$PARSID_SUPPORT" = "xno"; then
+ AC_CHECK_FUNCS(ioperm,[PARSID_SUPPORT=yes],)
++ AC_CHECK_FUNCS(outb_p inb_p)
+ fi
+
+ if test x"$PARSID_SUPPORT" = "xyes"; then
+Index: vice/src/arch/unix/parsid.c
+===================================================================
+--- vice/src/arch/unix/parsid.c (Revision 26764)
++++ vice/src/arch/unix/parsid.c (Revision 26765)
+@@ -217,8 +217,12 @@
+ #endif
+ #endif
+ #ifdef HAVE_IOPERM
++#ifndef HAVE_OUTB_P
++ outb(value, addr);
++#else
+ outb_p(value, addr);
+ #endif
++#endif
+ }
+
+ BYTE parsid_inb(int addr)
+@@ -237,8 +241,12 @@
+ #endif
+ #endif
+ #ifdef HAVE_IOPERM
++#ifndef HAVE_INB_P
++ return inb((unsigned short)addr);
++#else
+ return inb_p((unsigned short)addr);
+ #endif
++#endif
+ }
+
+ /* chip control pin assignments */
diff --git a/app-emulation/vice/vice-2.4.ebuild b/app-emulation/vice/vice-2.4.ebuild
index ba55dda484ec..0ec0effff02f 100644
--- a/app-emulation/vice/vice-2.4.ebuild
+++ b/app-emulation/vice/vice-2.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-2.4.ebuild,v 1.2 2012/11/06 21:55:05 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-2.4.ebuild,v 1.3 2013/01/06 07:27:57 mr_bones_ Exp $
-EAPI=2
-inherit autotools eutils games toolchain-funcs
+EAPI=5
+inherit autotools eutils toolchain-funcs games
DESCRIPTION="The Versatile Commodore 8-bit Emulator"
HOMEPAGE="http://vice-emu.sourceforge.net/"
@@ -59,6 +59,7 @@ DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-arm.patch
sed -i \
-e "s:/usr/local/lib/VICE:${GAMES_DATADIR}/${PN}:" \
man/vice.1 \
@@ -106,7 +107,7 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install
dodoc AUTHORS ChangeLog FEEDBACK README
prepgamesdirs
}