summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2011-07-27 15:37:30 +0000
committerDoug Goldstein <cardoe@gentoo.org>2011-07-27 15:37:30 +0000
commitdc9f438a3cb9fc5dd33c87b11a1a122065370546 (patch)
treef0e059012b48b72386488c99eb7b985ffcdf4e84 /app-emulation/virt-manager
parentVersion bump, bug #375727. Allow enabling of individual audio backends, bug #... (diff)
downloadgentoo-2-dc9f438a3cb9fc5dd33c87b11a1a122065370546.tar.gz
gentoo-2-dc9f438a3cb9fc5dd33c87b11a1a122065370546.tar.bz2
gentoo-2-dc9f438a3cb9fc5dd33c87b11a1a122065370546.zip
sync up the 9999 ebuild to the features of the 0.8.7-r3
(Portage version: 2.1.10.7/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/virt-manager')
-rw-r--r--app-emulation/virt-manager/ChangeLog6
-rw-r--r--app-emulation/virt-manager/virt-manager-0.8.7-r3.ebuild36
-rw-r--r--app-emulation/virt-manager/virt-manager-9999.ebuild15
3 files changed, 45 insertions, 12 deletions
diff --git a/app-emulation/virt-manager/ChangeLog b/app-emulation/virt-manager/ChangeLog
index 12b753af434b..dc386e53befa 100644
--- a/app-emulation/virt-manager/ChangeLog
+++ b/app-emulation/virt-manager/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/virt-manager
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/ChangeLog,v 1.52 2011/07/26 16:33:23 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/ChangeLog,v 1.53 2011/07/27 15:37:30 cardoe Exp $
+
+ 27 Jul 2011; Doug Goldstein <cardoe@gentoo.org> virt-manager-0.8.7-r3.ebuild,
+ virt-manager-9999.ebuild:
+ sync up the 9999 ebuild to the features of the 0.8.7-r3
26 Jul 2011; Doug Goldstein <cardoe@gentoo.org> virt-manager-0.8.7-r3.ebuild:
Add back ~x86 keyword since net-misc/spice-gtk is now ~arch keyworded on x86.
diff --git a/app-emulation/virt-manager/virt-manager-0.8.7-r3.ebuild b/app-emulation/virt-manager/virt-manager-0.8.7-r3.ebuild
index dadf2b7af222..19d7643e96b4 100644
--- a/app-emulation/virt-manager/virt-manager-0.8.7-r3.ebuild
+++ b/app-emulation/virt-manager/virt-manager-0.8.7-r3.ebuild
@@ -1,22 +1,33 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-0.8.7-r3.ebuild,v 1.2 2011/07/26 16:33:23 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-0.8.7-r3.ebuild,v 1.3 2011/07/27 15:37:30 cardoe Exp $
#BACKPORTS=
EAPI=2
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="http://git.fedorahosted.org/git/virt-manager.git"
+ GIT_ECLASS="git-2 autotools"
+fi
+
PYTHON_DEPEND="2:2.4"
# Stop gnome2.eclass from doing stuff on USE=debug
GCONF_DEBUG="no"
-inherit eutils gnome2 python ${HG_ECLASS}
+inherit eutils gnome2 python ${GIT_ECLASS}
-SRC_URI="http://virt-manager.org/download/sources/${PN}/${P}.tar.gz
- ${BACKPORTS:+mirror://gentoo/${P}-backports-${BACKPORTS}.tar.bz2}"
-KEYWORDS="~amd64 ~x86"
-VIRTINSTDEP=">=app-emulation/virtinst-0.500.6"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+ VIRTINSTDEP=">=app-emulation/virtinst-9999"
+else
+ SRC_URI="http://virt-manager.org/download/sources/${PN}/${P}.tar.gz
+ ${BACKPORTS:+mirror://gentoo/${P}-backports-${BACKPORTS}.tar.bz2}"
+ KEYWORDS="~amd64 ~x86"
+ VIRTINSTDEP=">=app-emulation/virtinst-0.500.6"
+fi
DESCRIPTION="A graphical tool for administering virtual machines (KVM/Xen)"
HOMEPAGE="http://virt-manager.org/"
@@ -52,6 +63,19 @@ src_prepare() {
EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
epatch
+ if [[ ${PV} = *9999* ]]; then
+ # virt-manager's autogen.sh touches this and eautoreconf fails
+ # unless we do this
+ touch config.rpath
+
+ rm -rf config.status
+ intltoolize --automake --copy --force
+ perl -i -p -e 's,^DATADIRNAME.*$,DATADIRNAME = share,' po/Makefile.in.in
+ perl -i -p -e 's,^GETTEXT_PACKAGE.*$,GETTEXT_PACKAGE = virt-manager,' \
+ po/Makefile.in.in
+ eautoreconf
+ fi
+
epatch "${FILESDIR}/${P}-vcpu-stats.patch"
gnome2_src_prepare
diff --git a/app-emulation/virt-manager/virt-manager-9999.ebuild b/app-emulation/virt-manager/virt-manager-9999.ebuild
index cea8a9754f67..486b2c492858 100644
--- a/app-emulation/virt-manager/virt-manager-9999.ebuild
+++ b/app-emulation/virt-manager/virt-manager-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-9999.ebuild,v 1.6 2011/07/21 21:08:50 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-9999.ebuild,v 1.7 2011/07/27 15:37:30 cardoe Exp $
-#BACKPORTS=1
+#BACKPORTS=
EAPI=2
@@ -33,7 +33,7 @@ DESCRIPTION="A graphical tool for administering virtual machines (KVM/Xen)"
HOMEPAGE="http://virt-manager.org/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="gnome-keyring policykit sasl"
+IUSE="gnome-keyring policykit sasl spice"
RDEPEND=">=dev-python/pygtk-1.99.12
>=app-emulation/libvirt-0.7.0[python,sasl?]
>=dev-libs/libxml2-2.6.23[python]
@@ -45,11 +45,16 @@ RDEPEND=">=dev-python/pygtk-1.99.12
>=dev-python/gconf-python-1.99.11
dev-python/urlgrabber
gnome-keyring? ( dev-python/gnome-keyring-python )
- policykit? ( sys-auth/polkit )"
+ policykit? ( sys-auth/polkit )
+ spice? ( >=net-misc/spice-gtk-0.6[python,sasl?,-gtk3] )"
DEPEND="${RDEPEND}
app-text/rarian
dev-util/intltool"
+# The TUI (terminal UI) requires newt_syrup which is not packaged on
+# Gentoo. bug #356711
+G2CONF="--without-tui"
+
src_prepare() {
sed -e "s/python/python2/" -i src/virt-manager.in || \
die "python2 update failed"
@@ -63,7 +68,7 @@ src_prepare() {
# unless we do this
touch config.rpath
- rm -f config.status
+ rm -rf config.status
intltoolize --automake --copy --force
perl -i -p -e 's,^DATADIRNAME.*$,DATADIRNAME = share,' po/Makefile.in.in
perl -i -p -e 's,^GETTEXT_PACKAGE.*$,GETTEXT_PACKAGE = virt-manager,' \