summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2005-02-18 00:38:09 +0000
committerStuart Herbert <stuart@gentoo.org>2005-02-18 00:38:09 +0000
commit0f84ae1e73fb80bbc2fcbf4303978a036c428ccd (patch)
tree0f588992944a982dddb4132888336702a9b48afd /app-emulation/vmware-linux-tools
parentfix typo (bug #82319); tidy (diff)
downloadgentoo-2-0f84ae1e73fb80bbc2fcbf4303978a036c428ccd.tar.gz
gentoo-2-0f84ae1e73fb80bbc2fcbf4303978a036c428ccd.tar.bz2
gentoo-2-0f84ae1e73fb80bbc2fcbf4303978a036c428ccd.zip
Initial import
Diffstat (limited to 'app-emulation/vmware-linux-tools')
-rw-r--r--app-emulation/vmware-linux-tools/ChangeLog11
-rw-r--r--app-emulation/vmware-linux-tools/Manifest7
-rw-r--r--app-emulation/vmware-linux-tools/files/4.5.2/locations22
-rwxr-xr-xapp-emulation/vmware-linux-tools/files/4.5.2/vmware-linux-tools93
-rw-r--r--app-emulation/vmware-linux-tools/files/4.5.2/xorg.conf111
-rw-r--r--app-emulation/vmware-linux-tools/files/digest-vmware-linux-tools-4.5.21
-rw-r--r--app-emulation/vmware-linux-tools/metadata.xml8
-rw-r--r--app-emulation/vmware-linux-tools/vmware-linux-tools-4.5.2.ebuild83
8 files changed, 336 insertions, 0 deletions
diff --git a/app-emulation/vmware-linux-tools/ChangeLog b/app-emulation/vmware-linux-tools/ChangeLog
new file mode 100644
index 000000000000..0ef1c9bcb606
--- /dev/null
+++ b/app-emulation/vmware-linux-tools/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emulation/vmware-linux-tools
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-linux-tools/ChangeLog,v 1.1 2005/02/18 00:38:09 stuart Exp $
+
+*vmware-linux-tools-4.5.2 (18 Feb 2005)
+
+ 18 Feb 2005; Stuart Herbert <stuart@gentoo.org> +metadata.xml,
+ +files/4.5.2/locations, +files/4.5.2/vmware-linux-tools,
+ +files/4.5.2/xorg.conf, +vmware-linux-tools-4.5.2.ebuild:
+ Initial import
+
diff --git a/app-emulation/vmware-linux-tools/Manifest b/app-emulation/vmware-linux-tools/Manifest
new file mode 100644
index 000000000000..de36de590be0
--- /dev/null
+++ b/app-emulation/vmware-linux-tools/Manifest
@@ -0,0 +1,7 @@
+MD5 14cb9cdf8bc2986f425302b970eecf71 vmware-linux-tools-4.5.2.ebuild 1905
+MD5 aadc2f563d18404cff667f17b75fccc3 ChangeLog 133
+MD5 0415383a9f09e469d1a77c2510dda94a metadata.xml 221
+MD5 076b748d7140400d21d72352b91b1e33 files/digest-vmware-linux-tools-4.5.2 71
+MD5 dbd7a30eea7c5ad1ef6358f2684c6a4a files/4.5.2/vmware-linux-tools 1961
+MD5 e5e510667afcb0d67ad5c113d84bd423 files/4.5.2/locations 128429
+MD5 bd0505ab92d03f82b898858d45787f58 files/4.5.2/xorg.conf 2646
diff --git a/app-emulation/vmware-linux-tools/files/4.5.2/locations b/app-emulation/vmware-linux-tools/files/4.5.2/locations
new file mode 100644
index 000000000000..478b1e4d1af4
--- /dev/null
+++ b/app-emulation/vmware-linux-tools/files/4.5.2/locations
@@ -0,0 +1,22 @@
+file /etc/vmware-tools/locations
+answer DOCDIR /usr/share/doc/vmware-tools
+answer RUN_CONFIGURATOR yes
+answer RESTORE_MODULES_CONF /etc/modules.conf
+answer RESTORE_MODULES_CONF_BAK /etc/modules.conf.BeforeVMwareToolsInstall
+answer RESTORE_BACK_LIST MODULES_CONF
+answer BUILDR_vmhgfs yes
+answer HEADER_DIR /lib/modules/2.6.7-gentoo-r9/build/include
+answer VMHGFS_CONFED yes
+answer BINDIR /usr/bin
+answer INITDIR /tmp
+answer INITSCRIPTSDIR /tmp
+answer SBINDIR /usr/sbin
+answer LIBDIR /usr/lib/vmware-tools
+directory /etc/vmware-tools
+directory /etc/vmware-tools/state
+file /etc/vmware-tools/not_configured 1109770680
+file /etc/vmware-tools/installer.sh 1109770680
+file /etc/vmware-tools/poweron-vm-default 1109770680
+file /etc/vmware-tools/resume-vm-default 1109770680
+file /etc/vmware-tools/suspend-vm-default 1109770680
+file /etc/vmware-tools/poweroff-vm-default 1109770680
diff --git a/app-emulation/vmware-linux-tools/files/4.5.2/vmware-linux-tools b/app-emulation/vmware-linux-tools/files/4.5.2/vmware-linux-tools
new file mode 100755
index 000000000000..2d75ac8af8c0
--- /dev/null
+++ b/app-emulation/vmware-linux-tools/files/4.5.2/vmware-linux-tools
@@ -0,0 +1,93 @@
+#!/sbin/runscript
+#
+# Copyright (C) 1998-2002 VMware, Inc. All Rights Reserved.
+# Updated by stuart@gentoo.org to support Gentoo Linux
+#
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-linux-tools/files/4.5.2/vmware-linux-tools,v 1.1 2005/02/18 00:38:09 stuart Exp $
+#
+# This script manages the services needed to run VMware software
+
+VMWARE_ETC_DIR=/etc/vmware-tools
+VMWARE_BIN_DIR=/usr/bin
+VMWARE_SBIN_DIR=/usr/sbin
+VMWARE_LIB_DIR=/usr/lib/vmware-tools
+
+VMWARE_GUESTD_PID=/var/run/vmware-guestd.pid
+VMWARE_GUESTD_BIN=${VMWARE_SBIN_DIR}/vmware-guestd
+VMWARE_CHECKVM_BIN=${VMWARE_SBIN_DIR}/vmware-checkvm
+
+VMWARE_CONFIG_TOOLS=${VMWARE_BIN_DIR}/vmware-config-tools.pl
+
+VMWARE_VMHGFS_MOD=vmhgfs
+
+VMWARE_NOT_CONFIGURED=${VMWARE_ETC_DIR}/not_configured
+
+# Is a given module loaded?
+isLoaded() {
+ local module="$1"
+
+ /sbin/lsmod | awk 'BEGIN {n = "no";} {if ($1 == "'"$module"'") n = "yes";} END {print n;}'
+}
+
+vmware_tools_load_module() {
+ if [ "`isLoaded "$1"`" = 'yes' ]; then
+ /sbin/rmmod "$1"
+ fi
+ /sbin/insmod -s -f "/lib/modules/`uname -r`/misc/$1.o" >/dev/null 2>&1 || /sbin/insmod -s -f "$1" >/dev/null 2>&1 || exit 1
+}
+
+vmware_tools_unload_module() {
+ if [ "`isLoaded "$1"`" = 'yes' ]; then
+ /sbin/rmmod "$1" >/dev/null 2>&1 || exit 1
+ fi
+}
+
+depend ()
+{
+ before clock
+}
+
+checkconfig ()
+{
+ if [ -f $VMWARE_NOT_CONFIGURED ]; then
+ eerror "Please run $VMWARE_CONFIG_TOOLS first"
+ eend 1
+ return 1
+ fi
+
+ if ! $VMWARE_CHECKVM_BIN > /dev/null 2>&1 ; then
+ eerror "Not running inside vmware"
+ eend 1
+ return 1
+ fi
+}
+
+start ()
+{
+ checkconfig || exit 1
+
+ ebegin "Loading vmware filesystem"
+ vmware_tools_load_module $VMWARE_VMHGFS_MOD
+ eend $?
+
+ ebegin "Starting vmware guestd"
+ start-stop-daemon -b --quiet -m --pidfile ${VMWARE_GUESTD_PID} --start --startas ${VMWARE_GUESTD_BIN}
+ eend $?
+
+}
+
+stop ()
+{
+ ebegin "Stopping vmware guestd"
+ start-stop-daemon --stop --pidfile ${VMWARE_GUESTD_PID} -x ${VMWARE_GUESTD_BIN}
+ eend $?
+
+ ebegin "Unloading vmware filesystem"
+ vmware_tools_unload_module $VMWARE_VMHGFS_MOD
+ eend $?
+}
+
+reload ()
+{
+ stop ; start
+}
diff --git a/app-emulation/vmware-linux-tools/files/4.5.2/xorg.conf b/app-emulation/vmware-linux-tools/files/4.5.2/xorg.conf
new file mode 100644
index 000000000000..9fcf4bae1848
--- /dev/null
+++ b/app-emulation/vmware-linux-tools/files/4.5.2/xorg.conf
@@ -0,0 +1,111 @@
+Section "ServerLayout"
+ Identifier "X.org Configured"
+ Screen 0 "Screen0" 0 0
+ InputDevice "Mouse0" "CorePointer"
+ InputDevice "Keyboard0" "CoreKeyboard"
+EndSection
+
+Section "Files"
+ RgbPath "/usr/lib/X11/rgb"
+ ModulePath "/usr/lib/modules"
+ FontPath "/usr/share/fonts/misc/"
+ FontPath "/usr/share/fonts/TTF/"
+ FontPath "/usr/share/fonts/Type1/"
+ FontPath "/usr/share/fonts/CID/"
+ FontPath "/usr/share/fonts/75dpi/"
+ FontPath "/usr/share/fonts/100dpi/"
+EndSection
+
+Section "Module"
+ Load "extmod"
+ Load "dri"
+ Load "dbe"
+ Load "record"
+ Load "xtrap"
+ Load "glx"
+ Load "type1"
+ Load "freetype"
+EndSection
+
+Section "InputDevice"
+ Identifier "Keyboard0"
+ Driver "kbd"
+EndSection
+
+Section "InputDevice"
+ Identifier "Mouse0"
+ Driver "mouse"
+ Option "Protocol" "auto"
+ Option "Device" "/dev/mouse"
+EndSection
+
+Section "Monitor"
+ Identifier "Monitor0"
+ VendorName "Monitor Vendor"
+ ModelName "Monitor Model"
+
+ HorizSync 1-10000
+ VertRefresh 1-10000
+
+ ModeLine "640x480" 100 640 700 800 900 480 500 600 700
+ ModeLine "800x600" 100 800 900 1000 1100 600 700 800 900
+ ModeLine "1024x768" 100 1024 1100 1200 1300 768 800 900 1000
+ ModeLine "1152x864" 100 1152 1200 1300 1400 864 900 1000 1100
+ ModeLine "1152x900" 100 1152 1200 1300 1400 900 1000 1100 1200
+ ModeLine "1280x1024" 100 1280 1300 1400 1500 1024 1100 1200 1300
+ ModeLine "1376x1032" 100 1376 1400 1500 1600 1032 1100 1200 1300
+ ModeLine "1600x1200" 100 1600 1700 1800 1900 1200 1300 1400 1500
+ ModeLine "2364x1773" 100 2364 2400 2500 2600 1773 1800 1900 2000
+
+EndSection
+
+Section "Device"
+ ### Available Driver options are:-
+ ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
+ ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
+ ### [arg]: arg optional
+ #Option "HWcursor" # [<bool>]
+ #Option "NoAccel" # [<bool>]
+ Identifier "Card0"
+ Driver "vmware"
+ VendorName "VMWare Inc"
+ BoardName "Unknown Board"
+ BusID "PCI:0:15:0"
+EndSection
+
+Section "Screen"
+ Identifier "Screen0"
+ Device "Card0"
+ Monitor "Monitor0"
+
+ SubSection "Display"
+ Viewport 0 0
+ Depth 4
+ Modes "1024x768"
+ EndSubSection
+
+ SubSection "Display"
+ Viewport 0 0
+ Depth 8
+ Modes "1024x768"
+ EndSubSection
+
+ SubSection "Display"
+ Viewport 0 0
+ Depth 15
+ Modes "1024x768"
+ EndSubSection
+
+ SubSection "Display"
+ Viewport 0 0
+ Depth 16
+ Modes "1024x768"
+ EndSubSection
+
+ SubSection "Display"
+ Viewport 0 0
+ Depth 24
+ Modes "1024x768"
+ EndSubSection
+EndSection
+
diff --git a/app-emulation/vmware-linux-tools/files/digest-vmware-linux-tools-4.5.2 b/app-emulation/vmware-linux-tools/files/digest-vmware-linux-tools-4.5.2
new file mode 100644
index 000000000000..e23e561bfaaa
--- /dev/null
+++ b/app-emulation/vmware-linux-tools/files/digest-vmware-linux-tools-4.5.2
@@ -0,0 +1 @@
+MD5 86b9a24aa1effe4da4f09a3393d44105 vmware-linux-tools.tar.gz 6630450
diff --git a/app-emulation/vmware-linux-tools/metadata.xml b/app-emulation/vmware-linux-tools/metadata.xml
new file mode 100644
index 000000000000..0d3acd8ee464
--- /dev/null
+++ b/app-emulation/vmware-linux-tools/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>vmware</herd>
+<maintainer>
+ <email>stuart@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-emulation/vmware-linux-tools/vmware-linux-tools-4.5.2.ebuild b/app-emulation/vmware-linux-tools/vmware-linux-tools-4.5.2.ebuild
new file mode 100644
index 000000000000..3bbe7425de11
--- /dev/null
+++ b/app-emulation/vmware-linux-tools/vmware-linux-tools-4.5.2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-linux-tools/vmware-linux-tools-4.5.2.ebuild,v 1.1 2005/02/18 00:38:09 stuart Exp $
+
+inherit eutils
+
+DESCRIPTION="Guest-os tools for VMWare workstation"
+HOMEPAGE="http://www.vmware.com/"
+
+# the vmware-tools sources are part of the vmware virtual machine;
+# they must be installed by hand
+SRC_URI="http://www.vmware/com/${PN}.tar.gz"
+LICENSE="vmware"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="X"
+RESTRICT="fetch"
+
+DEPEND=""
+#RDEPEND=""
+
+S=${WORKDIR}/vmware-tools-distrib
+
+src_install() {
+ # install the binaries
+ dosbin sbin/vmware-checkvm
+ dosbin sbin/vmware-guestd
+ dobin bin/vmware-config-tools.pl
+ dobin bin/vmware-toolbox
+
+ # NOTE: we deliberately do NOT install the vmware-uninstall-tools.pl
+ # script
+ #
+ # if you want to uninstall vmware from this machine, use Portage!
+
+ # install the config files
+ insinto /etc/vmware-tools
+ for x in \
+ installer.sh \
+ not_configured \
+ poweroff-vm-default \
+ poweron-vm-default \
+ resume-vm-default \
+ suspend-vm-default \
+ ; do
+ doins etc/$x
+ done
+
+ # populate the locations file
+ # we replace the timestamp in that file with the current
+ # timestamp
+
+ insinto /etc/vmware-tools
+ doins ${FILESDIR}/${PV}/locations
+ timestamp="`date '+%s'`"
+ sed -i "s|1109770680|$timestamp|g" ${D}/etc/vmware-tools/locations
+
+ # install the library files
+ mkdir -p ${D}/usr/lib/vmware-tools
+ cp -r lib/* ${D}/usr/lib/vmware-tools
+
+ # install the init scripts
+ doinitd ${FILESDIR}/${PV}/${PN}
+
+ # if we have X, install the default config
+ if useq X ; then
+ insinto /etc/X11
+ doins ${FILESDIR}/${PV}xorg.conf
+ fi
+
+ # and we're done
+}
+
+pkg_postinst ()
+{
+ einfo "To start using the vmware-tools, please run the following:"
+ einfo
+ einfo " /usr/bin/vmware-config-tools.pl"
+ einfo " rc-update add vmware-linux-tools default"
+ einfo " /etc/init.d/vmware-linux-tools start"
+ einfo
+ einfo "Please report all bugs to http://bugs.gentoo.org/"
+}