summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-06-07 22:25:33 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-06-07 22:25:33 +0000
commit06705cba2682c00901cceecb4b46483f158a6436 (patch)
treea11cb5bfb2a4e0d100aedb6b17e2bdf9469988fa /app-emulation/vmware-modules
parentApply patch already for 3.10.25, bug 483410 (diff)
downloadgentoo-2-06705cba2682c00901cceecb4b46483f158a6436.tar.gz
gentoo-2-06705cba2682c00901cceecb4b46483f158a6436.tar.bz2
gentoo-2-06705cba2682c00901cceecb4b46483f158a6436.zip
Conditionally add patch for kernel 3.12, bug 488072
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'app-emulation/vmware-modules')
-rw-r--r--app-emulation/vmware-modules/ChangeLog8
-rw-r--r--app-emulation/vmware-modules/files/271-vfsfollowlink.patch30
-rw-r--r--app-emulation/vmware-modules/files/279-vfsfollowlink.patch30
-rw-r--r--app-emulation/vmware-modules/vmware-modules-271.3.ebuild3
-rw-r--r--app-emulation/vmware-modules/vmware-modules-279.1-r1.ebuild3
-rw-r--r--app-emulation/vmware-modules/vmware-modules-279.2.ebuild3
6 files changed, 73 insertions, 4 deletions
diff --git a/app-emulation/vmware-modules/ChangeLog b/app-emulation/vmware-modules/ChangeLog
index 86a4aa473205..b5147ec2b40d 100644
--- a/app-emulation/vmware-modules/ChangeLog
+++ b/app-emulation/vmware-modules/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/vmware-modules
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/ChangeLog,v 1.119 2014/06/07 22:09:21 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/ChangeLog,v 1.120 2014/06/07 22:25:33 dilfridge Exp $
+
+ 07 Jun 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ vmware-modules-271.3.ebuild, vmware-modules-279.1-r1.ebuild,
+ vmware-modules-279.2.ebuild, +files/271-vfsfollowlink.patch,
+ +files/279-vfsfollowlink.patch:
+ Conditionally add patch for kernel 3.12, bug 488072
07 Jun 2014; Andreas K. Huettel <dilfridge@gentoo.org>
vmware-modules-271.3.ebuild, vmware-modules-279.1-r1.ebuild,
diff --git a/app-emulation/vmware-modules/files/271-vfsfollowlink.patch b/app-emulation/vmware-modules/files/271-vfsfollowlink.patch
new file mode 100644
index 000000000000..13f600e39f33
--- /dev/null
+++ b/app-emulation/vmware-modules/files/271-vfsfollowlink.patch
@@ -0,0 +1,30 @@
+diff -Naur a/linux/inode.c b/linux/inode.c
+--- a/vmblock-only/linux/inode.c 2013-10-03 04:29:47.471339204 -0400
++++ b/vmblock-only/linux/inode.c 2013-10-03 04:31:56.607334636 -0400
+@@ -36,7 +36,7 @@
+
+ /* Inode operations */
+ static struct dentry *InodeOpLookup(struct inode *dir,
+- struct dentry *dentry, struct nameidata *nd);
++ struct dentry *dentry, unsigned int flags);
+ static int InodeOpReadlink(struct dentry *dentry, char __user *buffer, int buflen);
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 13)
+ static void *InodeOpFollowlink(struct dentry *dentry, struct nameidata *nd);
+@@ -75,7 +75,7 @@
+ static struct dentry *
+ InodeOpLookup(struct inode *dir, // IN: parent directory's inode
+ struct dentry *dentry, // IN: dentry to lookup
+- struct nameidata *nd) // IN: lookup intent and information
++ unsigned int flags) // IN: lookup intent and information
+ {
+ char *filename;
+ struct inode *inode;
+@@ -221,7 +221,7 @@
+ goto out;
+ }
+
+- ret = vfs_follow_link(nd, iinfo->name);
++ nd_set_link(nd, iinfo->name);
+
+ out:
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 13)
diff --git a/app-emulation/vmware-modules/files/279-vfsfollowlink.patch b/app-emulation/vmware-modules/files/279-vfsfollowlink.patch
new file mode 100644
index 000000000000..13f600e39f33
--- /dev/null
+++ b/app-emulation/vmware-modules/files/279-vfsfollowlink.patch
@@ -0,0 +1,30 @@
+diff -Naur a/linux/inode.c b/linux/inode.c
+--- a/vmblock-only/linux/inode.c 2013-10-03 04:29:47.471339204 -0400
++++ b/vmblock-only/linux/inode.c 2013-10-03 04:31:56.607334636 -0400
+@@ -36,7 +36,7 @@
+
+ /* Inode operations */
+ static struct dentry *InodeOpLookup(struct inode *dir,
+- struct dentry *dentry, struct nameidata *nd);
++ struct dentry *dentry, unsigned int flags);
+ static int InodeOpReadlink(struct dentry *dentry, char __user *buffer, int buflen);
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 13)
+ static void *InodeOpFollowlink(struct dentry *dentry, struct nameidata *nd);
+@@ -75,7 +75,7 @@
+ static struct dentry *
+ InodeOpLookup(struct inode *dir, // IN: parent directory's inode
+ struct dentry *dentry, // IN: dentry to lookup
+- struct nameidata *nd) // IN: lookup intent and information
++ unsigned int flags) // IN: lookup intent and information
+ {
+ char *filename;
+ struct inode *inode;
+@@ -221,7 +221,7 @@
+ goto out;
+ }
+
+- ret = vfs_follow_link(nd, iinfo->name);
++ nd_set_link(nd, iinfo->name);
+
+ out:
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 13)
diff --git a/app-emulation/vmware-modules/vmware-modules-271.3.ebuild b/app-emulation/vmware-modules/vmware-modules-271.3.ebuild
index c01f1b0f15fc..17a7a0f22abb 100644
--- a/app-emulation/vmware-modules/vmware-modules-271.3.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-271.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/vmware-modules-271.3.ebuild,v 1.3 2014/06/07 22:09:21 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/vmware-modules-271.3.ebuild,v 1.4 2014/06/07 22:25:33 dilfridge Exp $
EAPI="4"
@@ -67,6 +67,7 @@ src_prepare() {
kernel_is ge 3 7 0 && epatch "${FILESDIR}/${PV_MAJOR}-putname.patch"
kernel_is ge 3 10 0 && epatch "${FILESDIR}/${PV_MAJOR}-3.10.0.patch"
kernel_is ge 3 10 25 && epatch "${FILESDIR}/${PV_MAJOR}-filldir.patch"
+ kernel_is ge 3 12 0 && epatch "${FILESDIR}/${PV_MAJOR}-vfsfollowlink.patch"
# Allow user patches so they can support RC kernels and whatever else
epatch_user
diff --git a/app-emulation/vmware-modules/vmware-modules-279.1-r1.ebuild b/app-emulation/vmware-modules/vmware-modules-279.1-r1.ebuild
index b26cacf57a2a..26bbc484c0ad 100644
--- a/app-emulation/vmware-modules/vmware-modules-279.1-r1.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-279.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/vmware-modules-279.1-r1.ebuild,v 1.3 2014/06/07 22:09:21 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/vmware-modules-279.1-r1.ebuild,v 1.4 2014/06/07 22:25:33 dilfridge Exp $
EAPI=5
@@ -81,6 +81,7 @@ src_prepare() {
kernel_is ge 3 7 0 && epatch "${FILESDIR}/${PV_MAJOR}-putname.patch"
kernel_is ge 3 10 0 && epatch "${FILESDIR}/${PV_MAJOR}-vmblock.patch"
kernel_is ge 3 10 25 && epatch "${FILESDIR}/${PV_MAJOR}-filldir.patch"
+ kernel_is ge 3 12 0 && epatch "${FILESDIR}/${PV_MAJOR}-vfsfollowlink.patch"
# Allow user patches so they can support RC kernels and whatever else
epatch_user
diff --git a/app-emulation/vmware-modules/vmware-modules-279.2.ebuild b/app-emulation/vmware-modules/vmware-modules-279.2.ebuild
index 5e43840ddc1f..b4c35887f32d 100644
--- a/app-emulation/vmware-modules/vmware-modules-279.2.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-279.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/vmware-modules-279.2.ebuild,v 1.3 2014/06/07 22:09:21 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/vmware-modules-279.2.ebuild,v 1.4 2014/06/07 22:25:33 dilfridge Exp $
EAPI=5
@@ -81,6 +81,7 @@ src_prepare() {
kernel_is ge 3 7 0 && epatch "${FILESDIR}/${PV_MAJOR}-putname.patch"
kernel_is ge 3 10 0 && epatch "${FILESDIR}/${PV_MAJOR}-vmblock.patch"
kernel_is ge 3 10 25 && epatch "${FILESDIR}/${PV_MAJOR}-filldir.patch"
+ kernel_is ge 3 12 0 && epatch "${FILESDIR}/${PV_MAJOR}-vfsfollowlink.patch"
# Allow user patches so they can support RC kernels and whatever else
epatch_user