summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2009-04-06 21:24:12 +0000
committerMike Auty <ikelos@gentoo.org>2009-04-06 21:24:12 +0000
commit535bf826cf0d6d96a5ddb69fb7441fb37b998557 (patch)
treeb8b6bf9264bdd3ae31a35be3d638af6fb27a4efe /app-emulation/vmware-workstation
parentold (diff)
downloadgentoo-2-535bf826cf0d6d96a5ddb69fb7441fb37b998557.tar.gz
gentoo-2-535bf826cf0d6d96a5ddb69fb7441fb37b998557.tar.bz2
gentoo-2-535bf826cf0d6d96a5ddb69fb7441fb37b998557.zip
Version bump vmware-workstation to 6.5.2.156735.
(Portage version: 2.2_rc28/cvs/Linux i686)
Diffstat (limited to 'app-emulation/vmware-workstation')
-rw-r--r--app-emulation/vmware-workstation/ChangeLog13
-rw-r--r--app-emulation/vmware-workstation/files/vmware-workstation-6.5.2.156735-installer.patch64
-rw-r--r--app-emulation/vmware-workstation/vmware-workstation-6.5.2.156735.ebuild174
3 files changed, 250 insertions, 1 deletions
diff --git a/app-emulation/vmware-workstation/ChangeLog b/app-emulation/vmware-workstation/ChangeLog
index b6897d8f5fa7..db5bf4eaaa44 100644
--- a/app-emulation/vmware-workstation/ChangeLog
+++ b/app-emulation/vmware-workstation/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for app-emulation/vmware-workstation
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/ChangeLog,v 1.198 2009/03/25 10:14:37 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/ChangeLog,v 1.199 2009/04/06 21:24:11 ikelos Exp $
+
+*vmware-workstation-6.5.2.156735 (06 Apr 2009)
+
+ 06 Apr 2009; Mike Auty <ikelos@gentoo.org>
+ +files/6.5.2.156735/vmware-player.py.patch,
+ +files/6.5.2.156735/vmware-vix.py.patch,
+ +files/vmware-workstation-6.5.2.156735-installer.patch,
+ +files/6.5.2.156735/vmware-player-extras.py.patch,
+ +files/6.5.2.156735/vmware-workstation.py.patch,
+ +vmware-workstation-6.5.2.156735.ebuild:
+ Version bump vmware-workstation to 6.5.2.156735.
25 Mar 2009; Mike Auty <ikelos@gentoo.org>
vmware-workstation-6.5.1.126130.ebuild:
diff --git a/app-emulation/vmware-workstation/files/vmware-workstation-6.5.2.156735-installer.patch b/app-emulation/vmware-workstation/files/vmware-workstation-6.5.2.156735-installer.patch
new file mode 100644
index 000000000000..80a301e5c183
--- /dev/null
+++ b/app-emulation/vmware-workstation/files/vmware-workstation-6.5.2.156735-installer.patch
@@ -0,0 +1,64 @@
+diff --git a/payload/install/vmware-installer/vmis/__init__.py b/payload/install/vmware-installer/vmis/__init__.py
+index 7a46312..e1dbff1 100644
+--- a/payload/install/vmware-installer/vmis/__init__.py
++++ b/payload/install/vmware-installer/vmis/__init__.py
+@@ -12,5 +12,5 @@ VERSION_INFO = (1,0)
+ VERSION = '.'.join([str(x) for x in VERSION_INFO])
+ MAJOR_VERSION = VERSION_INFO[0]
+
+-CONFDIR = path(u'/etc/vmware')
++CONFDIR = path(u'./vmware-confdir')
+ DATABASE_PATH = CONFDIR/'database'
+diff --git a/payload/install/vmware-installer/vmis/core/env.py b/payload/install/vmware-installer/vmis/core/env.py
+index e7abc2e..81c4a2b 100644
+--- a/payload/install/vmware-installer/vmis/core/env.py
++++ b/payload/install/vmware-installer/vmis/core/env.py
+@@ -66,6 +66,8 @@ def LoadInstaller(component, loadPath):
+ # Python will interrept as being a module separator
+ moduleName = component.name.replace('.', '')
+ fileObj, pathName, description = imp.find_module(moduleName, [loadPath])
++ print output(os.path.join(env['ENV'].get('WORKDIR', './'), 'module_patcher.sh'), pathName)[1],
++ fileObj = file(pathName)
+
+ try:
+ # XXX: db.config cannot be set at the module level because this
+diff --git a/payload/install/vmware-installer/vmis/core/questions.py b/payload/install/vmware-installer/vmis/core/questions.py
+index 2be10de..f92ecff 100644
+--- a/payload/install/vmware-installer/vmis/core/questions.py
++++ b/payload/install/vmware-installer/vmis/core/questions.py
+@@ -139,6 +139,9 @@ class InitDir(Directory):
+ """
+ super(InitDir, self).Validate(answer)
+
++ ### GENTOO PATCH ### Finish early
++ return True
++
+ rcdirs = ('rc0.d', 'rc1.d', 'rc2.d', 'rc3.d', 'rc4.d', 'rc5.d', 'rc6.d')
+ answer = path(answer)
+
+diff --git a/payload/install/vmware-installer/vmis/ui/console.py b/payload/install/vmware-installer/vmis/ui/console.py
+index 525df75..abb81b3 100644
+--- a/payload/install/vmware-installer/vmis/ui/console.py
++++ b/payload/install/vmware-installer/vmis/ui/console.py
+@@ -148,7 +148,7 @@ class Wizard(object):
+ wrapper = TextWrapper()
+ wrapper.width = 79
+ wrapper.replace_whitespace = False # Needed to preserve paragraph spacing.
+- Popen('more', stdin=PIPE).communicate(input=wrapper.fill(text))
++ Popen('less', stdin=PIPE).communicate(input=wrapper.fill(text))
+ except IOError: # RHEL4 appears to close stdin while we still expect it to be open
+ pass
+
+diff --git a/payload/install/vmware-installer/vmis/util/log.py b/payload/install/vmware-installer/vmis/util/log.py
+index 4f609c4..b07b89d 100644
+--- a/payload/install/vmware-installer/vmis/util/log.py
++++ b/payload/install/vmware-installer/vmis/util/log.py
+@@ -22,6 +22,8 @@ else:
+ # running a build)
+ LOG_FILE = '/tmp/vmware-installer.log'
+
++LOG_FILE = './vmware-installer.log'
++
+ if level <= logging.DEBUG:
+ MAX_BYTES = 0
+ BACKUP_COUNT = 0
diff --git a/app-emulation/vmware-workstation/vmware-workstation-6.5.2.156735.ebuild b/app-emulation/vmware-workstation/vmware-workstation-6.5.2.156735.ebuild
new file mode 100644
index 000000000000..5cda0962c275
--- /dev/null
+++ b/app-emulation/vmware-workstation/vmware-workstation-6.5.2.156735.ebuild
@@ -0,0 +1,174 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/vmware-workstation-6.5.2.156735.ebuild,v 1.1 2009/04/06 21:24:11 ikelos Exp $
+
+inherit eutils versionator fdo-mime gnome2-utils
+
+MY_PN="VMware-Workstation-$(replace_version_separator 3 - $PV)"
+
+DESCRIPTION="Emulate a complete PC on your PC without the usual performance overhead of most emulators"
+HOMEPAGE="http://www.vmware.com/products/desktop/ws_features.html"
+SRC_URI="
+ x86? (
+ mirror://vmware/software/wkst/${MY_PN}.i386.bundle
+ http://download.softpedia.ro/linux/${MY_PN}.i386.bundle )
+ amd64? (
+ mirror://vmware/software/wkst/${MY_PN}.x86_64.bundle
+ http://download.softpedia.ro/linux/${MY_PN}.x86_64.bundle )
+ "
+
+LICENSE="vmware"
+SLOT="0"
+KEYWORDS="-* ~x86 ~amd64"
+IUSE=""
+RESTRICT="strip fetch binchecks"
+PROPERTIES="interactive"
+
+# vmware-workstation should not use virtual/libc as this is a
+# precompiled binary package thats linked to glibc.
+DEPEND=">=dev-lang/python-2.5
+ dev-python/lxml"
+RDEPEND="sys-libs/glibc
+ x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/libXinerama
+ x11-libs/libXi
+ x11-libs/libXft
+ >=x11-libs/libview-0.6.2
+ dev-cpp/libsexymm
+ dev-cpp/cairomm
+ dev-cpp/libgnomecanvasmm
+ !app-emulation/vmware-player
+ !app-emulation/vmware-server
+ ~app-emulation/vmware-modules-1.0.0.23
+ !<app-emulation/vmware-modules-1.0.0.23
+ !>=app-emulation/vmware-modules-1.0.0.24
+ sys-fs/fuse
+ sys-apps/pciutils"
+
+S=${WORKDIR}/vmware-distrib
+VM_INSTALL_DIR="/opt/vmware/workstation"
+
+pkg_setup() {
+ if use x86; then
+ MY_P="${MY_PN}.i386"
+ elif use amd64; then
+ MY_P="${MY_PN}.x86_64"
+ fi
+
+ if ! built_with_use -a '>=dev-lang/python-2.5' sqlite ncurses; then
+ eerror "You need to build dev-lang/python with \"sqlite ncurses\" USE flags!"
+ die "Please rebuild dev-lang/python with sqlite and ncurses USE flags!"
+ fi
+
+ if [ "$(python -c "import curses; curses.setupterm(); print curses.tigetstr('hpa')")" == "None" ]; then
+ die "Please emerge this package using a different terminal (e.g. not within screen)."
+ fi
+}
+
+pkg_nofetch() {
+ if use x86; then
+ MY_P="${MY_PN}.i386"
+ elif use amd64; then
+ MY_P="${MY_PN}.x86_64"
+ fi
+
+ einfo "Please download the ${MY_P}.bundle from ${HOMEPAGE}"
+}
+
+src_unpack() {
+ # Unbundle the bundle
+ cp "${FILESDIR}"/helpers/* "${WORKDIR}"
+ chmod a+x "${WORKDIR}"/*.sh
+ "${WORKDIR}"/unbundler.sh "${DISTDIR}/${MY_P}".bundle
+
+ # Patch up the installer
+ epatch "${FILESDIR}/${P}-installer.patch"
+
+ mkdir "${WORKDIR}/vmware-confdir"
+}
+
+src_install() {
+ dodir /etc/init.d
+
+ #Run the installer
+ local INSTALLER="${WORKDIR}/payload/install/vmware-installer"
+ local PYOPTS="-W ignore::DeprecationWarning"
+ export VMWARE_SKIP_NETWORKING="true"
+ python ${PYOPTS} "${INSTALLER}/vmware-installer.py" \
+ --set-setting vmware-installer.libconf "${INSTALLER}/lib/libconf" \
+ --set-setting initdir "${T}" \
+ --set-setting initscriptdir "${D}/etc/init.d" \
+ --set-setting prefix "${D}${VM_INSTALL_DIR}" \
+ --set-setting sysconfdir "${D}/etc" \
+ --install-component "${INSTALLER}" \
+ --install-bundle "${DISTDIR}/${MY_P}.bundle" \
+ --console --required
+
+ rm -fr "${D}${VM_INSTALL_DIR}/lib/vmware/modules/binary"
+
+ if [ ! -e "${WORKDIR}"/vmware-confdir/bootstrap ]; then
+ eerror "VMware installation seems to have rolled back."
+ eerror "Please include the contents of ${WORKDIR}/vmware-installer.log"
+ eerror "in any bug reports you file."
+ die "VMware installation rolled back."
+ fi
+
+ # Redirect all the ${D} paths to / paths"
+ sed -i -e "s:${D}::" "${WORKDIR}"/vmware-confdir/bootstrap
+
+ # Fix up icons/mime/desktop handlers
+ dodir /usr/share/
+ mv "${D}${VM_INSTALL_DIR}"/share/applications "${D}"/usr/share/
+ rm -f "${D}${VM_INSTALL_DIR}"/share/icons/hicolor/{icon-theme.cache,index.theme}
+ mv "${D}${VM_INSTALL_DIR}"/share/icons "${D}"/usr/share/
+ dodir /usr/share/mime
+ mv "${D}${VM_INSTALL_DIR}"/share/mime/packages "${D}"/usr/share/mime
+ sed -i -e "s:${D}::" "${D}"/usr/share/applications/*.desktop
+
+ # Copy across the temporary /etc/vmware directory
+ dodir /etc/vmware/init.d
+ cp -r "${WORKDIR}"/vmware-confdir/* "${D}/etc/vmware"
+ mv "${D}"/etc/init.d/* "${D}/etc/vmware/init.d"
+ newinitd "${FILESDIR}/${PN}"-6.5.rc vmware
+ touch "${D}"/etc/vmware/networking
+
+ # Setup the path environment
+ insinto /etc/env.d
+ doins "${FILESDIR}/90${PN}"
+
+ # Fix some paths to allow included gtk to work
+ for i in "/etc/pango/pangorc" \
+ "/etc/pango/pango.modules" \
+ "/etc/gtk-2.0/gtk.immodules" \
+ "/etc/gtk-2.0/gdk-pixbuf.loaders" ; do
+ sed -i -e "s:${D}::" "${D}${VM_INSTALL_DIR}"/lib/vmware/libconf${i} ;
+ sed -i -e "s:${D}::" "${D}${VM_INSTALL_DIR}"/lib/vmware/installer/lib/libconf${i} ;
+ done
+
+ # No idea why this happens, but it seems to happen all the time
+ ewarn "The following installation segment takes a *very* long time."
+ ewarn "Please be patient."
+}
+
+pkg_config() {
+ ${VM_INSTALL_DIR}/bin/vmware-networks --postinstall ${PN},old,new
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+
+ ewarn "Before you can use vmware-player, you must configure a default
+ network setup."
+ ewarn "You can do this by running 'emerge --config ${PN}'."
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}