summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2006-02-05 13:45:51 +0000
committerSimon Stelling <blubb@gentoo.org>2006-02-05 13:45:51 +0000
commit6771afa77d57d9234042d7fc87c412dd5daaef6e (patch)
tree2fcb374473bc02975910964fe32720d6bf88cf34 /app-emulation/wine/wine-0.9.7.ebuild
parentrevision bump, next security bump as well (diff)
downloadgentoo-2-6771afa77d57d9234042d7fc87c412dd5daaef6e.tar.gz
gentoo-2-6771afa77d57d9234042d7fc87c412dd5daaef6e.tar.bz2
gentoo-2-6771afa77d57d9234042d7fc87c412dd5daaef6e.zip
remove old 2004.3 multilib checks
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'app-emulation/wine/wine-0.9.7.ebuild')
-rw-r--r--app-emulation/wine/wine-0.9.7.ebuild18
1 files changed, 2 insertions, 16 deletions
diff --git a/app-emulation/wine/wine-0.9.7.ebuild b/app-emulation/wine/wine-0.9.7.ebuild
index eb7a93daace3..421487b10bfb 100644
--- a/app-emulation/wine/wine-0.9.7.ebuild
+++ b/app-emulation/wine/wine-0.9.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.7.ebuild,v 1.2 2006/02/03 03:29:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.7.ebuild,v 1.3 2006/02/05 13:45:51 blubb Exp $
inherit eutils flag-o-matic multilib
@@ -59,21 +59,7 @@ DEPEND="${RDEPEND}
sys-devel/flex"
pkg_setup() {
- if use amd64 ; then
- if ! has_m32 ; then
- eerror "Your compiler seems to be unable to compile 32bit code."
- eerror "Make sure you compile gcc with:"
- echo
- eerror " USE=multilib FEATURES=-sandbox"
- die "Cannot produce 32bit code"
- fi
- if has_multilib_profile ; then
- export ABI=x86
- else
- append-flags -m32
- append-ldflags -m32
- fi
- fi
+ use amd64 && has_multilib_profile && export ABI=x86
}
src_unpack() {