summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-08 04:36:47 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-08 04:36:47 +0000
commit98f1749565ac51472567dc080cadfbb244ff8c34 (patch)
treeee3190ce89bc8bf3aa584c17a0fa209f678f7062 /app-emulation/wine/wine-20050830.ebuild
parentremove old version. Add || die to make on -8 and do not install the license (diff)
downloadgentoo-2-98f1749565ac51472567dc080cadfbb244ff8c34.tar.gz
gentoo-2-98f1749565ac51472567dc080cadfbb244ff8c34.tar.bz2
gentoo-2-98f1749565ac51472567dc080cadfbb244ff8c34.zip
Add upstream patch for WMF exploit #118101 and make sure all ebuilds support modular X.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'app-emulation/wine/wine-20050830.ebuild')
-rw-r--r--app-emulation/wine/wine-20050830.ebuild22
1 files changed, 19 insertions, 3 deletions
diff --git a/app-emulation/wine/wine-20050830.ebuild b/app-emulation/wine/wine-20050830.ebuild
index b990b0ce185a..bb898b9bdf7f 100644
--- a/app-emulation/wine/wine-20050830.ebuild
+++ b/app-emulation/wine/wine-20050830.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050830.ebuild,v 1.3 2006/01/05 03:00:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050830.ebuild,v 1.4 2006/01/08 04:36:47 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
+KEYWORDS="-* amd64 x86"
IUSE="X alsa arts cups debug nas opengl gif glut jack jpeg oss ncurses lcms" #doc
RESTRICT="test" #72375
@@ -18,7 +18,15 @@ RDEPEND=">=media-libs/freetype-2.0.0
media-fonts/corefonts
ncurses? ( >=sys-libs/ncurses-5.2 )
jack? ( media-sound/jack-audio-connection-kit )
- X? ( virtual/x11 )
+ X? ( || ( ( x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ )
+ virtual/x11
+ )
+ )
arts? ( kde-base/arts )
alsa? ( media-libs/alsa-lib )
nas? ( media-libs/nas )
@@ -34,6 +42,14 @@ RDEPEND=">=media-libs/freetype-2.0.0
>=sys-kernel/linux-headers-2.6
)"
DEPEND="${RDEPEND}
+ X? ( || ( ( x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ )
+ virtual/x11
+ )
+ )
sys-devel/bison
sys-devel/flex"
# doc? ( app-text/docbook-sgml-utils app-text/jadetex )