summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-30 19:47:28 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-30 19:47:28 +0000
commit8cab73dd18e95eefd4505f1e0c4832349706f139 (patch)
treec3fec118b758515395f2ab53e44cca0b52e90648 /app-emulation/x48
parentalpha/arm/ia64/sh/sparc stable wrt #348987 (diff)
downloadgentoo-2-8cab73dd18e95eefd4505f1e0c4832349706f139.tar.gz
gentoo-2-8cab73dd18e95eefd4505f1e0c4832349706f139.tar.bz2
gentoo-2-8cab73dd18e95eefd4505f1e0c4832349706f139.zip
Proxy commit from Kevin McCarthy: version bump to 0.6.3: cleanup with EAPI=3, fix dependencies, don't install the ROM dumps as their license is unclear, fix buffer overflow, add readline USE flag and fix build with it disabled. Update metadata.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/x48')
-rw-r--r--app-emulation/x48/ChangeLog14
-rw-r--r--app-emulation/x48/files/x48-0.6.3-no-readline.patch11
-rw-r--r--app-emulation/x48/files/x48-0.6.3-off-by-one.patch25
-rw-r--r--app-emulation/x48/metadata.xml17
-rw-r--r--app-emulation/x48/x48-0.4.3.ebuild50
-rw-r--r--app-emulation/x48/x48-0.6.1.ebuild62
-rw-r--r--app-emulation/x48/x48-0.6.3.ebuild61
7 files changed, 122 insertions, 118 deletions
diff --git a/app-emulation/x48/ChangeLog b/app-emulation/x48/ChangeLog
index 29ae5ebae206..e440cb9c5408 100644
--- a/app-emulation/x48/ChangeLog
+++ b/app-emulation/x48/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-emulation/x48
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/x48/ChangeLog,v 1.17 2009/09/22 17:56:44 vostorga Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/x48/ChangeLog,v 1.18 2011/01/30 19:47:27 flameeyes Exp $
+
+*x48-0.6.3 (30 Jan 2011)
+
+ 30 Jan 2011; Diego E. Pettenò <flameeyes@gentoo.org> -x48-0.4.3.ebuild,
+ -x48-0.6.1.ebuild, +x48-0.6.3.ebuild, +files/x48-0.6.3-no-readline.patch,
+ +files/x48-0.6.3-off-by-one.patch, metadata.xml:
+ Proxy commit from Kevin McCarthy: version bump to 0.6.3: cleanup with EAPI=3,
+ fix dependencies, don't install the ROM dumps as their license is unclear,
+ fix buffer overflow, add readline USE flag and fix build with it disabled.
+ Update metadata.
*x48-0.6.1 (22 Sep 2009)
diff --git a/app-emulation/x48/files/x48-0.6.3-no-readline.patch b/app-emulation/x48/files/x48-0.6.3-no-readline.patch
new file mode 100644
index 000000000000..90c7d7854b39
--- /dev/null
+++ b/app-emulation/x48/files/x48-0.6.3-no-readline.patch
@@ -0,0 +1,11 @@
+--- x48-0.6.3.orig/configure.ac 2011-01-30 12:35:56.960715403 -0500
++++ x48-0.6.3/configure.ac 2011-01-30 12:35:41.746142323 -0500
+@@ -82,7 +82,7 @@
+
+ # Checks for header files.
+ AC_HEADER_STDC
+-AC_CHECK_HEADERS([fcntl.h memory.h stdlib.h string.h sys/ioctl.h sys/time.h termios.h unistd.h])
++AC_CHECK_HEADERS([fcntl.h memory.h stdlib.h string.h sys/ioctl.h sys/time.h termios.h unistd.h stdint.h])
+
+ # Checks for typedefs, structures, and compiler characteristics.
+ AC_C_CONST
diff --git a/app-emulation/x48/files/x48-0.6.3-off-by-one.patch b/app-emulation/x48/files/x48-0.6.3-off-by-one.patch
new file mode 100644
index 000000000000..b71f23abe663
--- /dev/null
+++ b/app-emulation/x48/files/x48-0.6.3-off-by-one.patch
@@ -0,0 +1,25 @@
+--- x48-0.6.3.orig/src/debugger.c 2011-01-29 12:58:24.432244663 -0500
++++ x48-0.6.3/src/debugger.c 2011-01-29 13:06:46.750769284 -0500
+@@ -1919,10 +1919,7 @@
+ free (cl);
+ cl = (char *) 0;
+ }
+- if (old_line)
+- cl = strcpy ((char *) malloc (strlen (old_line)), old_line);
+- else
+- cl = strcpy ((char *) malloc (strlen ("(null)")), "(null)");
++ cl = strdup (old_line == NULL ? "(null)" : old_line);
+ }
+ else
+ {
+@@ -1936,8 +1933,8 @@
+ free (old_line);
+ old_line = (char *) 0;
+ }
+- cl = strcpy ((char *) malloc (strlen (rl)), rl);
+- old_line = strcpy ((char *) malloc (strlen (rl)), rl);
++ cl = strdup (rl);
++ old_line = strdup (rl);
+ #ifdef HAVE_READLINE
+ add_history (rl);
+ #endif
diff --git a/app-emulation/x48/metadata.xml b/app-emulation/x48/metadata.xml
index 9f3fdee2246b..76210502a74e 100644
--- a/app-emulation/x48/metadata.xml
+++ b/app-emulation/x48/metadata.xml
@@ -1,8 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>no-herd</herd>
- <maintainer>
- <email>maintainer-needed@gentoo.org</email>
- </maintainer>
+ <herd>no-herd</herd>
+
+ <maintainer>
+ <email>signals42@gmail.com</email>
+ <name>Kevin McCarthy</name>
+ <description>Proxied maintainer, assign bugs to him</description>
+ </maintainer>
+
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ <name>Diego Elio Pettenò</name>
+ <description>Proxy maintainer, CC him on bugs</description>
+ </maintainer>
</pkgmetadata>
diff --git a/app-emulation/x48/x48-0.4.3.ebuild b/app-emulation/x48/x48-0.4.3.ebuild
deleted file mode 100644
index f2224c6d6be2..000000000000
--- a/app-emulation/x48/x48-0.4.3.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/x48/x48-0.4.3.ebuild,v 1.6 2008/10/13 18:51:39 bangert Exp $
-
-inherit eutils
-
-DESCRIPTION="HP48 Calculator Emulator"
-HOMEPAGE="http://x48.berlios.de/"
-SRC_URI="mirror://berlios/x48/${P}.tar.gz"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-
-RDEPEND="x11-proto/xextproto
- app-text/rman"
-DEPEND="${RDEPEND}
- x11-libs/libXext
- x11-libs/libX11
- x11-misc/imake
- app-text/rman
- sys-libs/readline
- sys-libs/ncurses
- sys-libs/gpm"
-
-src_compile() {
- xmkmf || die
- emake CCOPTIONS="${CFLAGS}" LOCAL_LDFLAGS="${LDFLAGS}" || die
-}
-
-src_install() {
- dobin src/checkrom src/dump2rom src/mkcard src/x48
-
- newman src/x48.man x48.1
-
- dodir /usr/lib/X11/app-defaults
- insinto /usr/lib/X11/app-defaults/
- newins src/X48.ad X48
-
- dodoc doc/CARDS.doc doc/ROMDump.doc
- dodoc romdump/ROMDump romdump/ROMDump.s
-}
-
-pkg_postinst() {
- elog "The X48 emulator requires an HP48 ROM Image to run."
- elog
- elog "You can use the ROMDump utility and documentation included with this"
- elog "package to obtain this from your HP48 calculator."
-}
diff --git a/app-emulation/x48/x48-0.6.1.ebuild b/app-emulation/x48/x48-0.6.1.ebuild
deleted file mode 100644
index 26a3ad2ebe62..000000000000
--- a/app-emulation/x48/x48-0.6.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/x48/x48-0.6.1.ebuild,v 1.1 2009/09/22 17:56:44 vostorga Exp $
-
-inherit eutils
-
-DESCRIPTION="HP48 Calculator Emulator"
-HOMEPAGE="http://x48.berlios.de/"
-SRC_URI="mirror://berlios/x48/${P}.tar.gz
- http://www.hpcalc.org/hp48/pc/emulators/sxrom-j.zip
- http://www.hpcalc.org/hp48/pc/emulators/gxrom-r.zip"
-LICENSE="|| ( ( GPL-2 free-noncomm ) GPL-2 )"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-RDEPEND="x11-libs/libXext
- x11-libs/libX11"
-DEPEND="${RDEPEND}
- x11-proto/xextproto
- app-text/rman
- sys-libs/readline
- sys-libs/ncurses
- app-arch/unzip
- sys-libs/gpm"
-
-src_compile() {
- econf
- emake CCOPTIONS="${CFLAGS}" LOCAL_LDFLAGS="${LDFLAGS}" || die
-}
-
-src_install() {
- dobin src/checkrom src/dump2rom src/mkcard src/x48 || die "dobin failed"
-
- newman src/x48.man x48.1 || die "newman failed"
-
- dodir /usr/lib/X11/app-defaults || die "dodir failed"
- insinto /usr/lib/X11/app-defaults/
-
- dodir /usr/share/hp48 || die "dodir failed"
- insinto /usr/share/hp48
- doins "${WORKDIR}"/gxrom-r "${WORKDIR}"/sxrom-j || die "doins failed"
-
-}
-
-pkg_postinst() {
- elog "The X48 emulator requires an HP48 ROM Image to run."
- elog
- elog "If you own an HP-48 calculator, you can use the ROMDump utility"
- elog "included with this package to obtain this from your calculator."
- elog
- elog "Alternatively, HP has provided two ROM images for non-commercial"
- elog "use only."
- elog
- elog "For an HP-48SX type: x48 -rom /usr/share/hp48/sxrom-j"
- elog "For an HP-48GX type: x48 -rom /usr/share/hp48/gxrom-r"
- elog
- elog "(If you're not sure which one you want, go with HP-48GX)"
- elog
- elog "Note: you only need to use the '-rom' argument once"
-}
diff --git a/app-emulation/x48/x48-0.6.3.ebuild b/app-emulation/x48/x48-0.6.3.ebuild
new file mode 100644
index 000000000000..ea2ac65de6c9
--- /dev/null
+++ b/app-emulation/x48/x48-0.6.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/x48/x48-0.6.3.ebuild,v 1.1 2011/01/30 19:47:27 flameeyes Exp $
+
+EAPI=3
+
+inherit eutils autotools
+
+DESCRIPTION="HP48 Calculator Emulator"
+HOMEPAGE="http://x48.berlios.de/"
+SRC_URI="mirror://berlios/x48/${P}.tar.gz"
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="readline"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ readline? ( sys-libs/readline )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-libs/libXt"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-off-by-one.patch"
+ epatch "${FILESDIR}/${P}-no-readline.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable readline)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed."
+ dodoc AUTHORS README ChangeLog
+}
+
+pkg_postinst() {
+ elog "The X48 emulator requires an HP48 ROM image to run."
+ elog
+ elog "If you own an HP-48 calculator, you can use the ROMDump utility"
+ elog "included with this package to obtain this from your calculator."
+ elog
+ elog "Alternatively, HP has provided the ROM images for non-commercial"
+ elog "use only."
+ elog
+ elog "Due to confusion over the legal status of these ROMs you must"
+ elog "manually download one from http://www.hpcalc.org/hp48/pc/emulators/"
+ elog
+ elog "If you do not know which one to use, try 'HP 48GX Revision R ROM.'"
+ elog
+ elog "Once you have a ROM, you will need to install it by running:"
+ elog
+ elog "x48 -rom gxrom-r"
+ elog
+ elog "You will only have to do this the first time you run X48. The"
+ elog "ROM will be stored in ~/.hp48/rom for future runs."
+}