summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-09-06 14:46:38 +0000
committerMike Frysinger <vapier@gentoo.org>2009-09-06 14:46:38 +0000
commit14188ac5e93da8a2b784619673272769aaf4c8f4 (patch)
tree46eeaeb38c9b2dbcd6bdddd81434995ea37240b9 /app-emulation
parentamd64/x86 stable, bug #281915 (diff)
downloadgentoo-2-14188ac5e93da8a2b784619673272769aaf4c8f4.tar.gz
gentoo-2-14188ac5e93da8a2b784619673272769aaf4c8f4.tar.bz2
gentoo-2-14188ac5e93da8a2b784619673272769aaf4c8f4.zip
Add support for USE=gsm by netfab #283822.
(Portage version: 2.2_rc40/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog6
-rw-r--r--app-emulation/wine/wine-1.1.27.ebuild6
-rw-r--r--app-emulation/wine/wine-1.1.28.ebuild6
-rw-r--r--app-emulation/wine/wine-1.1.29.ebuild6
4 files changed, 17 insertions, 7 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index eb325860ed38..992d278f99ec 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.276 2009/09/06 14:42:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.277 2009/09/06 14:46:38 vapier Exp $
+
+ 06 Sep 2009; Mike Frysinger <vapier@gentoo.org> wine-1.1.27.ebuild,
+ wine-1.1.28.ebuild, wine-1.1.29.ebuild:
+ Add support for USE=gsm by netfab #283822.
06 Sep 2009; Mike Frysinger <vapier@gentoo.org> wine-1.1.29.ebuild:
Add support for mpg123 via USE=mp3 #283756 by Rafał Mużyło.
diff --git a/app-emulation/wine/wine-1.1.27.ebuild b/app-emulation/wine/wine-1.1.27.ebuild
index 86fbed48d748..23c96896cc00 100644
--- a/app-emulation/wine/wine-1.1.27.ebuild
+++ b/app-emulation/wine/wine-1.1.27.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.27.ebuild,v 1.3 2009/08/26 21:57:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.27.ebuild,v 1.4 2009/09/06 14:46:38 vapier Exp $
EAPI="2"
@@ -26,7 +26,7 @@ SRC_URI="${SRC_URI}
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="alsa cups dbus esd +gecko gnutls hal jack jpeg lcms ldap nas ncurses +opengl oss png samba scanner ssl win64 +X xcomposite xinerama xml"
+IUSE="alsa cups dbus esd +gecko gnutls gsm hal jack jpeg lcms ldap nas ncurses +opengl oss png samba scanner ssl win64 +X xcomposite xinerama xml"
RESTRICT="test" #72375
RDEPEND=">=media-libs/freetype-2.0.0
@@ -51,6 +51,7 @@ RDEPEND=">=media-libs/freetype-2.0.0
nas? ( media-libs/nas )
cups? ( net-print/cups )
opengl? ( virtual/opengl )
+ gsm? ( media-sound/gsm )
jpeg? ( media-libs/jpeg )
ldap? ( net-nds/openldap )
lcms? ( media-libs/lcms )
@@ -105,6 +106,7 @@ src_configure() {
$(use_with cups) \
$(use_with esd) \
$(use_with gnutls) \
+ $(use_with gsm libgsm) \
$(! use dbus && echo --without-hal || use_with hal) \
$(use_with jack) \
$(use_with jpeg) \
diff --git a/app-emulation/wine/wine-1.1.28.ebuild b/app-emulation/wine/wine-1.1.28.ebuild
index c95b0f41b26b..c1d9d4077b2a 100644
--- a/app-emulation/wine/wine-1.1.28.ebuild
+++ b/app-emulation/wine/wine-1.1.28.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.28.ebuild,v 1.3 2009/08/27 11:41:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.28.ebuild,v 1.4 2009/09/06 14:46:38 vapier Exp $
EAPI="2"
@@ -26,7 +26,7 @@ SRC_URI="${SRC_URI}
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="alsa cups dbus esd +gecko gnutls hal jack jpeg lcms ldap nas ncurses +opengl oss png samba scanner ssl test win64 +X xcomposite xinerama xml"
+IUSE="alsa cups dbus esd +gecko gnutls gsm hal jack jpeg lcms ldap nas ncurses +opengl oss png samba scanner ssl test win64 +X xcomposite xinerama xml"
RESTRICT="test" #72375
RDEPEND=">=media-libs/freetype-2.0.0
@@ -51,6 +51,7 @@ RDEPEND=">=media-libs/freetype-2.0.0
nas? ( media-libs/nas )
cups? ( net-print/cups )
opengl? ( virtual/opengl )
+ gsm? ( media-sound/gsm )
jpeg? ( media-libs/jpeg )
ldap? ( net-nds/openldap )
lcms? ( media-libs/lcms )
@@ -105,6 +106,7 @@ src_configure() {
$(use_with cups) \
$(use_with esd) \
$(use_with gnutls) \
+ $(use_with gsm) \
$(! use dbus && echo --without-hal || use_with hal) \
$(use_with jack) \
$(use_with jpeg) \
diff --git a/app-emulation/wine/wine-1.1.29.ebuild b/app-emulation/wine/wine-1.1.29.ebuild
index 308b10f4083f..e6dd1efe146a 100644
--- a/app-emulation/wine/wine-1.1.29.ebuild
+++ b/app-emulation/wine/wine-1.1.29.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.29.ebuild,v 1.2 2009/09/06 14:42:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.29.ebuild,v 1.3 2009/09/06 14:46:38 vapier Exp $
EAPI="2"
@@ -26,7 +26,7 @@ SRC_URI="${SRC_URI}
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="alsa cups dbus esd +gecko gnutls hal jack jpeg lcms ldap mp3 nas ncurses +opengl oss png samba scanner ssl test win64 +X xcomposite xinerama xml"
+IUSE="alsa cups dbus esd +gecko gnutls gsm hal jack jpeg lcms ldap mp3 nas ncurses +opengl oss png samba scanner ssl test win64 +X xcomposite xinerama xml"
RESTRICT="test" #72375
RDEPEND=">=media-libs/freetype-2.0.0
@@ -51,6 +51,7 @@ RDEPEND=">=media-libs/freetype-2.0.0
nas? ( media-libs/nas )
cups? ( net-print/cups )
opengl? ( virtual/opengl )
+ gsm? ( media-sound/gsm )
jpeg? ( media-libs/jpeg )
ldap? ( net-nds/openldap )
lcms? ( media-libs/lcms )
@@ -106,6 +107,7 @@ src_configure() {
$(use_with cups) \
$(use_with esd) \
$(use_with gnutls) \
+ $(use_with gsm) \
$(! use dbus && echo --without-hal || use_with hal) \
$(use_with jack) \
$(use_with jpeg) \