summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2008-01-25 14:47:20 +0000
committerLuca Barbato <lu_zero@gentoo.org>2008-01-25 14:47:20 +0000
commit155bb609401c16906b0873f70f2a1bf2067e8ebf (patch)
treebd4fe396019aa127635fbadbddf0356369bf0e4a /app-emulation
parentAdd ~sparc wrt #207369 (diff)
downloadgentoo-2-155bb609401c16906b0873f70f2a1bf2067e8ebf.tar.gz
gentoo-2-155bb609401c16906b0873f70f2a1bf2067e8ebf.tar.bz2
gentoo-2-155bb609401c16906b0873f70f2a1bf2067e8ebf.zip
New version, see bug #204675
(Portage version: 2.1.4)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu-softmmu/ChangeLog10
-rw-r--r--app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.9.13
-rw-r--r--app-emulation/qemu-softmmu/qemu-softmmu-0.9.1.ebuild108
3 files changed, 119 insertions, 2 deletions
diff --git a/app-emulation/qemu-softmmu/ChangeLog b/app-emulation/qemu-softmmu/ChangeLog
index caca5dd4920b..5bda0accb093 100644
--- a/app-emulation/qemu-softmmu/ChangeLog
+++ b/app-emulation/qemu-softmmu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/qemu-softmmu
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/ChangeLog,v 1.44 2007/11/13 00:06:21 lu_zero Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/ChangeLog,v 1.45 2008/01/25 14:47:19 lu_zero Exp $
+
+*qemu-softmmu-0.9.1 (25 Jan 2008)
+
+ 25 Jan 2008; Luca Barbato <lu_zero@gentoo.org> +qemu-softmmu-0.9.1.ebuild:
+ New version, improved ebuild by Carlo Marcelo Arenas Belon
+ <carenas@sajinet.com.pe>, bugs #204675
13 Nov 2007; Luca Barbato <lu_zero@gentoo.org>
qemu-softmmu-0.9.0-r1.ebuild:
diff --git a/app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.9.1 b/app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.9.1
new file mode 100644
index 000000000000..8e50cf7424be
--- /dev/null
+++ b/app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.9.1
@@ -0,0 +1,3 @@
+MD5 6591df8e9270eb358c881de4ebea1262 qemu-0.9.1.tar.gz 2804104
+RMD160 ee7bdb55a4540df2082d4bde9ebfd2f4e6f201a5 qemu-0.9.1.tar.gz 2804104
+SHA256 4756d0b4a4dc7dd88354bc6b37d381e4462dd328d0feef94803e90c0455835a5 qemu-0.9.1.tar.gz 2804104
diff --git a/app-emulation/qemu-softmmu/qemu-softmmu-0.9.1.ebuild b/app-emulation/qemu-softmmu/qemu-softmmu-0.9.1.ebuild
new file mode 100644
index 000000000000..f8438a1a578c
--- /dev/null
+++ b/app-emulation/qemu-softmmu/qemu-softmmu-0.9.1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/qemu-softmmu-0.9.1.ebuild,v 1.1 2008/01/25 14:47:19 lu_zero Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Multi-platform & multi-targets cpu emulator and dynamic translator"
+HOMEPAGE="http://fabrice.bellard.free.fr/qemu/"
+SRC_URI="${HOMEPAGE}${P/-softmmu/}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-alpha ~amd64 ~ppc -sparc ~x86"
+IUSE="sdl kqemu gnutls alsa"
+RESTRICT="binchecks test"
+
+DEPEND="virtual/libc
+ sys-libs/zlib
+ sdl? ( media-libs/libsdl )
+ !<=app-emulation/qemu-0.7.0
+ kqemu? ( >=app-emulation/kqemu-1.3.0_pre10 )
+ gnutls? (
+ dev-util/pkgconfig
+ net-libs/gnutls
+ )
+ app-text/texi2html"
+RDEPEND="sys-libs/zlib
+ sdl? ( media-libs/libsdl )
+ gnutls? ( net-libs/gnutls )
+ alsa? ( media-libs/alsa-lib )"
+
+S="${WORKDIR}/${P/-softmmu/}"
+
+pkg_setup() {
+ if [ "$(gcc-major-version)" == "4" ]; then
+ eerror "qemu requires gcc-3 in order to build and work correctly"
+ eerror "please compile it switching to gcc-3."
+ eerror "We are aware that qemu can guess a gcc-3 but this feature"
+ eerror "could be harmful."
+ die "gcc 4 cannot build qemu"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ # Alter target makefiles to accept CFLAGS set via flag-o.
+ sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
+ Makefile Makefile.target tests/Makefile
+ # Ensure mprotect restrictions are relaxed for emulator binaries
+ [[ -x /sbin/paxctl ]] && \
+ sed -i 's/^VL_LDFLAGS=$/VL_LDFLAGS=-Wl,-z,execheap/' \
+ Makefile.target
+ # Prevent install of kernel module by qemu's makefile
+ sed -i 's/\(.\/install.sh\)/#\1/' Makefile
+ # avoid strip
+ sed -i 's:$(INSTALL) -m 755 -s:$(INSTALL) -m 755:' Makefile Makefile.target
+}
+
+src_compile() {
+ #Let the application set its cflags
+ unset CFLAGS
+
+ # Switch off hardened tech
+ filter-flags -fpie -fstack-protector
+
+ myconf="--disable-gcc-check"
+ if use alsa; then
+ myconf="$myconf --enable-alsa"
+ fi
+ if ! use gnutls; then
+ myconf="$myconf --disable-vnc-tls"
+ fi
+ if ! use kqemu; then
+ myconf="$myconf --disable-kqemu"
+ fi
+ if ! use sdl ; then
+ myconf="$myconf --disable-sdl --disable-gfx-check"
+ fi
+ ./configure \
+ --prefix=/usr \
+ --enable-adlib \
+ --cc=$(tc-getCC) \
+ --host-cc=$(tc-getCC) \
+ --disable-linux-user \
+ --enable-system \
+ ${myconf} \
+ || die "could not configure"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make install \
+ prefix="${D}/usr" \
+ bindir="${D}/usr/bin" \
+ datadir="${D}/usr/share/qemu" \
+ docdir="${D}/usr/share/doc/${P}" \
+ mandir="${D}/usr/share/man" || die
+
+ chmod -x "${D}/usr/share/man/*/*"
+}
+
+pkg_postinst() {
+ einfo "You will need the Universal TUN/TAP driver compiled into"
+ einfo "kernel or as a module to use the virtual network device."
+}