summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-01-03 18:08:34 +0000
committerMichael Januszewski <spock@gentoo.org>2008-01-03 18:08:34 +0000
commit42e194fa42160be01321fee14d1ecc3c2317468a (patch)
tree046c6d9bd7ac1cc31c152f3c1a03f7ef753c1648 /app-emulation
parentMarking ghostscript-gpl-8.61-r1 ppc64 for bug 202217 (diff)
downloadgentoo-2-42e194fa42160be01321fee14d1ecc3c2317468a.tar.gz
gentoo-2-42e194fa42160be01321fee14d1ecc3c2317468a.tar.bz2
gentoo-2-42e194fa42160be01321fee14d1ecc3c2317468a.zip
Version bump.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/uade/ChangeLog9
-rw-r--r--app-emulation/uade/files/digest-uade-2.093
-rw-r--r--app-emulation/uade/uade-2.09.ebuild38
3 files changed, 48 insertions, 2 deletions
diff --git a/app-emulation/uade/ChangeLog b/app-emulation/uade/ChangeLog
index 9c6091831822..0f3c2b089ff8 100644
--- a/app-emulation/uade/ChangeLog
+++ b/app-emulation/uade/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/uade
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/ChangeLog,v 1.46 2007/07/10 22:38:07 spock Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/ChangeLog,v 1.47 2008/01/03 18:08:34 spock Exp $
+
+*uade-2.09 (03 Jan 2008)
+
+ 03 Jan 2008; Michał Januszewski <spock@gentoo.org> +uade-2.09.ebuild:
+ Version bump.
*uade-2.07 (10 Jul 2007)
diff --git a/app-emulation/uade/files/digest-uade-2.09 b/app-emulation/uade/files/digest-uade-2.09
new file mode 100644
index 000000000000..a63717e5feb8
--- /dev/null
+++ b/app-emulation/uade/files/digest-uade-2.09
@@ -0,0 +1,3 @@
+MD5 8f49cd3e99e91d58ace7bffde878f6fc uade-2.09.tar.bz2 2761783
+RMD160 231a6fbea46d4f84c09166c24f09c1b4c9c7f033 uade-2.09.tar.bz2 2761783
+SHA256 192764b2a61fefd61cd34be2d004e20c7e4840378b96e34ba4d9f152f382104b uade-2.09.tar.bz2 2761783
diff --git a/app-emulation/uade/uade-2.09.ebuild b/app-emulation/uade/uade-2.09.ebuild
new file mode 100644
index 000000000000..432df94273f3
--- /dev/null
+++ b/app-emulation/uade/uade-2.09.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-2.09.ebuild,v 1.1 2008/01/03 18:08:34 spock Exp $
+
+inherit eutils
+
+DESCRIPTION="Unix Amiga Delitracker Emulator - plays old Amiga tunes through UAE emulation and cloned m68k-assembler Eagleplayer API"
+HOMEPAGE="http://zakalwe.fi/uade"
+SRC_URI="http://zakalwe.fi/uade/uade2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="audacious"
+
+RDEPEND="media-libs/libao
+ audacious? ( >=media-sound/audacious-0.2 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --package-prefix="${D}" \
+ $(use_with audacious) \
+ --with-uade123 \
+ --with-text-scope \
+ --without-xmms \
+ || die "configure failed"
+ emake || die 'emake failed'
+}
+
+src_install() {
+ make install || die 'make install failed'
+ dodoc AUTHORS ChangeLog doc/BUGS doc/PLANS
+ doman doc/uade123.1
+}