summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-01-30 00:21:06 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-01-30 00:21:06 +0000
commit43ee41e10b976bdc05ef51eaf1398193547dd958 (patch)
tree5cde565349a38ac52ce42e4466a1cce6ec05c261 /app-emulation
parentBumping to 20090129 (diff)
downloadgentoo-2-43ee41e10b976bdc05ef51eaf1398193547dd958.tar.gz
gentoo-2-43ee41e10b976bdc05ef51eaf1398193547dd958.tar.bz2
gentoo-2-43ee41e10b976bdc05ef51eaf1398193547dd958.zip
Version bump to fix bug #250677. Keyworded ~amd64.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/aranym/ChangeLog11
-rw-r--r--app-emulation/aranym/aranym-0.9.7_beta.ebuild58
2 files changed, 66 insertions, 3 deletions
diff --git a/app-emulation/aranym/ChangeLog b/app-emulation/aranym/ChangeLog
index 35d1d6ae0bc1..cc06867adc5a 100644
--- a/app-emulation/aranym/ChangeLog
+++ b/app-emulation/aranym/ChangeLog
@@ -1,13 +1,18 @@
# ChangeLog for app-emulation/aranym
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/ChangeLog,v 1.13 2007/12/25 12:12:56 phreak Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/ChangeLog,v 1.14 2009/01/30 00:21:06 dirtyepic Exp $
+
+*aranym-0.9.7_beta (30 Jan 2009)
+
+ 30 Jan 2009; Ryan Hill <dirtyepic@gentoo.org> +aranym-0.9.7_beta.ebuild:
+ Version bump to fix bug #250677. Keyworded ~amd64.
25 Dec 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing dholm from metadata.xml as per #24623. Assigning to maintainer-needed.
14 Nov 2007; Robin H. Johnson <robbat2@gentoo.org>
aranym-0.9.4_beta2.ebuild:
- Fix $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/ChangeLog,v 1.13 2007/12/25 12:12:56 phreak Exp $ string.
+ Fix $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/ChangeLog,v 1.14 2009/01/30 00:21:06 dirtyepic Exp $ string.
15 Mar 2007; <dholm@gentoo.org> -aranym-0.8.6_beta.ebuild,
-aranym-0.9.0.ebuild:
diff --git a/app-emulation/aranym/aranym-0.9.7_beta.ebuild b/app-emulation/aranym/aranym-0.9.7_beta.ebuild
new file mode 100644
index 000000000000..aa9523508520
--- /dev/null
+++ b/app-emulation/aranym/aranym-0.9.7_beta.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/aranym-0.9.7_beta.ebuild,v 1.1 2009/01/30 00:21:06 dirtyepic Exp $
+
+inherit flag-o-matic eutils
+
+MY_PV="${PV/_/}"
+AFROS="afros812.zip"
+S="${WORKDIR}/${PN}-${MY_PV}"
+DESCRIPTION="Atari Running on Any Machine, is a virtual machine software for running Atari ST/TT/Falcon operating systems and TOS/GEM applications"
+HOMEPAGE="http://aranym.sourceforge.net/"
+SRC_URI="mirror://sourceforge/aranym/${PN}-${MY_PV}.tar.gz
+ mirror://sourceforge/aranym/${AFROS}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="opengl"
+
+RDEPEND="media-libs/libsdl
+ games-emulation/emutos
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_unpack() {
+ unpack ${PN}-${MY_PV}.tar.gz
+ cd "${S}"
+}
+
+src_compile() {
+ filter-flags -mpowerpc-gfxopt
+
+ use opengl && myconf="--enable-opengl"
+ if [[ ${ARCH} == x86 ]]; then
+ myconf="${myconf} --enable-jit-compiler"
+ fi
+
+ econf ${myconf} || die "configure failed"
+ emake || die "failed during compilation"
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_PROGRAM="install" install || die "installation failed"
+
+ dosym /usr/games/lib/etos512k.img /usr/share/aranym
+
+ cd "${D}"/usr/share/aranym
+ unzip "${DISTDIR}/${AFROS}"
+
+ find . -type f -perm -o+w -print0 | xargs -0 fperms o-w
+
+ sed -i -e "s|tmp|usr/share/aranym|g" "${D}"/usr/share/aranym/afros/config
+}
+
+pkg_postinst() {
+ elog "To run ARAnyM with AFROS type: aranym --config /usr/share/aranym/afros/config"
+}